USB to Ethernet adapter works with Reach M+ but not with M2

Hello all!

I have previously used several Reach M+ modules with Asix AX88772B based USB to Ethernet adapter used to establish network connection via Ethernet cable (exact assembly being Reach M+ connected with USB OTG cable to USB to Ethernet adapter and the adapter connected to network router with Ethernet cable). This configuration worked flawlessly and plug-n-play.

Now I got my hands on to some new Reach M2 modules and tested the same USB to Ethernet adapter with it. Didn’t work. Reach M2 could not use the said USB to Ethernet adapter to establish network connection. Is this because Reach M2 lacks the driver for the said adapter but M+ has it? Or is this issue related to some other difference between Reach M+ and M2 modules?

For example this thought crossed my mind: Does M2 still support USB OTG? The device documentation (https://docs.emlid.com/reachm2/) states that USB OTG cable would be supplied with the module, but the ones I received did not have USB OTG cable with them. M2 documentation further describes use cases where USB OTG cable is used but the fact that the cable was missing from the shipment made me doubt the presence of USB OTG support.

If the issue is related to a missing driver, then is it possible to install the driver to M2? If yes, then can anyone point me towards driver installation instructions.

This topic was already touched by this post: Reach M2 and ethernet adapter (post was already closed, so I could not continue it). In this post the suggested solution was a “feature request” for Emlid. I am looking for a solution that I could implement by myself without the need for waiting future software updates. The reason for uncompromising need for Ethernet connection is that Reach M2 modules are used in environment where lots of electromagnetic interface is present and wireless connections are therefore unreliable. Wired serial connection is also not an option since I need to access Reachview control panel occasionally, which can only happen through network connection.

Thanks in advance for helping me with this issue!

I did some further research by trying a different USB to Ethernet adapter. The adapter I found for testing was TP-Link’s UE200 (https://www.tp-link.com/uk/home-networking/computer-accessory/ue200/). Here is a picture of the setup (red Ethernet cable goes to the router and Reach M2 is supplied with 5V power):

This adapter worked without any issues. This was indicated by the following things (all the time Reach M2 was in hotspot mode and all WiFi-connections were disabled from Reachview):

  • Reach M2 was able to get correction data via TCP connection

  • I was able to connect to Reach M2 with Reachview application on my phone. The phone was connected to the network created by the router. Reach M2 was connected to this router with Ethernet cable and UE200 adapter.

  • Light on UE200 adapter blinked all the time during testing indicating Ethernet data flow between the router and Reach M2.

The fact that UE200 adapter (which is based on Realtek’s RTL8152B chip) works like a charm and adapter that is based on Asix AX88772B chip doesn’t work at all indicates, that Reach M2 does support USB OTG (which I doubted for no reason), has driver for UE200 adapter BUT lacks driver for Asix AX88772B chip.

Now I can narrow my question down to these two:

  1. Is it possible to install a driver for AX88772B on Reach M2? If yes, how?

  2. Is there any possibility that Reach M2 modules would have preinstalled Asix drivers in the future?

PS. @ corrado.steri, you might be interested about the fact that TP-Link’s UE200 USB to Ethernet adapter works plug-n-play with Reach M2.

Hi Simo,

Sorry for the delay. Could you please generate and share with me with Full system report when the Asix AX88772B adapter is plugged in?

I’d like to check whether it’s defined or not first. Also, if there is indeed no driver in Reach M2 firmware for such types of adapters, the report should help to place the proper task for our devs. After we thoroughly analyze all inputs, we can assess if it’s possible to fix it.

You can share the FSR in the ticket you sent. It might contain sensitive information.

1 Like

Hello Svetlana and thank you for your answer and noting this issue!

I have delivered the full system reports from 4 different cases (Reach M2 and Reach M+ with AX88772B adapter and with UE200 adapter) in the ticket I sent. The extra reports hopefully provide good reference information related to this issue.

I’ll stay tuned for updates from you.

I just want to share the conclusion that we discussed in emails.

It’s difficult to maintain support for a high number of drivers. Reach M2 indeed doesn’t have a driver for Asix AX88772B Ethernet adapters.

However, it works fine with UE200 adapters, and we’ll continue to support them. So, this can be a workaround in some cases.

Just want to thank Emlid for clarification regarding this matter. It is good to know the specific model of the network adapter Reach M2 supports. Hopefully this thread will serve as a time saving guide for someone pondering on the same questions as I did.

3 Likes