M2 USB0 ethernet adapter works in V2.22 not in v2.24?

Following this thread (USB to Ethernet adapter works with Reach M+ but not with M2) we tried hooking up a TP-Link adapter to our M2 modules.
The reason is we want to connect the USB0 port to a wired device and use the M2 as access point via its wifi connection.

This works perfectly for the No1 M2 (with 2.22 firmware). The device gets an IP address on USB0 ( and we can ping devices on the .6.x network while connected to the M2 wifi (the access point). However for the other M2 this does not work.

We get the following behavior:
M2 no1: Firmware 2.22 gets an IP address on USB0 from our DHCP server
M2 no2: Firmware 2.24 does not get an address.

A SSH session tells me:
nmcli device show:
GENERAL.TYPE: ethernet
GENERAL.STATE: 20 (unavailable)

Has there a change in the firmware causing this? Any help greatly appreciated

Hi @han,

Please, share the exact ethernet adapter model you use with your device.

Also, the Full system reports from both units would be of great help. You can email us at support@emlid.com with them since they may contain sensitive info.

Hi Svetlana - we are using the TPLink UE200. But we will test again, as soon as I get hold of another M2 module (the ones we had are already shipped to our customer). We tested without the GPS antenna attached, that might have an influence of the DCHP request as the M2 does not have a proper timestamp.

So I’ll get back to the issue ASAP

Hi @han,

Thanks! Please keep me updated.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.

Hi @han,

I think I have some updates to share with you :slight_smile:

We’ve recently run some tests with the TP-Link UE200 adapter and Reach M2. And everything worked as intended. So don’t hesitate to update your Reach M2 to the latest firmware version and try it out.