Supported USB to Ethernet Adapters for M2 and RS2

There have been several threads such as this one more than a year ago and this one around the same time together with this most recently covering the topic over the years (I found a thread from 2016).

I presume from the above threads that for example the TP-Link UE200 adapter (based on Realtek’s RTL8152B chip) is actually out of the box compatible with the M2 (and presumably RS2 also)?

Therefore (as there has been repeated/concerted interest), I was wondering if Emlid could please confirm which particular USB to Ethernet wired adapter**(s)** (if there is indeed more than just one make/model) they currently have built-in firmware driver support for - and if so, is this from any particular date/firmware revision?

Furthermore do Emlid have this “feature” on their development roadmap - to provide a (limited) supported subset of make/model of such USB-Ethernet devices? If not could it pretty please be added? :grinning:

4 Likes

Presumably if there is some level of support in receiver firmware for the Realtek RTL8152 chipset based adapters then this extends to the RTL815x family more generally?

I have ordered a relatively cheap adapter that has PD power delivery + 10/100/1000BaseT RJ45 support going to USB-C to test with. As far as I can tell it uses the Realtek RTL8153 chipset.

Hi @DirtyHarry,

I got your questions. I need a bit more time to clarify some details, and I’ll get back to you with an answer.

3 Likes

Hi @DirtyHarry,

Sorry it took so long to get back to you.

For now, we can surely say that Reach devices should work with Asix AX88772B USB-to-Ethernet adapters since we’ve tested this particular adapter ourselves. Some of our users indeed work with Realtek RTL8152B, but we can’t confirm that it works since we’ve never tested that.

I’ve noted your request for listing all supported chipsets. However, we need to test all of them thoroughly before sharing such a list with you and other our users not to mislead anyone.

1 Like

Hi there,

Just wanted to share our experience with the exact same issue. We have a set up where our Reach M2 are left in the field for a long period of time. There is Ethernet connection available but WiFi is either absent or impractical for our use case. It is important for us to be able to connect Reach M2 to internet using for instance an RJ45 cable. We power Reach through the JST-GH port.

Over the last months, we were unable to find any Ethernet adapter that would work with our recently purchased (Feb 2020) 4x Reach M2, which have had versions ranging from v22 to 26 over the duration of our tests.

Here are the adapters that we tested and which failed:

  • Tp-Link UE 200 (USB 2.0) (people reported this one used to work a few years back)
  • Tp-Link UE 300 (USB 3.0)
  • Tp-Link UE 330 USB 3.0 3-Port Hub & Gigabit Ethernet Adapter 2 in 1 USB Adapter. The USB hub LED is powered, but the LAN LEDs stay off.
  • i-tec USB 2.0 Fast Ethernet Adapter (runs the supposedly supported Asix AX88772B driver. We checked the asix.ko file and although the driver compiled, there are also a lot of errors listed in there…)

These last three adapters also failed. They have a Micro USB connector so that they can be plugged into the Reach M2 Micro USB port directly:

None of these 7 adapters weren’t even recognized (not showing up in lsusb).

The first four adapters listed above require a small USB-Micro to female-USB cable to make the connection with the Reach’s Micro USB port. We tested four different flavors of such cables, including USB-OTG, etc. None of them would work when combined with any of the adapters. However, these cables would work fine if one used them to connect for instance a USB stick. The USB stick would show up in lsusb and one would be able to access its contents from the Reach.

We also tried using three different models of routers (from different brands), on two different networks, without any success.

After abandoning any hope for Ethernet connectivity, we thought we’d use an LTE/4G Huawei wingle ( https://consumer.huawei.com/en/routers/e8372/ ) to create a local mobile hotspot and use the Reach’s wifi. Once we connected this wingle to Reach M2, it was able to recognize that device and communicate with it using an Ethernet connection (eth0) directly (the irony!). Of course the wingle itself then communicates over 4G/LTE. This was our replacement solution in the end.

While I primarily write this to save others some time and money, I also have a small hope that Emlid will take this (and the other posts on this topic listed by the OP) as a sign that some improvement in the support of Ethernet-based solutions would be most welcome :wink:

Best,
Vincent

5 Likes

Hi Vincent,

I can hardly say much regarding your tests with Tp-Link adapter models. As I said before, we haven’t tested them ourselves and couldn’t confirm if they work with Reach M2.

However, the i-tec USB 2.0 Fast Ethernet Adapter indeed seems to be based on the Asix AX88772B chip. So, that’s weird that it doesn’t work.

I understand that you already found a workaround. However, if you’d like to, we could check what went wrong with the i-tec USB 2.0. In case you want to investigate that, please email us at support@emlid.com with the Full system report from your unit.

I just got around to finally testing this adapter that’s been kicking around my drawer for months!

This is the actual Pro Signal branded adapter I bought. Having looked up the MAC address vendor, it appears that it is made under contract / white labelled by CE Link Limited. This is the OEM page for the adapter.

I’m pleased to report that it appears to actually work. It successfully connects at 1Gbps, obtains an IP address and reports its hostname correctly to the DHCP server/router. The Reach interface etc is all accessible as it is through the WiFi interface - both of which appear to be accessible on either IP address that they are assigned.

One peculiarity that I noticed, and I’m not 100G % sure yet whether it’s a limitation of the USB-C adapter or the Reach unit, but I can only use either the network interface via the USB-C or the power adapter. Appears that I cannot run both charge through the USB-C adapter and get ethernet connectivity at the same time. It’s either power or network - depending on what gets connected first/remains connected.

Looking at the status on the GUI I can see that its ether:

  1. “OTG Cable = Connected” and “Charger status = discharging” when the RS is connected to the wired Ethernet network
  2. When it is receiving power via USB-C then “OTG Cable = Disconnected” and “Charger status = Charging”

Can Emlid folks confirm if this is a device/port/chipset limitation on the Reach?

1 Like

I’m actually testing this as we speak and I can confirm these same results ,when the charger is connected it drops the Ethernet connection ,not sure why This is the unit Im using
USB C Hub QGeeM 12 in 1 Triple Display USB Type-c Hub USB C Docking Station with 4K Dual HDMI, 1080P VGA,100W PD, Ethernet,USB C to USB 3.0, Card Reader, USB-C Data Compatible with MacBook,USB C Dock
even if I am able to connect via ethernet it still for some reason is not connected to the internet…

2 Likes

Hi Dave

Nice to know its not just me then haha!

Just tried this adapter out on a Samsung Galaxy tablet and it pushes charge and talks Ethernet simultaneously. Must be a limitation on the Reach then I reckon.

1 Like

So this is what I haven’t figured out ,Router assigns Reach a ip address 192.168.1.135 but in the control panel it still at 192.168.42.1 , so its physically still not connected to the internet.Screenshot 2021-08-07 161156

1 Like

Looks like wired and wireless connections are on different subnets, that may be the root of your connectivity issue.

1 Like

The 192.168.42.1 is likely a static IP. Try to configure your routers DCHP to operate on 192.168.42.xxx instead, but tell it to omit assigned 41.1 to anything.

It could be something like that.

When I was testing my adapter last night, I could see it registered on my router/DHCP server. It obtained the next IP address in sequence after the IP address allocated to its WiFi interface.

The RS2 could be accessed by using either IP address, although only the WiFI obtained address was visible on the RS2 portal page.

Disabling WiFi on the RS2 could still access it fully from the wired network connection.

Yes that’s right ,reach can still be accessed through its hotspot and default IP and through the wired connection ( router IP) ,so why doesn’t it take the router IP or can could I change that it
does .maybe I’ll try @wizprod idea

As long as you can make a connection via the wired IP address, then that is what matters.

Although that IP is not displayed on the status page is probably down to some inherent limitation of the RS2 firmware.

Emlid could possibly confirm if that’s the case.

@svetlana.nikolenko

1 Like

This why I started testing because I want to use this for my permanent M2 base station so I don’t know if this will really work .power supply plus Ethernet in one unit

If Emlid can’t change the USB-C to be simultaneous Ethernet data and power input through a firmware update, then I guess the only alternative is to have a second cable connection to the RS232 port and provide power input via that.

@svetlana.nikolenko could you folks confirm whether it’s possible to have the USB-C port characteristics updated to support dual Ethernet and power input operation?

Secondly if the Reach panel/web interface can display the IP address if the RS2 is connected via an OTG Ethernet adapter on the USB-C? Many thanks

2 Likes

So actually it is connected to the internet :+1: :+1: :+1: just that you cant update the device through ethernet . And to confirm I tried another usb to ethernet https://ikling.com/product/ikling-9-in-1-usb-c-hub it looses the connection after connecting power

1 Like

Hi @DirtyHarry,

The setup is rather unusual, and it took some time to think about. USB-C port on Reach RS2 was initially designed only for charging. As we see, it also supports connecting Ethernet adapters. However, it wasn’t done on purpose. Working with an Ethernet adapter is possible because Reach firmware contains some drivers by default.

So, these limitations weren’t added on purpose either. It works that way since it wasn’t assumed that this port would be used for anything but charging. As I wrote above in the thread, we noted your feedback. If we decide to add full Ethernet adapter support, we’ll prepare the whole infrastructure for this. For now, I’d use the RS232 workaround you mentioned.

2 Likes

Hi Svetlana. Thanks for the update.

Perhaps having both power input and wired Ethernet is something you folks may wish to consider as a future feature, if it does not require major changes to the hardware. In my humble opinion it would be a very useful and market differentiating feature - especially if folks are using the receiver as a (semi) permanent base for corrections. I find wifi to bit a bit temperamental sometimes.

3 Likes