Reach Firmware 29 Beta 3 is out

Hello everyone!

We are pleased to announce the new Beta version of Reach Firmware - 29 Beta 1!

Here is a list of changes:

  • Added point markers into the RINEX log when collecting data with ReachView 3 - if you have RINEX logging enabled, collection start/stop events will be saved into the RINEX log
  • Supported encrypted protocols over TLS/SSL for some NTRIP casters
  • Changed restriction for device naming: the underscore character (_) is forbidden
  • Fixed some cases when the raw log can be suddenly restarted
  • Miscellaneous improvements

This update is available for Reach M+/M2 and Reach RS+/RS2.
Feel free to share feedback on new features!


We just updated all our receivers to v28.4, lol! You all are on it!


A post was split to a new topic: Logs for Stop & Go

Whoa! This is great. The right way forward and cant wait to test it out.

1 Like

What is this feature do?

Thanks. but does this feature add these markers on the stop and go occupations start and end?

1 Like

7 posts were split to a new topic: Connection to Caster issues

Hi @l3technologycambodia,

Quite literally, it records the point markers directly into the raw data RINEX log. :slightly_smiling_face: Some post-processing applications can work with Stop & Go by using the points from the raw log. You don’t need to have a separate CSV file in such cases.


Hi Guillermo,

Yes, it contains the records of the start and end times of the point collection.

good morning after updating my rs2 to version 29.1 the instrument flashes continuously and does not fix I tried to switch off and on but nothing changes the leds lights up to switch on and off

Just updated one of our M2’s this morning and cannot get it to stay connected to NTRIP. It gives me an error message and loses the mount point. I’ve tried reboots and resetting the NTRIP configuration.

Michael, I’ve deleted the full system report from the public view so that no sensitive info is leaked. Rest assured that we have downloaded it and will be looking at it with our devs :slight_smile:

1 Like

Hi @tedescostudio73,

Thanks for reporting!

I see that my colleague Kirill is already in touch with you regarding this issue over email. Let’s continue the troubleshooting there to keep all the details in one place.

I appreciate it!

7 posts were split to a new topic: Issue with logs recording on 29 Beta 1

Hi Michael,

We’ve checked the Full system report with the devs, and logs look fine overall. So, it’s pretty hard to tell why the issues with NTRIP happens at the moment. Can you connect to the NTRIP if you manually enter the mount point? Is it possible to double-check that the NTRIP service provides a stable stream? Do you have another NTRIP to check to understand if it happens with all connections or with a particular one?

Is this the post you were replying to? Once I get in I can manually enter the mount point and it will fix. The problem from this post is that I am unable to connect sometimes to the local hotspot of the M2. The RS2 is kind of flaky but after a couple of tries it hops on. I am able to connect to both via my WiFi network and even when I set the M2 back to hotspot it won’t connect. I reboot it and it jumps on the WiFi just fine but when I am in the field and don’t have my Verizon hotspot on I can’t connect.

I’m still having a ton of trouble trying to connect to the RS2 and M2 hotspots. Been sitting here for about 20 minutes now. I have to get this job done today! I have rebooted all hardware including my phone. I have also forgotten and reauthenticated with each Wi-Fi signal.

A post was merged into an existing topic: Issue with logs recording on 29 Beta 1