Connection to Caster issues

I noticed there is now an issue with getting NTRIP to start and talk between my base and rover with this beta firmware. Previously I could start the base, and go out and set targets, etc. while I wait for the base to launch. Then typically once it has launched my rover is already on and waiting and it gains fix. Twice now I have had to do a full reboot of my rover after the base launches to begin receiving corrections.

1 Like

Hi @dbuchanan,

Thanks for reporting!

Is it possible that there is some issue with the Internet connection? Maybe, the connection is intermitted, and the rover can’t receive the stream of corrections.

Does this behavior change if you roll back to the stable version? It’s important to understand if it works differently in the same conditions and with the same settings.

1 Like

I am going to roll it back today and let you know.

1 Like

Just to follow up, rolled back to the previous firmware and there are zero issues.

2 Likes

I just want to say I think my hardware is now having this same issue with the latest 29 firmware. I only this morning upgraded from the 28.4 firmware I was on when I last had this problem. Either that or the Emlid Caster service is down.

1 Like

@liudmila.slepova Can I send you the logs from my Base?

I cant get past the Reach setup to get back to my old firmware which worked. Its forcing it to go to the latest firmware which did not work for me. Please help, as I need these functioning to complete a few jobs.

1 Like

In order to get it to work, here are the steps I had to do.

NTRIP via Hotspot alone DID NOT WORK.
To get NTRIP to work, I had to connect using Bluetooth (NTRIP over Bluetooth then became available).
Once connected to bluetooth, it would disconnect almost immediately.
The only fix I found to keep it from disconnecting, was to:

  1. Leave my hotspot on (even though I was connected via Bluetooth)
  2. As soon as the receiver connects via Bluetooth, tap on settings

It seems like for this unit, once I tap on settings, it stops disconnecting it from Bluetooth. I have no idea why this is, and I never had to jump through this many hoops when it was 28.4 firmware. For now, I will have to leave it alone because I need them for work!

LMK if you would like me to send logs, and maybe figure out why this is happening?

1 Like

I have experienced similar results with my RS2

Hi @dbuchanan,

Am I getting it right that you’re connecting to our Caster? Do those disconnections happen only with the base receiver?

Via lora no it does not happen. But lora will not work on urban environments here in the states hence why I need ntrip. I think it’s twofold. I even swapped the base and rover units (base is now rover, and rover is now base) and it’s not just a one unit issue.

There seems to be issues with NTRIP and Bluetooth maintaining connection. When I return I will send logs.

Just to follow up, it looks like at least the bluetooth connectivity is related to Android OS 13. We tried the bluetooth connection and hotspot via iPhone iOS and it worked without issue. No idea what could have changed between Firmware that prevents Android OS 13 from working with it okay now.