Reach Firmware 29 Beta 3 is out

A post was merged into an existing topic: Issue with logs recording on 29 Beta 1

Hi Michael,

Right, I mean that post. We were checking the issues with the NTRIP connection mainly.

Regarding the issue with the hotspot, when has it started? With 29 Beta 1 update particularly? Have you tried to connect via a different device to understand if it works the same way?

1 Like

The receiver hotspot issue started with 29 beta 1. I have tried two different phones but both were on Android. I am not sure if this is absolute or not but I can sometimes connect after forgetting the network and then re-authenticating. This has been a trick that I’ve used for a long time but it continues to happen now. Here is what I’m getting in the correction input settings.

I PM’d you my system report.

I rolled back to 28.4 and It fixed. However, just an FYI for anyone else that rolls back, you might lose everything.

1 Like

So it seems that it will stay fixed for about 3 to 5 minutes and then it went back to single. I checked my internet connection and my Wi-Fi connection to the Rover and everything looks okay. Ntrip says it’s connected but no fix.

Once I lost the fix it has not come back. NTRIP still says connected but I have no base station satellites. Just PM the new system report from 28.4.

I reset the settings to default on the RS2, went back through configuration and achieved a fix. I will test it again in a little while and hopefully it sticks.

Michael,

Thanks! I’ve already passed the reports to the devs. We’ll dig into it.

2 posts were split to a new topic: Clear memory on Reach

Thank you very much. I think I have isolated my Rover’s problem with fixing after the rollback was due to the hotspot on my phone. I connected it to a different hotspot today and it is getting a fix fairly quickly. It does seem like I am having to forget and reauthenticate the Wi-Fi connection to the receiver whether it be through my hotspot or to the receiver hotspot.

I am going to roll it back today and let you know.

1 Like

Hi there,

Firmware 29 Beta 1 knocked my RS2 out like LL Cool J.

It was the first time I had to use an external computer to restore a previous firmware.

Battery was 75%, no power outages, etc.

Any ideas what could have caused this?

The unit entered a perpetual boot cycle. I left it for one hour, had my good old sledgehammer with me when coming back, but then found a thread dealing with resetting the device. :sweat_smile:

Cheers

Buddy

2 Likes

Different symptoms but we had to roll back to the 28.4 version.

2 Likes

Hi Michael,

We’ve found an issue with the correct mount point fetching. This explains why you could get FIX when entering the mount point manually. We’ll fix this in the future release. Thanks for drawing our attention to it!

Regarding the intermitted work of the hotspot, it’s a bit of a mystery now as we couldn’t repeat it so far. But we’ll try to check this with more devices.

1 Like

Hi Buddy,

Thanks for reporting! I hope RS2 did not get hurt :sweat_smile:.

Do I get right that the receiver’s LEDs were in continuous loading, and RS2 could not boot completely?

That’s great, thanks for everyone’s efforts.

Just to follow up, rolled back to the previous firmware and there are zero issues.

1 Like

Horrible day today and off the bat I will say that I think a lot of it has to do with Verizon’s crubling network in our area. I had no more than 2 bars all day on 4G or 5G and while the NTRIP would login it kept telling me it was waiting on corrections. There are several things that I have had to do on V28.4 since rolling back that are all related to connectivity in some manner. I am having to forget and reauthenticate with networks, kill the Reachview 3 app and reboot the RS2 in order to get it to change from the Reach hotspot to my mobile hotspot. II can tell it is on the mobile hotspot because the Reach hotspot disappears as an option but it is taking at least 10 times every session to get it to show up as an available receiver. Once it finally decides to show up it operates as normal, NTRIP looks good but the receiver stays in single.

If I can get on the internet with another device connected to the mobile hotspot shouldn’t that be enough bandwidth to stream corrections? It feels like Reachview has some authentication and network switching issues.

1 Like

Hello everyone!

Today we’ve released the new Beta version of Reach Firmware - 29 Beta 2!

Improvements:

  • Improved stability when working over external LoRa module on Reach M2
  • Added the 14Hz rate selector for the NMEA position output on single-band receivers
  • Improved battery charge estimation on Reach RS2
  • Increased the number of supported BeiDou satellites for multi-band devices
  • Added SBAS selection to the raw RINEX logging settings

Fixes:

  • Some issues with unavailable log files
  • Getting NTRIP mount points for some casters
  • Some cases when the LoRa frequency settings cannot be applied due to regulatory restrictions
  • Alignment of the Base corrections label on the Logging tab
  • Hint placement about included RINEX header for Reach RS2 in the raw log settings
  • Faded Updates section on repeatedly opened Updates panel
  • Raw data debug setting for logging

This update is available for Reach M+/M2 and Reach RS+/RS2.

14 Likes