PPK base log for PosPac UAV

I am trying to use log file form base RS2+ in Pospac UAV application. I get info from Applanix that log file is not compatible because to combine two datasets base station should be set to full seconds. I tried 5 Hz setting and 1hz setting in GNSS settings and that didn’t help. How can I set the RS2+ to log data in full seconds. There is similar thread here but there is also no solution.

Hi, you can try this if you activated the UBX log in addition to the RINEX.

1 Like

Hi sorry but this information are new to me and I am not an expert in GNSS data. So I shuld set in log to “Backup source data for Rinex” ? and next put those files to Emil Studio and convert them ?

Yes, this is the way :slight_smile:

1 Like

Which version of Reach Firmware do you have? Starting from version 30 all Rinex logs, recorded on Reach are adjusted to full second and should work with PosPac.

Yesterday I upgraded to 30.1 earlier it was 30…

And you have taken Rinex straight from Reach to PosPac without any conversions in between? Could you please send the RINEX in question to support@emlid.com and link to this topic? We will check it and see if it indeed is not aligned to a full second, because it should be.

1 Like

Yes I put this file directly to Pospac and I get an error. I will send this file to support@emlid.com

The file the you have provided is recorded on full seconds, so no issue there. What I noticed though is that it is a very short file, just 7 minutes and the signal quality is not that great. Maybe you just recorded it for testing?

I recommend recording a longer file with a good sky view in an open area an trying again.

You can open the .23O file in any text editor and see that the epochs are recorded on full seconds.

Ok thanks for clarify that. Yes I recorded it only for testing. Do you think If I will test longer and record base position for 15 minutes. This Processing error during Compute RTX will not show ?

To be honest, I have no personal experience with PosPac, so I am just guessing here. Most likely PosPac can’t see enough “good” observation and is showing this error. If you provide it with a better data quality it might work. Try a longer recording in a more open area, so that you capture more good data and give it another shot. If it doesn’t help, come back and we will think of something else.

1 Like

So I should set in base options to average data for more than 5 minutes ? For example for 15 minutes ? Thanks for help. That’s great that you have so informative forum :slight_smile:

Hi Miron,

I remember a similar thread about using Reach RS2 as a base station in POSPac. Once we added a line with leap seconds to navigation files and made the epochs’ seconds integer, everything started to work like a charm.

So I agree with Igor’s suggestion. I’d record a 1-hour log in an open sky area and try to upload it to POSPac.

Averaging the data in the Base settings is needed to configure the base for RTK. For PPK, it’s not needed, so you can go straight to Logging.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.


This message is in case anyone stumbles upon this thread. We have tested a handful of datasets and came to the conclusion that the “Unable to start order” error disappears after you trim the beginning of your log. Following this, we have created a guide - Using Reach RS2/RS2+ base station for YellowScan LiDAR systems.

In case there’s still an issue, please start a new thread or email us at support@emlid.com, and we will check it.

1 Like