Navio2 with second GPS module

Sorry to reopen this thread but I tried adding an extra GPS module but wasn’t able to make it work. Hereis how I am trying to do it

  • I am using a GPS module based with the Ublox Neo-m8n chip and I am connecting it via the UART port

  • My etc/default/arducopter is as follow:
    ARDUPILOT_OPTS="-A udp:192.168.1.29:14550 -E /dev/ttyAMA0"
    I am not using radio telemetry so I removed the -C option.

  • I’ve set the mission parameters GPS_TYPE2, GPS_AUTO_SWITCH and SERIAL4 as instructed.

Any ideas what may be going wrong?

Hello,

Some changes since 2017:

/etc/default/arducopter is now like this:

Capture d’écran 2021-02-05 à 17.03.24

Before plugging GPS to UART Navio2 port, I checked configuration with UBlox utility and adjusted UART serial speed at 57600 and other parameters according to my need (I do not use GPS_SAVE_CONFIG option). I use the same method for the Navio2 GPS (ublox utility).

Serial 4 is set at 57600 (same as M8N UART speed) and protocol at 5 (GPS)

Capture d’écran 2021-02-05 à 17.10.04

After reboot, GPS2 is identified and data displayed

Capture d’écran 2021-02-05 à 17.11.27

Satcount for GPS 1 AND 2 can be checked in status window

What can be wrong:
UART serial speed of GPS different from Serial 4 speed,

Inversion of RX and TX line on the GPS unit

Thanks for the fast reply.

I managed to connect the second GPS. My RX and TX ports were inverted since I thought they were supposed to be connect directly instead of inverted.

However I am receiving the message “unhealthy GPS receiver” in mission planner. Any ideas why?

Another thing. Why did you change the baud rate of the second GPS? At the moment I am using the baud rate of 38400 as instructed by our old post.

Thanks again for the support

38400 was a remain of “old APM time” with M6N GPS generation. Now, M8N is able to process GPS and Glonass at 5 hz with NMEA and UBX data flow. Setting UART at 57600 or 115200 with M9N is quite common when board is able to do it.

Hi Pedro,

When you get this message in Mission Planner, it’s essential to review your copter’s hardware setup. Please check that the receiver is placed far from the other electronic components. The proximity to electronics might affect the reception of the GPS signal.

I also suggest taking a look at this thread where you might find some tips for resolving this issue.

I see.

I managed to connect the to the second GPS using ublox u-center and a UART-USB conversor. In u-center the baud rate is initialed listed as 9600 which I found it odd since I was using 38400 in the SERIAL4_BAUD parameter. Nevertheless I manage to change it to 57600, however once I connect to mission planner it says on the "messages"tab that the detected baud rate is 115200 (which also happened in one of your images). Do you know what is happening?

Apart from this minor inconsistence the external GPS appears to be working fine and I was able to fly the drone in loiter mode without much issue. On other hand the internal GPS of NAVIO2 still appears to have some problems, since I keep getting the “Unhealthy GPS Signal” if it is active.

The copters hardware seems to be alright I am mounting both GPS’s on an elevated antena and putting a metal plate bellow it. At the moment I have the copter disassembled but once I assemble it back I will take a picture.

The problem seems to be the delay between messages from the GPS, where the NAVIO2 unit can’t keep up with the 200ms threshold. See the image bellow where I plotted the “GPA Delta” field from both GPS units. Any ideas what is happening? Thanks gps_comparisson

I will also check the thread you suggested. Thanks.

I’m also experiencing the uneven rates on Navio2 GPS with the “unhealthy” message on ardupilot 4.0.3.

Can you fly with only the Navio2 GPS ? because I surely can’t.
How did you get this cute graph ?

I found how to get the graph it’s GPA.Delta in a log.

No, I can’t fly in Loiter mode using the Navio2 GPS. Crashed a few times trying to do it though…

As you mentioned bellow the data is available on GPA.Delta in the flights log. The graphic was made in MATLAB.

Good news I found a fix for the rate and therefore “unhealthy gps signal”.

Navio’s GPS continues to be unusable though. Would you be kind enough to try your Navio’s GPS in Loiter to see if it works on your setup after the fix ?