Unhealthy GPS Signal?

Hi

I’m using the latest emlid raspbian image with ArduCopter 4.0.3 and Navio2.

I’m having trouble with GPS, receiving an Unhealthy GPS Signal warning/error
But the GPS has a 3d fix with 10+ satellites and HDOP under 1?

What are the effects of this error, and how do I get rid of it?

Hi there Jacob!

Unhealthy GPS I believe means the refresh rate of the GPS is under 5 Hz. Are you by chance SSH’ing into the drone while receiving this ‘Unhealthy SSH’ signal?

I remember I had this on mine as well. Is it possible to check the refresh rate at any time?

Hi

I’m not using SSH.
I just have the drone connected with a 3DR radio to my laptop.

Hi Jacob,

Could you post here the photos of the hardware setup?

The GPS antenna is on the wooden plate on the left and the antenna on the right is telemetry.

I’ve just been out in the field and done some testing.
Now I have a problem that sometimes when I boot the drone,
Mission Planer will report GPS: No GPS

So maybe there’s a hardware problem?

Hi,
You’ve got your GPS antenna directly between two ESC’s. ,not a good idea.
GPS signal is very weak. Like trying to see a single 40W light bulb from space ! So in order to make it work well it is important to
a) keep antenna away from any source of interference (best to avoid all other electronics and even the main wiring as it also will create a magnetic field during flight)
b) Point antenna up without anything over it ( Like in your setup would have to mount it on top mounting bracket, not underneath.
c) ensure antenna has best exposure to surroundings (Not like in your setup where only a small section on one side can receive the GPS signal. - GPS Satellites are constantly on the move. So some of them may be low on the horizon whilst others can be right above at certain times of the day. - Just have a look at this: https://in-the-sky.org/satmap_worldmap.php
d) Best is to have antenna raised above everything else in order to get best reception. There are many photos out there showing antenna mounted higher than everything else on drone.


e) There is also recommendation out there to shield antenna from interference from underneath by applying some metal plate, copper or alloy tape.

So in your case I would reverse setup. - Move telemetry antenna down and GPS antenna up high. But definitely not both at same height / level.

1 Like

I switched to another telemetry radio I had laying around and put the GPS antenna on a mount.

Now I have 3D Fix indoors, but EKF is marked red?

I can see the problem:
The antenna of your telemetry radio is sending RF signal right into the Navio2 which has got all the sensors. By simply facing the antenna downwards it should solve the problem. It also makes much more sense to have the antenna of the telemetry system and also of the wireless camera (if installed) facing down as the signal needs to go down to your ground-station during flight. No point of sending it up into the sky.

Hi

I’ve tried placing the telemetry antenna downward in various positions but still EKF is red.

At first MP says No GPS and then EKF is white, but when GPS turns on it turns red.

After having another look at your photo I’ve noticed cable from GPS antenna running across control unit. Try placing it differently.
Also in Mission Planner when you get the red EKF warning you can click on it and it will show you what the actual problem is. I suspect it is compass related. Has compass been calibrated ? Any magnetic field close by? Move drone outside and check readings. Another thing I’ve noticed is the control unit appears to be mounted with cable ties. …bad idea. It should always be mounted with some form of anti vibration system / mount. I.e. the Navio2 recommended mounts, or a thick double sided foam tape.
…Ahhh, can see those speakers close by. That would do it. They have big magnets in them. As mentioned before, try it outside away from any magnetic source.

I just tried testing outside.
It seems the culprit was to high HDOP

After the system has been on for about 20sec I now have 3D Fix and white EKF :slight_smile:

1 Like

Pleased to hear.
Have fun.
…and safe flying.
:slightly_smiling_face: