RS2 bluetooth connection loss on Samsung TabActive

Hi,

We currently have major problems in communication between the Emlid Reach RS2 and the Samsung tablets of the TabActive 2 and TabActive3 series used by our customers.
Apparently as a result of the last update of the Samsung operating system, we have failures in Bluetooth communication. The RS2 is recognized and can be paired, but if a Bluetooth connection is established by the app in order to consume the NMEA data, this connection is interrupted after a few seconds.

We were able to simulate the problem on both the TabActive2 and the TabActive3 with an RS2 (firmware 27) and an RS2 (firmware 27.1). However, the same tablets have no problems using the NMEA data stream from other GNSS receivers.
We also tested the communication with an older tablet (with older Samsung operating system). This communication works fine.

Has anyone encountered similar problems here? Or ideas for a solution. Due to security policies, most customers rely on installing the latest updates or, based on the number of problem reports that have reached us, have already done so.

Best regards,
Tilman Jahn
TOPO graphics

Hi @jahn,

I see the same request in the email.

Let’s continue our conversation there. The troubleshooting procedure may require sensitive information about the units.

2 Likes

Hi @jahn,

We are having the exact same issue with the TabActive3.
Interested to hear if anyone has solutions.

1 Like

@jahn @andrew.belov

I was able to downgrade the Samsung October firmware to July firmware and the connection issues are fixed.
I used the following video for instructions on downgrading. It is in Pakistani but was able to follow his screen.

hi, this coincides with our observations that the problem appears on devices with Samsung’s October update. Devices with the firmware version July 2021 do not appear to be affected.

I have the same problem on my Active 3 trying to link TcpGPS to RS2 over bluetooth.

A workaround I have is to connect Activ 3 to RS2 and when it fails then connect my Samsung S20 to RS2 using trial version of TcpGPS. When this is established I disconnect and the Activ 3 maintains connection.
I know this is a pretty dodgey way around but it may get you out of a tight spot until a fix is found.

If this is a bit vague I’ll do a short video

We did some further research on this issue. Regarding our experience there seems to be a workaround for some Samsung devices:

  1. clear cache and data of the system app „bluetooth“ and force the app to stop
  2. restart tablet
  3. disable bluetooth
  4. once again clear cache and data of the bluetooth app
  5. unpair all devices
  6. pair RS2
  7. use NMEA-data from RS2

Up to now, this procedure seems to work for Samsung Active Tab2. For Active Tab 3 this procedure did not work on three tested devices.
It also seems to work for Samsung Tab A. Thanks to @andrew.belov for testing!

Maybe this will help some of you!

Hi @andrew.belov

I had this problem approx. 2 month ago when I first updated an active tab 3 to the oktober update. I also had to downgrade and since then I advise our customers not to upgrade the firmware of the samsung tablet.
As an app we use QField. I had this problem only when working in QField. In QField ~10 seconds after connecting to RS2 it disconnected again. I always thought QField is having problems with the changed bluetooth stack (yes, I think google or samsung messed up something in the bluetooth stack. So far I could not find out what the did) but apparently the problem seems to be earlier in the communication. At least this is what I understood from @jahn research.
I know of another app producer having the same problem. I asked him what they did to fix the problem. He wrote: “… A workaround in the app that improved the situation was to set BLE to High Priority when connecting. …”. So maybe this hint helps your dev team.
Can you please keep us updated on this issue. I can not hold back our customers not to update the tablet software for ever.
Best reagards Roland

Roland,

Thanks for your valuable feedback!

Quite an interesting note about BLE. I’ll pass your findings to our developers.

Sure thing, I’ll provide an update as soon as I have any news.

Hi Andrew,

do you have any news?

Best regards!

Hi @jahn @Rondal @noel @apg,

We released a new firmware version, V28.1, with improved Bluetooth connection stability.
You can download and test it with your devices.

Any feedback is much appreciated!

Hi Andrew,
I am just back to office after holidays. Is this an official firmware version or do I have to switch to Beta channel for update? Just tried to update our RS2 (still using Version 27) but it keeps saying “You are up to date”?
edit 2022-01-04:
Using the flashing tool (Mac OS 12.1, Flashing Tool v1.7.1) also failed. I have tried v27.1 and v28.1 Both updates failed. Any idea?

edit 2022-01-05:
I managed flashing the new firmware using a windows computer. Although the tool said “flashing failed” the new firmware was installed and I could start the RS2. I will continue testing the next days.

Best regards

Hi @andrew.belov

Finally I was able to test the new Firmware Version 28.1 on a samsung galaxy active tab 3.

  1. I had to reflash the samsung tablet to enable automatic updates again (This feature got lost because I did not add the CSC file when I did the downgrade in the first place). I just want to say that I did the test with a fresh installation of the tablet.
  2. I updated the samsung tablet software to the december 1st system update. (Basebandversion is T575XXU3BUL2)
  3. I was able to pair the RS2 with the samsung tablet. Strangely it did not ask for the paring password!? Do you know why?
  4. I installed the latest qfield app.
  5. In the qfield app, after a scan, the reach bluetooth device (RS2) was visible for selection.
  6. I was able to connect to reach bluetooth device. The samsung tablet showed a popup asking me if I want to pair.
  7. After hiting ‘pair’ the qfield app showed the RS2 as connected.
  8. After ~10 seconds the qfield app disconnected again.

Result: The behavior is still the same like it was with previous firmware versions of the RS2.

Can you do the following:
If you don’t have purchase a Samsung Galaxy Active Tab 3 and repeat the steps above.
The goal is to find out if the problem is the RS2 or the qfield or both.

Again, everything works with the july1st system version of the samsung tablet.
If you want we can shedule a remote meeting where I can try to demonstrate the problem.

Best regards
Roland

1 Like

Hi @andrew.belov

I asked again the guys, who suffered from the same/similar problem, what they did on the hardware side. This is what they did:

“This was a very chipset specific fix. We needed to extend the start-up time of the internal DC-DC converter. The chipset was an ST Blue-NRG1”

Please forward this information to the dev team.
Best regards Roland

Someone else is having the same problem with another samsung tablet. See this topic: RS2 not connecting to Samsung Tab A& through Bluetooth

Hi @jahn,

Happy New Year!

Due to the holidays, I was unable to answer you in time. Sorry for that!

It sounds like your unit wasn’t connected to the Internet at that time. That is why it didn’t see any updates. The release is stable and doesn’t require a beta subscription.

If you face such behavior of the updater again and the unit is connected to the Internet, please let me know.

When the flashing fails, please send us a flasher report to support@emlid.com. It helps to diagnose possible causes of the procedure’s failure.

If you already have the results of your tests, please share them with us.

Hi @andrew.belov,

although it is somehow of topic:
the unit was connected to our local wireless lan. Internet connection was available since the unit received NTRIP correction data meanwhile.
I have tried update via Reach App on two RS2 devices and a M2 device, using v27 or v27.1. None of these advertised a new firmware version. I have flashed all devices using a windows computer. Transmitting the firmware worked fine, automatic reboot failed. Thus, the flash utility responded with failed. Disconnection the devise and manual rebooting the device worked fine.

Up to now I do not have any new results due to a lot of other tasks to do. sorry.

Hi @Rondal,

Thanks for the thorough tests and report!

I’ve passed your findings to the team.

From our side, I can tell that we’re still examining the issue.

Our tests of V28.1 with available Android devices in the office were successful. Therefore, we decided to buy one of the Samsung Galaxy Active Tab 3 to reproduce the issue with the exact hardware. We’ve succeeded in reproducing the behavior.

Right now, our devs are looking for possible solutions from the Reach devices’ perspective. I’m following the progress and will let you know once I have any updates to share.

2 Likes

@jahn,

Thanks for the details!

That sounds interesting. Let’s track this behavior. If it repeats again, please share the full system report from the unit to support@emlid.com

The Flashing Tool can show the flashing failure if the automatic reboot fails or takes too long. However, the flashing procedure is usually completed in such cases. The unit can be manually rebooted with the fresh firmware installed.

Ok, thanks for letting me know!

A post was split to a new topic: BT issues with RS2