RS2 not connecting to Samsung Tab A& through Bluetooth

I have successfully paired the RS2 to my phone, Samsung S10,E in ESRI Field Mapping, so I know that it is possible. When I try to connect to my Galaxy Tab A7 the connection keeps dropping. I Lefebure NTRIP Client and I can see the connection between the tablet and the receiver connect and drop over and over. The tablet paired with the receiver no problem, they just won’t stay connected. I have seen earlier threads from people having similar issues, I joust don’t see any resolution to the issue. Any help would be greatly appreciated.

Hi Sam,

I’ve messaged you in the direct support ticket. Let’s continue troubleshooting there as it may require an exchange of sensitive info.

How do I get to the direct support ticket.

I meant the email you sent to us. :slightly_smiling_face:

OK. I really think the issue is with our tablet. I tried to connect to the arrow gold system that we have and I got the same result.

Hi @samhottinger @liudmila.slepova

This sounds exactly like this problem here: RS2 bluetooth connection loss on Samsung TabActive .
Yes, I think these problems are comming from an update of the system software introduced by google or samsung. The question is on what side can the problem be solved. In the firmware of the hardware (in this case an RS2) or on the app side or both.
So I would like to see an in deep investigation lead by emlid to find out how to solve the mess Samsung or Goolge has made with the latest updates. @samhottinger The last working system software on a Samsung Galaxy Tab Active 3 was the July 1st 2021. What system software version do you have on your tablet? If you want to make your Tab A work again I’m almost sure you need to downgrade the system software on your tablet to the last know working one. You can find information on how to downgrade for example here https://www.sammobile.com/ and google for ‘odin firmware installation’. @liudmila.slepova Please keep us updated on the issue. As I wrote in the other topic: We can not hold back our customers not to upgrade the samsung software forever even if it is not emlids fault. Regards Roland

Hi Roland,

Thanks for sharing all these observations!

I see that Andrew has already replied to you in the corresponding thread regarding this issue. We have Samsung Galaxy Tab Active 3 in the office, and the devs are already looking into it. We’re in sync with Andrew on the situation about Bluetooth, so we collect all the details from you and other users in one place to have the most updated picture on it. Hopefully, we’ll provide you with the new info on this soon.

So, I finally got the RS2 to connect to the Samsung Tablet. I installed Field Genius to test if the software was the problem. Field Genius had me set the blue tooth output on the RS2 to ERB. It then connected just fine. I switched the blue tooth output on the RS2 back to NMEA and now it works just fine.

1 Like

Hi Sam,

That’s good news! Thanks for letting us know.