ReachView beta v2.1.5 update

Hey everyone!

Today we’ve released yet another ReachView 2 update, this time the tag is v2.1.4.

New features

  • RCH-410 RTKLIB update to newer beta. RTKLIB has been heavily updated. The new code is a mixture of the latest upstream beta 26, rtklibexplorer’s demo5 branch and our features
  • RCH-409 Firefox support. Front-end has been updated to fix the insane behavior in this browser
  • RCH-394 Display base on the map. Look for a bright green dot!
  • RCH-245 Smaller grid size. The minimum grid size has been decreased to 500mm. More map features coming in the future updates

Bug fixes

  • RCH-401 In-app connect to open wi-fi validation fails
  • RCH-400 Loading screen disappears too early
  • RCH-379 Logging: delete is glitchy with multiple files
  • RCH-398 Satellite chart sorting: SBAS sats are separated from the rest
  • RCH-399 Base sat levels are still displayed after corrections stop

Known problems

In this version we did not fix the logs. Even if you started them, they will not automatically start after a reboot. Sorry! Another small update to fix this is coming soon

How to update?

To move to the beta release, you need to flash the new, beta image!

  1. Go to the settings tab, and find the check for updates link. You will be redirected to the setup screen you’ve seen when ran your Reach for the first time.

  2. The last part of the setup will show that there is a new version v2.1.4 available. Click the blue update button to perform the actual update.(Never mind the screenshot has v2.1.1).

  3. The update process will have a progress bar, you will see Reach downloading and installing different part of the software. Please wait until it shows that the update went successfully with a green tick.

  4. Click the Reboot and go to the app button.

  5. If something seems wrong with the app, please try to clear the cache and report the issue here.

Time mark support

One of the critical features missing in our new beta releases has been the missing time mark support. We are still working on a better way to convert the logs to RINEX onboard Reach, but in the meantime we offer patched RTKLIB apps to convert the raw logs to RINEX without losing the events and post-processing these RINEX files.

  • RTKCONV will help you convert raw logs to RINEX
  • RTKPOST will generate .pos and _events.pos files containing event positions
  • RTKPLOT to view the results. This one is actually mainline.

We also plan to update our post-processing tutorials some time next week.

New RTKLIB notes

This is a very fresh RTKLIB release and with your help we hope to find bugs and fine-tune the parameters for better performance, so reports and logs are very welcome, as always.

The actual code as available at out GitHub, on branch reach.

That’s it!

Thank you for using Reach and the new beta. The response has been great. We are working on making it even better!

Best regards,
Emlid team


We’ve released v2.1.5, which should fix the bug with logs not saving their state after reboot!


Great, thank you! I will be able to do some testing in NE Germany next weekend. Any suggestions how a test should look like?

Update worked well. Booting the reach used as base was again very slow and only after 2 power resets. Connection via UART, 433MHz works well.

Strange is the extreamly fast fix under weard conditions behind a window in our flat:


I updated one of my Reaches to 2.1.4 this am (from 1.2). Update went pretty well and the new GUI is very nice. I had also recently gotten access to some Ntrip correction data, so I also tried to set that up. Also went well. I was able to get Ntrip corrections to show up and start working. Great.

All was set up via the wifi router in my apartment, which meant I was stuck sitting a few meters outside my apartment, or else I would lose the signal. I wanted to see if I could get my reach to go mobile. My plan was to connect the reach to my iPhone to get Ntrip data and then to my tablet via bluetooth to use mock GPS in an app and see if I could wander off from my apartment. So I went to the new reach view wifi page and gave it my iPhone hotspot info and told it to connect. It did not. And did not log back on to the apartment wifi. So I cycled the reach. It did not log on to either wifi. Weird. But it DID restart its own hotspot. So I logged in to the reach hotspot, deleted the iPhone hotspot info, leaving just the apartment wifi info. I told the reach to connect to that. It closed its own hotspot but did not show up in Fing on my apartment wifi. I cycled it again and it again did not log on to the apartment router but instead started the hotspot. I logged back in to the Reach, deleted ALL saved wifi info, re-added my apartment wifi, and cycled it again. Still no connection. It won’t log on to my wifi but will only create its own hotspot. What did I do???

Apologies if this is incorrect for this thread and should have been its own post. I thought this might be related to the new release of 2.1.4. Since it is in the new wifi page Im having trouble.

Thanks for the report!
It looks like that wpa_supplicant.conf file crashed. There are two ways to fix this problem:

First way - you can reflash your Reach and try again to add network and connect.

Other way:

  1. Connect to reach via SSH (root / emlidreach)
  2. Open wpa_supplicant.conf file (path to file: /etc/wpa_supplicant/wpa_supplicant.conf)
  3. Delete strange symbols (like this at line 10)
  4. Reboot your Reach

After that, Reach must to connect to your network.

Great, I would like to try it soon. Thank you.

That was ever happened to me, fix faster inside the building with extremely poor signal, real fix not fake.

I updated from a working 2.1.3 to 2.1.4 and it appears all settings other than wireless are gone. Both Reach units connect to WiFi, but no values are shown for most things and its not finding a fix or showing the satellites.

I tried to hit the “Reset configs to default” button, but it doesn’t seem to set anything. Thoughs? I’ll try reflashing to 2.1.3 and try it again.

@Shaddow Thats probably a browser problem. I didn’t have these problems. All my settings where still there. Try to clear your browser chache or use another browser. Chromium works well.

1 Like

Well done Emlid team! You guys are really on top of it to give us the best that these devices can offer.
Look forward to this weeks testing.


Great to see the updates rolling in so fast!

I’m trying to ssh into Reach however it keeps rejecting the password. Tried both “reach” as stating in the docs and the new password I setup for this particular unit.

My terminal has no problem finding the reach by either ssh reach@192.168.x.x or ssh reach@xxxxxx.local…just wont take the password. weird? Im on MacOS Sierra and using the HoRNDIS workaround.


For connect to Reach via SSH use name “root” (root@192.168.x.x) and password “emlidreach”

FYI…the docs says this:

Linux/Mac OS X

Open up a terminal and type ssh reach@, where is the IP address of your Reach unit. If there is only one Reach unit on the network, it should be accessible by ssh reach@reach.local. If you are on the Reach-hosted network, it’s IP address will always be The password is also reach.

Thankyou that got me in :slight_smile:

You are right. But docs is accurate for ReachView v1.2.
Thanks for that information, we’ll fix it soon.

You are welcome! :slight_smile:

Upgrade is done. How easy it was ! Once again congratulations to Emlid team for such a good support.
I would so much like to have a dual frequency base now. I hope this is in Emlid plan.


Definitely a cache issue, the browser tries to save the page in memory, but sometimes the app changes significantly during update, so you might see this.

After a lot of testing i can share this:

A) works:

  • ntrip server ~25 km away and reach rover.(fix with gps only and gps&glo 5 hz after a few minutes. fix is staying sold over a long time )

  • reach base station (rtcm or raw data) & reach rover (baseline about 40 m. both in same wlan. data is processed with rtknavi demo5 by tim. - same solution like above)

B) works not

Reach base and rover . data is processed at reach.

What i see ar ratio is sometimes very fluctuating and jumping 1.5 /1.6/ 2.7./ 1.1/2.3…
sometimes i got fix after minutes of running, but falling back to ratio ~1 and staying there…
when i collect raw data from both reach units and use rtkpost i got very good solutions with fix…




Appreciate your testing. Could you please post a screenshot of your rtk settings? Judging by the AR number you are using continuous AR? You are on version 2.1.4?

This is ntrip server with Reach rover. On 2.14

With own base I use same settings.

HI to everyone, ho to update from version 1.2?