Rover keeps moving slowly in one direction even in Static Mode

Hello all!!!
I have successfully connected reach device with RF modules and getting cm accuracy. But the problem is my rover is keep moving right or left in one direction continuously. It never stays or moves randomly in the same point. My rover is in Static Positioning mode.

These are my settings and results:

See the results for approx 40 minutes:

I need something like this which can move randomly at one point and not just move in one direction.

(This figure is just for reference to show how my rover should move)

@bide @igor.vereninov @igorvereninov

Any help would be appreciated. Thanks a lot :slight_smile:

Hi, i think ypu should choose kinematic mode. Static is for steady rover in one point. CMIIW

Hi @dicky
Thanks for your response but my rover is not moving and in steady position.

Regards

Sorry, misunderstanding. Ahay…

@Alok_P

I’ll bet if you logged for 24 hours, there would be a point where one satellite would disappear over the horizon, or a new one would appear, and your fix would snap into one spot and stay there.

For me, if it was not too much work, I would go back and occupy the point again. Otherwise, I would spend some time playing with the RTKLIB settings. For example: raise the RTKLIB horizon by 5, then 10 degrees and also consider excluding the different satellites one at a time.

Hi @bide

Thank you for your reply. I am only using RTKPLOT and I changed the RTKPLOT settings but still same results. My rover is keep on moving in one direction. Although my Status shows Fix.

Figure shows the RTKPLOT settings:

Also how to adjust this in RTKPLOT?

Sorry, I should have said you can change those settings are in RTKPOST.

Could you send your raw log files, please?

Hey @andrew.yushkevich

Actually I am back home from office. I don’t have any log files here. I will try to get some log files on Monday and will share with you.

Regards

Hi @bide. Thanks a lot. Also, I am not doing post-processing. I am checking my data in real-time. Thats why I am little concern about why my rover always move even in Static mode.

Hi @andrew.yushkevich

There are 2 log files:

Hi, @Alok_P

  1. Try to turn on GLONASS to get better satellites visibility. Now you have only 4-5 “good” satellites.


  2. Try our new beta & patched RTKLIB apps. There’re a plenty of new features which could help you in work.

Hi. You have obtained a great result. Reach uses only one frequency L1. To get the result more accurately the desired L2.

HI,
If I read the data correctly, your baseline appears to be approximately 2KM. As Andrew said, you may have few satellites that are giving a good fix of 3 cm , but another example of precise but changing measurement. From some sources, I have read that Static measurements should be a minimum of 4 hours to compensate for orbit variations (solar storms, etc.). Using more satellites helps, especially if you are using static measurements.
Speed and accuracy are tradeoffs.

I know I am almost always too impatient in static measurements. I think your results say the data is consistent enough to be considered non-moving, but is clearly influenced by slowly changing orbits, etc. Longer times and post-processing should help precision Static measurements.

My first GPS was good to approximately +/-200 meters (USA). In perspective, a drift of a few cm is a considerable improvement .

Good Luck,
RickJ

1 Like