No transmission of the 1006 ARP station coordinates via LoRa

I am using the Reach RS+ survey kit (consisting of two identical RS+ units) for surveying purpose. I configured the devices for RTK over LoRa radio, exactly as instructed in this setup video:

Reach RS/RS+ — RTK over LoRa radio

Yesterday I was in the field for surveying, everything was working as expected and shown in the video.

All of the sudden the fix was lost in my rover and never came back. After a while I discovered, that the baseline is approximately 5000 km and the base position and height 0, 0, 0. I concluded, that the base stoped transmitting its position or transmitted a wrong position. Satellite corrections were still received, which I could tell from the grey bars in the SNR status graph. I was unable to regain the RTK fix, here’s what I’ve tried allready:

  • Reboot both receivers
  • Verify the latest firmware installed (2.18.1 stable)
  • Verify that base coordinates are inserted (tried both: manually and averaged)
  • Switch RTCM3 message 1006 off and on again
  • Try different LoRa frequencies on both receivers (always matching)
  • Try different LoRa air rates on both receivers (always matching)
  • Reset settings to default via the settings menu, reconfigured according video “RTK over LoRa radio
  • Try to reflash both Reach RS+ units, which failed, see my other post.

At this point I have no clue how to get the survey kit work again in RTK over LoRa mode. Anyone who can help?

Thank you very much.

1 Like

Hi Uli,

Looks like you base station coordinates are not set.

Please go to Base mode tab and double check you base is set over a known point or its position is averaged.

Indeed, it looks like base station coordinates are not set, but they are. I verified that and tried both:

  • Manual inserted coordinates
  • Averaged coordinates

I see. Thanks, let’s continue the conversation in another thread :slight_smile:

Hi @CpNemo,

This is highly unusual behaviour. Could you please send us a full system report? You can send it via PM on the forum or mail it to

1 Like

Unfortunately I can’t send system reports. My base is stuck in firmware update mode. This problem needs to be fixed first.

HI @CpNemo,

I’ve just replied to you in this thread.

I was able to reflash and reconfigure the unit. APR station coordinates are now transmitted via LoRa again. However, I face a different problem now: Wi-Fi randomly switches off after some minutes, see my other post:

Reach RS+ Wi-Fi randomly switches off and stays off


The initial issue was resolved by reflashing the device.