Reach RS+ Firmware reflashing failed, even in Firmware Update Mode

I am using two Reach RS+ units with Firmware 2.18.1 stable. Due to a misbehavior in RTK/LoRa configuration I was trying to reflash the firmware according to the instructions given:

Firmware reflashing

Unfortunately the process ended with the message “Flashing failed”, although I followed the given instructions very carefully and set the device to firmware update mode. I tried this on two different Windows 10 systems with both my Reach RS+ units without success.

Why does the flashing fail? What else can I do to reflash the RS+ units?


Hi Uli,

First of all, what kind of misbehavior you observe with your RTK/LoRa configuration?

BFirst of all, what kind of misbehavior you observe with your RTK/LoRa configuration?

See my other post:

No transmission of the 1006 ARP station coordinates via LoRa

Could you post screenshot of flashing tool with the error?

I have no access to my Windows 10 system for the time being, but I remember the screen looked exactly like the one Emlid shows in the troubleshooting section:

The flashing tool recognizes my Reach RS+ units and shows “initializing…” in step 5. Then “Flashing failed” ist shown. Same behavior on both of my Reach RS+ units with firmware 2.18.1.

Hi @CpNemo,

Have you tried troubleshooting mode?

Beginning from the step, where “Flashing failed” error appears, could you please do the following:

  1. Disconnect Reach RS+ device from the PC

  2. Hold the power button for 10 seconds until Reach turns off

  3. Press Try again button in the Reach Firmware Flash Tool on PC

  4. While pressing and holding the power button, plug the USB into a PC.

All LEDs should blink several times simultaneously, and then start blinking one after another. After that, the unit should start the firmware update.

Let us know if there will be any progress.

Yes, I have done all the steps described in the troubleshooting section to put the device in firmware update mode with the flashing LEDs. The result: „Flashing failed“.

I have the same problem on a rs2 flash fails even doing it the way that is suppossed to work if it does fail, I tried Linux also since win10 didn’t work and the same error. Not able to flash.

I’ve found when reflashing, this part is the trickiest, and usually the factor if it works or not…just my experience.

I have made a video of the failing update procedure:

I tried different USB cables and even freezing the device as suggested above, with no success. The same behavior is reproducible on two different Windows 10 systems. Also the Firmware Flash Tool crashes the system with a blue screen on every second attempt. Same problem on both Windows 10 systems and both of my Reach RS+ units.

Hi @CpNemo,

We’re looking into the issue now.

Currently, may I ask you to share flasher logs from both Windows PC you tried?

You can find them here:
C:\Users\<username>\AppData\Local\Emlid\Reach Firmware Flash Tool\logs

Is there any chance you can try reflashing on a Linux device?

I will try the flashing on a Linux device and let you now how it was going.

In the meanwhile here is the log-file: (3.1 KB)

A Python script returned the message: “Failed to enable eMMC device, FEL flasher returned 1”

Ok, I tried Ubuntu 18.04. Same problem, flashing fails right after “Device initialization…”

Same as my first unit, mine stopped booting and hung in flashing light mode, does yours still boot up and can be used? I tried disconnecting usb drives, usb sticks everything, linux laptop,windows laptop, linux PC windows PC, linux on virtualbox etc. Just based on quick connection etc when I ever get brave enough to use the flasher it will be on linux not windows

Unfortunately my Base is now stuck in firmware update mode with the rolling LEDs since yesterdays flashing attempts. So I can’t use my equipment anymore and would be grateful for any quick help.

@ brycethomaskennedy
How did you solve the problem with your first unit which hung in update mode?

Hi @CpNemo,

May I ask you to shut down the unit and try reflashing on Ubuntu once again?
You need to press the power button for 15 seconds to turn it off.

Please make sure you enter firmware update mode before reflashing.

At the moment, we’re working on the fix for this flasher issue. I’ll let you know once it’s available.

Sorry for the inconvenience!

I have tried it again, several times on the Linux system. I pressed the button at least 15 seconds to switch it off. No success, flashing fails.

According to the logs it occurs to me, that not being able to put the device in firmware update mode is not the cause of the flashing failure.

Hi @CpNemo,

May I ask you to share the log from Linux as well? It’s located here:
~/.local/share/Emlid/Reach Manufacturing Flash Tool/logs

Could you please describe or share a video of LED behavior when you try to run the firmware update mode?

Here is the Ubuntu log file: (5.6 KB)

I can’t make a video before Tuesday, but I try to describe the procedure:

  • To shut down the device I press and hold the power button for at least 15 seconds
  • All LEDs go off
  • After another 15 seconds I release the power button
  • Then I press and hold the power button
  • All LEDs go and remain on a the same time
  • I plug in the USB cable
  • Shortly thereafter the LEDs start a rolling pattern
  • I release the power button
  • The flashing tool recognizes the device in step 4
  • The flashing starts device initialization in step 5
  • Flashing fails after initialization.

Hi @CpNemo,

Thanks a lot for sharing the log file!

I redirected it to our devs and it was very helpful.

At the moment, we hope to release the new flasher version for Windows next week.