Missing camera events at equal intervals with Reach Rover unit PPK

I’m flying a Reach Rover unit on DJI M600 pro connected via hotshoe running Reach View V.2.22.0

I have several flights that are missing ~10% of camera events after processing RINEX files with Trimble R10 base station logs with RTKPOST. Flights flown at 120 m AGL with 2 second intervals between captures.

I have seen several posts discussing Missing events and Missing events PPK but unsure if a solution has been found.

My problem may also be unique…I am missing an event every 8-9 photos but sometimes every 4 - 5 photos and other times skipping many photos. See map below:

I am positive that the camera shutter went off during missing events because the distance between photos is consistent.

Also interesting, I ran RTKPOST with .obs from the RINEX 2.11 and from the UBX converted to RINEX 2.11. They have different number of camera events.

Converted from UBX to Rinex 2.11 with RTKCONV ver.2.4.3 has 888 / 1,108 events:

and Rinex output from Reach View directly has 904 / 1,108 events:

All collection and processing was done with GPS + GLONASS + SBAS + QZSS at 5 Hz

My questions:

  1. Why am I missing events at roughly a fixed interval?
  2. Is there a way to recover events or find another place they could be stored from raw logs?
  3. Is there a way to interpolate / connect missing event logs with images?

My Setup:

Data:
Rover RINEX log -> raw_202001160353_RINEX-2_11.zip (7.7 MB)
Rover UBX log -> raw_202001160353_ubx.zip (8.7 MB)
Base RINEX -> 00010160.zip (246.4 KB)

1 Like

Hi Dan,

On Reach M+/Reach Module, please use one of the following GNSS selections for time mark logging:

System Frequency
GPS + GLONASS + GALILEO + SBAS + QZSS 1 Hz
GPS + GLONASS + QZSS 5 Hz
GPS + GALILEO 5 Hz
GPS 10 Hz

Otherwise, you might lose time marks during the flight.

I’d also recommend updating your device to the latest v2.22.2 as there are some improvements on time mark logging in this version.

Hi Tatiana,
Thanks for your reply. Do you know why I would have different events in the UBX vs Rinex files? Or is there any way to retrieve the events ?

Hi Dan,

I experienced a similar issue for a very long time, more than 6+ month, tried everything, was told that the problem was from the antenna placement or the electrical quality of my plane but no luck until i tried to ignore what was on emlid docs, this part :

If your raw logs from base and rover are saved in .ubx format you should convert them to RINEX. If you already have RINEX logs from the receivers you can skip this step.

Using only the UBX files, I never missed an event since and I just tried today to use the RINEX logs from a recent flight and I lost 23 events even when using 2.22.2 on the RS/M+ combo

Please Tatiana update your docs with :

If your raw logs from base and rover are saved in .ubx format OR YOU HAVE A PROBLEM WITH EVENT NUMBER you should convert them to RINEX. If you already have RINEX logs from the receivers you can skip this step.

Hi Dan, Benjamin,

We thoroughly tested time marks logging on Reach M+ devices earlier. Unfortunately, we weren’t able to reproduce such behavior while working with stable configurations from above. I’ve written about it here:

May I ask you to try one of the configurations I shared above and then post the logs here? I’d like to check if the issue persists.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.