Differences b/w RS2 direct rinex vs UBX converted rinex

Hi,

I don’t know whether it’s something I do but I see differences in rover POS files when I PPK the same rover OBS using the same RS2 as base but one time I converted the UBX to rinex 3.02 with RTKLIB and one time I took the rinex 3.02 that was recorded directly by the RS2 (all from the same logging of the RS2).

Solution is mostly float but should the diff between the two be on order of tens of meters?

Which one is the right way to go - record rinex 3.02 or take the ubx and convert it?

I uploaded both base OBS versions.

I am using RTKLIB 2.4.3 b8 on ubuntu 18.04.

Has anyone else seen this phenomenon or can point to a thread where this is resolved?

I saw this post Missing camera events at equal intervals with Reach Rover unit PPK for related rinex 2.11 issues, but that did not seem to get solved.

Tnx

Float could be waaay out, so yes.

Could you elaborate you setup here? ref. your uploaded rinex files

I would say that you haven’t used the same base-position for RTK and PPK?

I would say @wizprod has a good point there

Data is here. https://drive.google.com/drive/folders/1kXPOGxfO1Cy6kDzyiPIdInONVrz90rD5?usp=sharing

  1. Base reference 1 - I had RS2 record raw rinex 3.02 as described here:
    https://docs.emlid.com/reachrs2/reachview/logging/

  2. Base reference 2 - when recording raw rinex, ubx is also recorded as backup. I converted the ubx to rinex 3.02 with rtklib.

Note - both of the above were recorded during the same log session of the RS2 simultaneously.

I then PPK’ed the same rover obs file, one time with the raw rinex 3.02 that was saved by the RS2 (base ref 1) and then a second time using the rinex that was converted from ubx file (base ref 2).

Should there be such a difference between these two methods? Shouldn’t it be the same rinex? I didn’t intend to test it. I stumbled across this difference by chance.

@TB_RTK - “waaay out” for float is 10s of meters? isn’t float more like 1-2 [m]?

Thank you. I`ll have a look at it

There is no outer edge for a float so any numbers is possible.
But looking at your pattern above(pointed out by @wizprod) is seems like a systematic error e.g wrong base coordinates (They are all equaly shifted).

But I have also seen bad data produce similar shift.

Looks like base coordinates issue. But why are they different? convbin and RTKCONV do not yield the same result?

Raw rinex 3.02 header using ‘convbin’ it seems:

image

Rinex 3.02 header from conversion of ubx with RTKLIB (RTKCONV-qt):

Convbin is not part of Emlids program (as of writing).
The entire RTKlib has not been tuned to their product line.
I would stick with apps provided by Emlid https://docs.emlid.com/reachrs/common/tutorials/gps-post-processing/#required-data

Distances between the 2 results are in +10m or +3m? If +3m then I believe the reason is the that your RTKPost setting is reading the position from the header of each Rinex file (Approximate Position XYZ ).
Try to change these 2 lines to have the same values or set them to 0 0 0 and input your base position in RTKPost.

I just tried now on my RS2 2.39.0 version. Both rinex and raw (after converted to rinex) yeld the same base coordinates. No error here

What Reachview version did you run on your RS2?
Are you using the latest RTKlib from this page ? Yours end with B8, mine end with Eml

And i converted to Rinex 3.03, not 3.02 like yours.

1 Like

Kudos @TB_RTK !!

I used the Debian package for ubuntu from here https://packages.ubuntu.com/search?keywords=rtklib and that had version 2.4.3 b8. I think the biggest thing with that version was that the ubx conversion yielded after UBX conversion, a single frequency OBS from the RS2 which is not right.

I downloaded the ubuntu binaries from the link you sent and that is
image

Now all seems OK. Position diff between the raw rinex and converted ubx makes sense now:

1 Like

I think the b8 version of RTKConv is for L1 only. I was affected by it several months ago and someone from Emlid pointed this out. I did not know that it was for L1 only. b33 version is for L1/L2

1 Like