Emlid

Community Forum

Javad Radio Modem Connections via BT


(Carl Schaefer) #1

I’m trying to use Javad radio modems in place of the LoRa modems to provide long-range RTK corrections between 2 Reach RS+ GNSS receivers.

The Javad radio at the base is HPT435BT and at the rover is their “J-Radio”

I want to connect both via BT to their respective Reach RS+ units.

I am unable to get a “connected” message within ReachView after pairing either Reach RS+ unit with the Javad radio. I can pair them, but the “connected” message disappears after a few seconds on the Bluetooth page within ReachView.

In an attempt to try to make the BT connections work, I have even tried to setup the Javad radios as BT masters and provided the MAC address for the Reach RS+ unit but the “connected” message only lasts for a few seconds, then reverts to the “x”. In this master mode, ReachView cycles back and forth several times between “connected” and the “x” but it never stays connected.

The Javad radios spec sheet indicates the following:
Bluetooth V2.0 Class 2 supporting SPP Slave and Master Profiles

I am using the lastest dev firmware v2.17.5 in both Reach RS+ units.

It looks as though Dmitiry was able to get a BT connection via this post

Any help/ideas would be appreciated.

Thanks
Carl


(mod edit: trimmed forum rules from post)

(Tatiana Andreeva) #3

Hi @ak_schaef,

Could you please post here:

  • system reports from both RS+ units;
  • screenshots of Javad radio configurations?

(Carl Schaefer) #4

Rover.log (2.5 KB)
base.log (2.5 KB)
Here are text files of base and rover logs followed by screen shots of Javad BT config pages within AWlaunch.

HPT435_BT

JRADIO_identification


(Tatiana Andreeva) #6

Hi @ak_schaef,

May I ask you to try to configure this radio using ModemVU utility?


(Carl Schaefer) #7

I am in contact with Javad tech support and after struggling to get ModemVU to properly configure modems they indicated using AWLaunch utility is the correct software for radio modem configuration. However, I can now connect to the HP435BT via ModemVU and screen captures from within are attached.

Is there a way to reset the BT configuration within Reach? Something odd is going on. I have attached several screen captures to help illustrate.

  1. I connected my phone (Android ver 8.1.0) to my base Reach RS+ using Androids bluetooth connection setup screen and was successfully able to pair with Reach.

  2. Within ReachView, I paired the phone at the Bluetooth configuration screen and at first the “connection” symbol appeared but after a few seconds it reverted to the “x” and presumably lost connection (see screen capture ReachBT_phone.jpg).

  3. I changed ReachView to output position to BT and turned off the Base Mode setting. I then got the “Send Error (111)” on the Position Output screen, which as I understand means no data is being sent via BT (see screen capture Reach_BT_PositionOutput.jpg).

  4. I installed a Bluetooth Serial Terminal app on my phone and was able to connect to reach only to discover NMEA sentences appearing in the Terminal. (See screen capture BT_Serial_Terminal.jpg).

  5. also attached for reference are screen captures of both the reach and HP435BT bluetooth specs as captured by another bluetooth app. (see screen captures BTspec_xxx.jpg)

In my testing I am able to connect to the HP435BT modem using the same Bluetooth Serial Terminal but since no data is being passed around, it just sits their blank. But, at least I know it is staying connected.

It seems to me that something within ReachView is making the BT connection disappear which might be blocking the RTCM corrections from being transmitted?

Maybe with all of my BT testing in trying to make this work, I need some way of doing a full reset to ReachView and going back to defaults or clearing out all the pairings etc. (???) I initially tested this all using the current stable version of ReachView and after struggling to maintain a connection, I installed the current dev version, but without any luck.

Javad support is also looking at it from their side.

I appreciate the help in trying to get this to work.

CarlScreenCaptures.zip (1.1 MB)

ModemVU_1 ModemVU_2 ModemVU_3 ModemVU_4


(Carl Schaefer) #8

Hi @tatiana.andreeva,

Javad tech support is wondering about the following regarding BT :

"What is the authorization key set on Bluetooth master (at your GNSS receiver)? Does it use PIN code or pass key authorization?’

Also, is there a way to completely reset the BT config within Reach (see previous post). I’m thinking of resetting the devices back to factory defaults before retesting.

Carl


(Tatiana Andreeva) #9

Hi @ak_schaef,

We’re getting the Javad radio we used for tests in order to reproduce your issue.

The default PIN is 123456, but it can be changed in ReachView app.

You can reset all settings to default in ReachView Setting tab.


(Carl Schaefer) #10

Hi @tatiana.andreeva,

I got it to stay connected and they work!

I reset the Emlid unit and the Javad radios and started over from scratch.

The key point is that the Javad radios need to be configured in Master mode and the MAC address of the Emlid Reach unit entered into the Javad bluetooth setup within AWLaunch software. (and in this configuration I don’t think the PIN codes matter, but left them at 1234 which is what the Javad defaults to)

Then the Emlid Reach units Bluetooth settings need be have the “always discoverable” toggle turned OFF. (At least I think this is important for this scenario)

Even this took several tries including rebooting units. You know you are close if the “connected” symbol cycles on and off with the “x” on the Bluetooth page within Reach every 4-5 seconds. It still didn’t work in this state, but rebooting everything all over again and repairing had them stay connected and my Rover unit was able to receive corrections from the Base via the Javad radio modems.

So, now as long as they hang on to their configurations we should be golden.

I’m going to have beer to celebrate.

Thanks,
Carl


(Tatiana Andreeva) #11

Hi @ak_schaef,

Glad to hear you figured it out! :slightly_smiling_face: