Insta-flip problem


#44

When I use qgroundcontrol, the channels seem right. I am in mode 2. This is the screenshot I got and it seems accurate. Please note that I have the throttle as low as possible and I put the second stick in the far right (horizontal) and middle (vertical) position. I calibrated the ESCs and they attached in the proper order.


#45

I tested the ESCs the way you suggested and everything was consistent. (Channel 3 transmitter way)


(Tatiana Andreeva) #46

Hi @Lucullus,

I’ve seen you already posted logs and hardware photos in another topic. However, may I ask you to post the latest logs and photos of your current setup once again?

I’m afraid it’s really hard to see the whole picture without it.


#47

1 7-4-2019 2-07-10 PM.bin (136 KB)
1 7-4-2019 2-07-10 PM.bin.log (229.6 KB)


#48


#49

Here is a video of it shooting up almost immediately. Please note that I barely move the throttle up. https://www.youtube.com/watch?v=gFsT9RCtNNw

EDIT: I should note that this video does show the exact flight indicated by the logs above, but it does reflect the general trend


#50

Here is the throttle position when it shoots up like that. Please note that my trims were centered.


(Tatiana Andreeva) #51

Hi @Lucullus,

May I ask you to conduct the following test?

  1. Detach props
  2. Arm the drone
  3. Try moving the throttle up slowly. Servos’ spin rate should be increasing (you should hear it)
  4. Check out at which throttle position servos spin rate will stop increasing and become maximum

It’d be great if you share a video and logs as well.


#52

It seems to reach the maximum position at the highest throttle. Could it be the size of propellers that is causing the issue? Please note that I am using the most recent version of the emlid fork of raspbian. According to qgroundcontrol, I am running ardupilot 3.6.5. Here is the video of it.

3 7-5-2019 8-43-20 AM.bin.log (757.5 KB)


#53

My motors are racerstars:
https://m.racerstar.com/Racerstar-Racing-Edition-2205-BR2205-2300KV-2-4S-Brushless-Motor-Red-CW-or-CCW-for-220-250-RC-Drone-FPV-Racing-p-33.html
My propellers are 8045s


My Escs is a 4 in 1


#54

This is how I calibrated the ESCs


#55

Here is another video https://www.youtube.com/watch?v=9Iy5-fykGnM. I would include the logs but I cant seem to find them in mission planner

I also tried modifying the weight and expo of the throttle channel via the taranis qx7 but that did not help. Here is a pic of one of the many settings I tried using

The thing is that there is no in betweens. It is either shooting up at a certain threshold or it is moving at all. No matter what I do, this seems to be the problem


#56

Actually here are the logs2019-07-06 15-43-08.tlog (147.5 KB)
tlog 2019-07-06 15-45-19.tlog (651.3 KB)
2019-07-06 15-51-14.tlog (110.7 KB)


(Tatiana Andreeva) #57

Hi @Lucullus,

The motors you use require the smaller props. According to the data from the link you shared above, your motos need 5-inch props (5045).

It’s more likely that’s the reason for the behavior you encountered.

I’m joining to @mlebret advice here: