Flashing reach rs


I’m stuck trying to flash new firmware in rs unit

Trying to connect flash tool with unit, doesnt work even after zadig

Please help.

Hi, @farouk.abd.kader! Welcome to Emlid Community forum!

Are you following the information according to this link in the documentation?

I think you have to install the old Edison drivers first. Emlid DOCS seemed to have removed that information which leaves users with older Reach products with no longer supported Emlid chips at a loss.

You can search the community for Edison drivers to get them.

EDIT: Download Intel® Edison Configuration Tool

*Also, zadig is for the PLUS version of the RS+. Not the RS only.

Yes i did as per guided in the notes.
Even tried other options like zadig but still doesn’t work.


Thanks for your explanation mate.
Do you mind to help me with the right version of driver win10 for Reach Rs if you could?

Download Intel® Edison Configuration Tool

1 Like

Thanks a lot @timd1971 i’ll give it a try.

Still no luck at the moment :frowning:

Hey everyone,

It’s not necessary to download any additional drivers for Edison devices now as the new Flash Tool should be able to handle them. That’s why we removed them from our docs.

Regarding the inability to flash the device, Mohd, could you please share the screenshot of your Device Manager when Reach is connected? We’ll need to understand how the unit is recognized on your computer.

1 Like

In my case, which may be isolated, I had gone round and round and round with NO success getting the firmware flash updater to work on the units. The ONLY solution for “me” was to install the Edison drivers.

Otherwise the flasher would just sit there for eternity looking for the Reach RS unit.

*I cannot remember at the moment, but I think I also had to install them as unsigned drivers as a Windows 10 boot up option. There are posts about this by others also doing this with success.

Either way, this is how I got mine to firmware 26.

This is emlid flasher screen

this is device manager screen

I think we need to see the Ports (COM & LPT) expanded. When recognized, it should show your unit there.

More reading. Only way I was successful to get flashed to firmware 26. USB-to-PC still does not work though.

This is nightmare.

Been trying all night long to get it to work.

But its still the same.

Maybe emlid need to think how to give support to non IT savvy like me.

Try a different PC / Laptop and different USB connectors. Some have had to try with a external powered USB hub since laptop didn’t put out enough power?

Good luck. I know exactly that nightmare too well. I don’t think this is dealt with much anymore ever since they changed from Edison to Neutis chip in their products for the better.

Hi Mohd,

Could you please elaborate on what version you Reach RS is at the moment? Are you capable of working with it?

Regarding the Device Manager, as @jp-drain-sol mentioned, it’s essential to see how your Ports (COM & LPT) section looks like to understand how the unit is recognized in the system. Please, also elaborate on what PC and what OS version you work with.

We’re currently checking what could be the issue here.

1 Like

Hi Mohd,

I just wanted to tell you that we’re working on making the process with Reach Flash Tool easier and more straightforward.

For now, to be able to reflash the unit, I’d suggest doing the following:

Please let us know if it helps.

1 Like

Hi Polina,

Its still the same, even using my new computer today.

What a shame.

Hi Mohd,

We’ve tried to reproduce the issue with our office devices. However, we were able to reflash several Reach Module devices without any issues. So, it seems that we need more info about your device to check the possible root of the issue. Probably, such difficulties aren’t related to the Flasher tool.

Could you clarify the current firmware version of your Reach Module?

Still, we’re in the process of making the Reach Module reflashing workflow easier.

1 Like

Hi Svetlana

Its 2.20.8 for now