Flashing Emlid Reach RS? (Intel Edison chip)

I pulled out my (2) Emlid Reach RS units with old Intel Edison chips. Had old firmware on them. Wanted to use the new ReachView 3, so have to flash to newer firmware.

Couldn’t get the units installed in Windows 10 for the life of me. Stumbled across a possible solution here in the community hopefully. Had to hold down SHIFT key while powering down Windows 10 to get to the Advanced options mode at startup to install unsigned drivers.

Seemed to install the unsigned drivers this time.

Here is the post (thanks to @ cojeffj:

So the the Reach Firmware Flash Tool 1.4.1 detected the unit finally.

It had an option to “Use downloaded firmware 26.0 (latest)”.

So naturally did that instead of using my prior downloaded firmware v2.24.2 from docs.

Is the v26.0 beta or something? Since it offered this to download and flash, will this be ok?

Thank you!!!

Ok, guess it’s not beta:


Both the ROVER and BASE finished flashing. But now the BASE will NOT power on or anything. GREAT. : / I plugged usb cable into wall plug hoping it may need more juice or something, but doubt it. Before I flashed them, the batteries were fine. Wonderful.
UPDATE: After letting BASE sit on charger 10 minutes or so, it powers back on. What the hell ever.

In the Device Manager, shows my ROVER is under Other Devices > Reach but now says drivers are not installed (Code 28). All lights solid after plugging in to usb port on pc. Have to hold down power button much longer for power down?

Hi @timd1971,

It’s indeed weird that units behaved that way after flashing. Firmware versions shouldn’t affect the battery performance. Could you clarify whether it is possible to turn both your units on now?

The latest Flasher tool should install all needed drivers itself. If it doesn’t work that way, please let me know. To turn the Reach off, please try to hold the power button for more than 10 seconds.

We’ve just changed the firmware version naming. So, you’re right that the 26 firmware version is a stable one. The Flasher tool will never suggest you downloading Beta versions.

1 Like

Yes. The BASE that wouldn’t come on, eventually powered on after plugging into wall charger. The battery levels stay well above 90%… maybe a thermal protection thing. Both are working with with Firmware 26 and connecting etc.

The only thing is, yes, the weirdness with trying to connect the Reach RS to a Windows 10 device via supplied USB cable. Even after installing the Edison 1.2.1 drivers (normally, and the trick by rebooting into advanced options mode to allow UNSIGNED drivers to install), seems problematic always. It always says Reach driver not installed and cannot update driver. So basically cannot use the USB cable for output communication. I just remembered that I purchased a serial cable also… so can try that later. Can the Rover USB cable connected to PC even be used for output communication to a COM port?

My workaround for now is to use Bluetooth connection via emulated serial COM port to send output from Rover to the PC.

Hi @timd1971,

Yes, it should be possible to output position from Reach RS via USB to PC.

Could you post the screenshot with this Unsigned drivers error?

I had to reboot Windows 10 in Advanced Options mode in order to install UNSIGNED drivers in order for the Reach Firmware Flash Tool to install Firmware 26. That was the ONLY way it work to flash it, otherwise, the Flash Tool would sit their for eternity. After this trick, at least I can FLASH the units. ((2) Reach RS (Edison))

The problem I have now is that the "Reach RS shows up under Other Devices as Reach with a YELLOW warning symbol that drivers for this device are not installed, therefore cannot cannot connect via USB-to-PC.

If I turn unit off as Flash Tool states, then the “Intel Edison Board” shows up???

Unplug, Reach under Other devices shows back up with no driver installed as before in prior screenshot?

Just simply will not install the unit as a COM port via USB-to-PC option.

Hi @timd1971,

We’ve just tested Reach Modules USB-to-PC connection on Windows, and it worked fine. So, the issues you experience are rather unexpected.

Could you please email us at support@emlid.com with the Flasher logs? To access flasher logs, follow these steps:

  1. Press Win + R

  2. The Run window should appear

  3. Paste this string into the Run window: AppData\Local\Emlid\Reach Firmware Flash Tool\logs

It should open the folder with flasher logs. Please zip the folder and send it in.

Also, could you specify whether you tried to output the position from Reach to your PC?

1 Like

I emailed the flasher logs - logs.zip file for the Reach RS (Edison) problem I am having with Windows 10 detecting receiver(s) but is not creating a COM port or not installing drivers.

Yes, I did try to OUTPUT POSITION from Reach RS to PC (USB-to-PC), but it will not since the PC is not detecting the receiver(s). I can do this via BLUETOOTH, but NOT USB cable.

Thank you for the help!


Just want to post an update that we’ve received the files. I’ll post all news here.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.

Hi @timd1971,

The new version of Reach Firmware Flash Tool is out. It contains the fix for the issue with COM ports assignment during the reflashing. Please update the installed tool to receive the new changes.

You may also download the new version from the following guide.