Converting UBX files to RINEX using RTKCONV

Can’t create Rinex files with rtkconv.exe. I took raw .ubx files and tried to convert. No success. I changed format from auto to u-blox still no success.

Using teqc, I was able to convert .ubx to .obs but not .nav.

teqc command:
..\..\..\GPS\teqc_mingw_64\teqc +obs + +nav +,+ -tbin 1d gitalong_base raw_20161112*.ubx

1 Like


But it’s my first time using RTKCONV so maybe I’m doing something wrong. After clicking Convert, no files are written to disk.

try to change format into U-blox not auto


Tried that too. Are you able to successfully do it?

Also, should I always get a .nav file for every .ubx? In other words, is this a true statement?

ubx always yields obs + nav?

but maybe you have to use the latest rtkconv because of some changes in the format for m8t messages

Which version is that? I thought I had the latest from:

download the latest files and copy on your directory

Ok, 2.4.3 beta fixed this issue.

HI in rinex convert, the signal from the satellites is very fragmented.
it is possible to solve?

1 Like

Hi everyone!

Just wanted to say you can now convert UBX to RINEX in our Emlid Studio PPK software. We’ve designed the app to be easy to use, so the process is more straightforward than in RTKLib. In case you need any help with converting your data, you can always create a new topic with your questions. The tips from our guide can also come in handy.

1 Like