ReachView 2 beta Bug Reports

Could not connect to a strange name wifi (name included a *) with a very long password including letter other than 0-9 and a-x.

Tried Reflashing unit this morning. Intel Phone Flash Lite showed successful flash with no errors.

No change in ReachView. No Correction information. All data configurations show only internal receiver connection.

Only setting for mode is Kinetic, No Stable or Single Mode. Only solution is Single.

I would revert to previous image, but last Version while showing Fixes with good resolution gave meter+ errors in ENU on both Reach and postprocessing.

Any ideas?

OK. Some progress…

I abandoned the smartphone WebBrowser and went to Firefox on my Ubuntu 14.04 Trusty OS 32Bit,

And guess what !! The initial view shows the missing Connections SetUp screen. I tried Chrome on my smartPhone, but could not access the Reach units. Same problem with My Windows7 WebBrowser. Any suggestion?

Next step is to see if if there is FirefoxWebBrowser for Android & Test it.

Hello again. Well, Both Reach units appear to work good for Beta release. Now, I’ll look more at suggestions for my planned uses.

I have no idea why the some of the WebBrowsers don’t work with this Beta Version. Obviously, there is some incompatability somewhere.

I am now using Firefox Browser with Android. Entering “192.168.XX.XXX” in Website search where XX.XXX or XX.XX is your rover and base addresses.

By the way, the GNSS Predictor appears to be working. Nice Feature!!

Cannot connect to open WiFi. “Create” button is not clickable. Only tried from Android phone.

Thank you all for the useful feedback!

Confirmed issues:
RCH-352: Create button not clickable for open networks (@savvy0816)
RCH-344: SSID should allow printable ASCII characters instead of only 0-9, a-Z (@savvy0816)
RCH-353: Wi-Fi Password should allow any characters (@tobias-dahms )
RCH-354: Browser caching issues (@TB_RTK )

@TB_RTK

-GNSS predictor does not update coordinate in real-time, but it is not needed as it is for an area.
-Reach naming allows big letters, but no special characters. This is reasonable because it is used for device local name, access point name and is buried deep in the OS. We do not want issues potentially caused by special characters.

@Andreas_Ortner

I am not sure if I follow. How reproducible not saving of settings is? Is it only for the base settings?

@RickJ

Please do not use default browser on Android, it does not support many modern features. We do all of our testing on Chrome and Firefox. These should work well.

@Charlie_Robinson

This is very strange. Did you try to connect to 192.168.42.1 address? Rebooting the module did not help?

@savvy0816

Which version of RTKCONV did you use?

1 Like

Confirmed. Good catch! RCH-356 issue.

@igor.vereninov : That address worked - I was trying the addresses in the quickstart guide, with :5000 appended. Cheers :slight_smile:

Hi,
i have a minor bug: when connecitng to a WIFI, the interface won’t allow anything bat a-z, 0-9 in the WAP2 password, while WPA2 PSK can (and do) contain special characters and punctuation

Hi Johannes,

Thanks! This one has been reported:[quote=“ivereninov, post:31, topic:4311”]
RCH-344: SSID should allow printable ASCII characters instead of only 0-9, a-Z (@savvy0816)
RCH-353: Wi-Fi Password should allow any characters (@tobias-dahms )
[/quote]

2 Likes

yes, sorry, i searched here but didn’t see it

Cannot specify position output frequency (Hz).
Cannot specify individual NMEA strings in position output: GGA vs GSA, etc.

I did try to do it again. I think the error was my own. I used reachlocal to connect to reach and i had 2 windows open.
maybe in did use the false reach.

solution: i did rename reach into reachbase und reachrover.

another question: where i can find the .conf files on reach using ssh.?

anther bug:

i cant insert into corrections like this:

Reflash failed with an error on Win10 64bit. The toolchain works since I can flash the edison original (most recent default image). If I try to flash on the top of that it seems to do the emlid install, but when reach shows up as a wifi hotspot I am unable to connect. I reflashed under OS X, it seems doing the same thing. (reach shows as wifi, but when I connect to it it does not even ask for wifi password and not possible to connect).

I also tried with flashall.bat and ended up the same: reach shows up as a wifi hotspot, but unable to connect and when I look it up on the Edison Board Configuration Tool, it says firmware version not detected.

Hi Emlid Team , due USB connection is not supported on this beta release I am wondering why my 3DR radios doesnt work sending information about corrections, could you check why if you connect 3DR radios using Reach uart port and configuring on reach view, the corrections sent from base are not received for Rover?

What happens if you remove the protocol (http://) and the trailing slash?

Hi, as most of the user I’m also really excited about the new beta version (v2.0.9). The firmware Upgrade was not a problem at all (using Ubuntu 16.04). Just had to make one manual reboot after all the update process.

Then I just try to get my old setup working again using a radio for the communication of my both units, Which seems not to work proper. A TCP connection works fine:

The average single and average fix option is awesome and the main reason why I gave the beta a try…

Just the serial connection seems not to work yet. At my base unit I use a USB adapter which doesn’t show up, It just show me a UART device:

With the reach image 1.2 my setup was working.

Anyone how had success with a radio rtk connection?