Wifi setting of Rover


I am trying to use a wifi range-extender on ground so the ROVER can be covered by wifi during missions. I would like to ask: is there anyway to change the ACK_timeout and CTS settings of Rover unit?


If you know Linux, then you probably can. I think Reach uses wpa_supplicant and hostapd but I’m not sure. Or maybe it would be a setting that needs to be changed in a kernel module. I am not familiar.

I guess the point is you won’t find a nice GUI setting for it in ReachView, so you’ll have to ssh in and do some hacking at the command prompt.

Good Luck!

Thanks to your reply. Then I have to try something else.


If you must use Wi-Fi then maybe just try an access point (or router) with good power.

There was a fellow who posted his project here and he used something similar up on a portable pole.

Here you go:

Yes, I am trying to use a router. But the guy who is helping me on this matter said that only increase wifi range (he modified the router to increase its range) is not enough, the receiving end (Rover) must also change ACK_timeout and CTS setting. Otherwise, it will cutoff the connection over a certain distance by default.

I have tried a 4G dongle but it didn’t work. However, it may be because I used wrong type of dongle.

Sorry for late response. I saw it in the following link. But the dongles he mentioned are old models. Can’t find Huawei E171 anywhere, ZTE MF 823 is still available on Taobao. Have not tried it yet.

These are the ones we had a chance to test. If you make your dongle work with a Linux laptop, it will most likely work with Reach.

have received ZTE MF 823 from Taobao but it is not compatible to sim cards on the market. Guess it’s too old, telecom carriers no longer support the spec. or the protocol ZTE used is out of date. I’ll try if I can find any old sim card.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.