When is a new version (arducopter) being released?

Hi,
it’s been almost a year that Arducopter 4.0.3 was released as an official Navio distribution.
I’ve been using Arducopter 4.0.7 since February 2021 yet to my surprise still no new official version being offered.
(Would love to have a fully supported version so I can again make use of things like the status LED)

I know Version 4.1.0 is currently beta tested by the arducopter dev. team. Is Emlid waiting for the official stable release of this particular version before any release?

Thanks

Hi Karl,

Thanks for the request!

At the moment, we don’t have plans on updating the pre-installed versions of ArduCopter on our Raspberry Pi OS image for Navio2 in the near future. For now, you need to manually add a required version of ArduCopter if you need to work with them.

Hi Liudmila.

thanks for the reply.
Yes, I am aware of that procedure. Been using it various times in the past.
However, it doesn’t fix the status LED issue if manually upgraded. - Hence my original question about the Navio official release.

Hi Karl,

I’ve double-checked with the team the info about the issue with the LED indication. We’ve introduced the fix for the issue that was added in the master branch of the ArduPilot project. However, it was not added to any of the stable releases yet.

The fix is presented in the latest beta releases 4.1.0-betaX. So, it looks like it should be added in 4.1.0 stable.

Hello,

Led is working with 4.1.0rc6 from arducopter

Thanks

1 Like

I have to wonder what is going on with Emlid and support for Navio2?
The AU website shows Navio2 for sale and explains the software features including ROS.
Yet in recent months I haven’t been able to access docs for Navio2 as it is not showing at all as a tap and on the support page Navio2 is not even displayed - only 3 other products.


Also no link on main page to actually download Emlid’s Firmware package for Raspberry Pi.

To top it of I had to re-install everything after a recent crash and got a message “depository has changed to …buster/stable-old”
So, turns out as of August 2021 Buster is being phased out. But where is the replacement / up-dated firmware from Emlid ??
Further to that I’ve noticed various installation problems due to missing files causing “file not found - reverting to old version” messages. Only after multiple installations attempts by the installer did it finally succeed. And even that had a message “dpk installer exited with error code1”
But I have to wonder now how reliable this installation will be during flight ??
Also since January there has been the issue with the ROS package which hasn’t been really resolved only a workaround solution offered.

Also there has been “Bullseye” released in August. --> Replacement for Buster. Yet still no new firmware from Emlid.

Recently Arduplane 4.1 and Ardurover 4.1 have been released and Arducopter 4.1 will follow in a few days.
Will this finally trigger a new firmware release or are we Navio2 users expected to piece together various old firmware components, using workarounds and manually updating Arducopter/rover/plane releases?
…After all it has been over a full year since last Emlid firmware release.

Hi Karl,

We’re always here to provide technical support for Navio devices. I see that the recent rearrangements of our website pages caused some confusion. So, let me explain what was changed.

Navio2 has its own website page now. It was made to separate Reach devices and Navio2. That makes it more convenient for future users to find out about the device. For that reason, Navio2 docs are no longer accessible from the docs page for Reach devices. However, you can always find them by using the Docs section from the Navio2 official website.

Regarding the image for Navio2, we’re not planning on building a new image this time. But we’re not ceasing the support of the latest released image. It’s made using the Raspberry Pi OS image, which they can update, but it doesn’t mean that our current image isn’t operational. If you’ve met some unexpected messages concerning the system update, please provide all the details about this in a separate topic. We’ll make sure to look into it and understand why this happened.

Considering the ROS issue, we’ve made that script as a solution for the installation of additional packages. It was the fastest way to provide the solution in such case. You need to clone the script only once. Further, you can install the packages using one command. We’ve added this in our docs, too.

I see that the image update is expected due to the new stable releases of ArduPilot firmware. But at the same time, you can install any selected version using the current image. Navio2 is a highly customizable device that can be used in various software and hardware configurations. For some users, it’s enough to use the supported ArduPilot firmware versions provided by Navio2 image. Other users may want to use newer versions, not always stable ones. That’s why you can always tweak Navio2 to work with the selected firmware so that it meets your project’s requirements.

Thanks Liudmila,

As mentioned a big concern for me (and most likely other users) is if the current outdated Emlid firmware can be trusted after installation and the various problems encountered during installation.
Also there are clearly certain inconsistencies within the last 12 months when it comes to Navio2 and Emlid.

  • In the past Emlid had two if not more releases of firmware and / or controller software within a year. Now nothing for over a year.
  • As you’ve mentioned, the website has changed. - Yet Navio is still showing for sale on the AU website as in the past, yet no further link to docs and downloads.
  • As seen below, there is a clear difference in pricing between the US website and the AU website. In essence currently the price is a full $100.- more expensive in Australia then in the US. In the past both websites and pricing had been about the same. - Not anymore.

To me it has all the indicators that Navio may be dropped in the near future and hence separation and lack of updates has occurred. Please correct me if I’m wrong.

Hi Karl,

Sorry, it took a bit longer for me to respond.

The current Navio2 image we provide isn’t outdated. At this point, it’s based on the older version of Raspberry Pi OS, but it’s still maintained. The latest release introduces something new, for sure. But since Navio2 uses ArduPilot firmware which works on a command-line interface, those changes might not be that useful.

There should be no issues with the installation process on Navio2. At this moment, we don’t have similar reports from other users. But if you encountered any, please tell me more about it. I’m sure we’ll figure out what exactly caused it.

It’s not on our agenda now, but we’re still providing technical support and any other help concerning Navio devices.

Navio2 is still can be purchased in the store with other Reach devices. We didn’t create a separate store for the device. The new Navio2 page is for all future users that want to know what the device can do. You can use the link to the docs from there or use popular search engines, for example.

Thanks for drawing my attention to it. We’re currently checking the question about the pricing in the Australian store with our dealer. The information should be updated at the nearest time.