What Are RTK settings for Base and Rover when outputting to File for RTKPost

If Config is set to with the following will this work?



Will this work?

If you are not using radio or wi-fi communication link for RTK, and if you are post-processing, then I recommend putting both units in Rover mode and logging to file with this setting:

  • Raw data log for onboard receiver:
  • file

Base mode is only required if you are using a communication link for RTK. In base mode, you can’t see the satellite signals, but you can in rover mode.

When using RTKPost, just pick the .obs file that you want to use as the base and the other .obs file as the rover. The *.nav files can be picked from the unit that had the best sky view.

Thank you, I will try that out next time I am in the field. Sounds like a good process.

Also, the Mode you want is “Single” and choose GPS + Glonass 5Hz, This will give you more satellites and better results in post-processing (at least, it does for me here in the UK - I am not sure of the coverage of Glonass satellites). Make sure to enable Glonass when running RTKPost.

My first attempt was a failure because I had my settings off. I will try again using your settings. I am still working on a radio solution using Wifi but may just buy radios as others have.
Thank you for your help.

Don’t worry, I’ve done work several times and with incorrect settings and had to go back and redo it. In my small experience:

  • being in a rush = problems for sure
  • carefully check the settings each time, especially:
  • the output modes for solution output, raw log, and base corrections
  • the ublox configuration settings on both units (GPS10Hz, GPS/GLONASS5Hz, etc.)
  • always use the SAVE button after changing a setting, or even changing the config file
  • after starting Reach, refresh the page and double-check your settings are correct (cached pages in the web browser have fooled me several times)
  • finally, go to the log page and look to see the log file(s), then refresh after a few moments and see the file size increasing, so you know it is working.
  • now feel good that you can do your work and not be wasting your time!
1 Like

Thanks for taking the time to write your workflow down. This is very helpful.
My other problem is probably the same for all of us. This is something I am working on intermittently because of several other commitments.
I have been mapping today and built a complicated spreadsheet yesterday and have a most of the day meeting tomorrow.
These posts are printed and is the beginning of startup checklist.
Once it is repetitive, everything should click.
Also, looks like the TW3710 antennas are getting a much better signal than the kit antenna when compared side-by-side.

1 Like

Hi Matt friends, we are trying to post-process rinex data logs from 2 rovers in RTKplot, the single mode is for both rovers?

Yes - that’s how I do it, at least. Single mode lets you log the raw data from both, then you can post-process using either as the rover. I’m not sure if the other modes allow you to do this because I have never tried them.

I am collecting points at the present moment. I will let you know how this method works for me.

I collected today with the settings you gave above. One rover was in a stationary position in Rover mode.
The other was a moving rover also set to single mode with the same settings. Both resulted in solutions and both plotted well. What are the settings to post process this data into an RTK solution for the single point and the points collected in with the moving rover?
I set up the base rover over a known point that was post processed last week using GNSS Solutions. The RTKlib solution for that point had about a 3 meter error.
Another question, how can two “single” solution rovers end up with RTK output?

When you were collecting today, you were doing 2 separate things:

  • processing single-solution coordinates and logging to a .pos file
  • logging the raw ublox data to a .ubx file

The .pos file is only a single solution and it is really just for you to look at and it is not necessary for post-processing. The raw .ubx file (or .rtcm3 file if you used base mode) is what you will use for post-processing.

  1. ReachView automatically converts the .ubx files to RINEX (files like: .obs .nav .gnav .hnav .qnav .sbs) for you, but you may want to convert them to RINEX with different options using rtkconv.exe or convbin.
  2. Now, take those RINEX files and use them as input in rtkpost.exe or rnx2rtkp to create your .pos file.
  3. Use rtkplot.exe to open your new .pos file and see if you got float or fix status.
    Q=5 (red) single status, Q=2 (yellow) float status, Q=1 (green) fix status

There are probably details on how to set up rtkpost.exe elsewhere in the forum.

When I ran the .obs file through GNSS solutions software and the position fixed. On previous collection this same point Fixed to one of the static point stations but had a float solution to the other static point station. That is good news.
When I run this same collected date through RTKPlot all I see is a Q=5 Single solution. I do not understand how RCKPlot can get a Q=1 Fixed solution without having other know fixed stations in order to correct the errors of the signal corrections from the GPS sats.
I used the other rover to walk the perimeter of the 15 acre tract mainly to get the corners of the property. Maybe it will work tomorrow morning when I sleep on it.
Thanks for your help.

Sorry, I am not familiar with GNSS solutions software.

You need to forget the .pos files that were created with Reach, and post-process your raw log files in order to get your result:

rtkconv.exe takes raw log files and converts them to RINEX for rtkpost.exe

rtkpost.exe is what calculates your position using the base and rover RINEX observations. You need to provide a base .obs file, a rover .obs file, at least a .nav file, plus the known coordinates of the base. Then you ask it to process in static mode or kinematic mode to give you a new position file with float and fix status.

rtkplot.exe lets you see your results after you have finished.

Hi Bide, I downloaded both logs from my base in rover mode and from my rover also in rover mode.
Comes with a .obs, .nav and .sbs file for each log.

In rtkpost I use .obs file from my rover as RINEX OBS: Rover, .obs file from my base as RINEX OBS: Base Station.

What .nav file should I use in RINEX *NAV/CLK …?

I process them as static and kinematic mode but keeps saying:
error : no obs data

:open_mouth:

thanks for your attention

Use the .nav file from the base. Try without the .sbs file. Make sure you have entered your base coordinates and height in the options.

Yesterday @igor.vereninov published a post-processing tutorial which will help you as well.

If you still get error: no obs data, then open the obs files with a text editor and see if there is a header plus data or just a header with no data.

We are working in a remote area in Mexico, how can I get a kinematic solution without a Base station reference file?

How can I get my Base Station coordinates (Base Reach) without a reference station, tried the ‘average from file’ option but didn’t work either.

RTKplot displays no solution data.

@igor.vereninov tutorial was useful, even found a reference station in my state (50 km away) but different error ‘no position in rinex header’

Thanks for the attention, I’m a RTKnoob :stuck_out_tongue: