SIM in RS2+, Emlid Flow, Mobile Data, no dice so far

If you use a SIM card in your RS2+ serving as a Base, what issues have you encountered which prevented Emlid Flow, Mobile Data from being able to be turned on?

The Data Activation Center (DAC) SIM was activated last week.

With the nano SIM fully inserted , seated and locked in the RS2+
Power on RS2+ allow to fully boot
Connect Android device to WiFi and same network as RS2+
Launched Emlid Flow app, connected to receiver, then Settings, Mobile data,
APN Settings, APN credentials only required to enter:
Still in Emlid Flow, Use mobile data, unable to use slider to turn on.

I’ve been writing in to, and understand the number of requests to support has increased recently, so it may take a little longer than usual to get back to me.

I did receive one reply saying that " Some of our users that worked with AT&T SIM card used the following APN: broadband. Can you please try it?" I tried doing this even though it didn’t make any sense.

I also sent them a FULL System Report a few days ago, but haven’t heard if that was of any help to them.

I also wrote to the folks at DAC to see if they have ever provided Emlid users with SIM cards and what issues they were aware of, if any.

Thank you very much for any help.

Kind regards,


I just wanted to leave an update here. We were in touch with Kelly over email regarding this case. The devs analyzed the logs from the receiver and they didn’t find any hardware-related issues with the device. Currently, we can conclude that the issues with the mobile data connection are most likely caused by the data-only plan on this AT&T SIM card. Based on the feedback from the users with the data-only plan AT&T SIM cards, the issue was resolved once the SIM card is on the regular plan (voice calls/data plan).

In case someone else faces issues with mobile data on Reach, please first check all the recommendations we listed in the How to provide Reach RS2+ with internet access via a SIM card support tip. If it doesn’t help, please reach out to us to and send the details about your plan along with the Full system report from the receiver. We’ll look into it.

A post was split to a new topic: RS2+ challenges with getting the internet from the SIM card

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.