RS2+ short LoRa range

Hey @erro.alfaro88
I share your frustration.
I have been experiencing similar results that seem to be getting worse & worse.
Today I dedicated my entire day to troubleshooting and I am no closer to a solution.
The LoRa radios continue to be a source of contention and the weak link in the Emlid RTK architecture.
I have owned 3 x RS2 receivers, 1 x RS2+ and 2 x M2 receivers so I have a clear idea of how these machines work.
At present, I cannot achieve a Fix beyond 100m baseline - with a clear line of sight and clear view of sky.
I have already exhausted the problem with Tech Support via email and they have not been any help.
The set up I am using is a RS2 & RS2+ as Base & Rover respectively.

When I started using these 2 receivers I was getting an optimal range of up to 1 km in very sketchy circumstances. Over time the range has just gotten worse & worse and now it is at an all time low.

Switching them around has not improved the range. Changing the radio parameters has not improved anything. Today, I even tried using them without the OEM LoRa antennas 1 at a time to see if perhaps one of them had a busted antenna connection. The range reduced to 10m so I guess that is not the problem.

I have tried aftermarket antennas, that seemed to improve, but not for long.

There is only 1 thing left to try and that is to re-flash the firmware on the Base receiver (I already flashed Firmware on the Rover last week).

I will try that tomorrow and hope it works.

I will be posting the results here.

3 Likes

Curious.

You have 2 M2s.

Do you also have 2 LoRa radios for them?

If so… do you have these same issues with those? Good thing though if external LoRa radios fail over time, can always get new ones for M2s.

Very odd… you used to get 1km in rough conditions now down to 100m in ideal conditions??? :woozy_face:

1 Like

Wonder if the LoRa components including the Power Amplifier are degrading/failing over time of long use?

But that would not explain the case for new RS3 units unless using lower grade components but would assume the same as before?

1 Like

Hey Tim
I bought the M2s to make a base station (which i still haven’t done) and also to be used as a back up field system if needs be.
I have a single LoRa radio.
I have tested these systems but they are not in every day use.
I made reference to them simply to point out that i have a functional knowledge of the Emlid RTK receivers.
In my testing, the M2s worked well.
I have not used them in some time as the circuitry for the Metta housing that I bought to be used with the M2 went bad.
I agree with you- very odd results.
My last experience with Emlid customer service was disheartening since I was made to feel that because the conditions were not perfect, (there were power lines & trees visible in the photos I sent) then these could have been at least partially responsible for the poor range. The site had clear line of sight and clear of the sky. I don’t see how any real world situation could be better than that. I was not able to achieve a 70m fix that day

1 Like

I have considered that as a possibility.
I have also noted that I am no longer able to connect my mobile devices on Emlid Flow via bluetooth
Also, the Emlid Flow wifi connection “disappears” after some time.
In order to reconnect, you have to restart the receivers.
Very odd behavior

1 Like

I’d use the M2 (and if u have an antenna to connect to it though?) with external LoRa Radio to test and systematically rule out between equipment.

Very odd as you used to get 1km, but now hardly that in comparison.

I agree, high voltage power lines etc will cause interference… but sounds like that response about it was unreasonable.

2 Likes

I plan to use the M2 as an independent check.
However, I don’t have a suitable housing at present so field testing is a bit clumsy hence my delay in doing so
The power lines and trees were not in locations that should adversely impact on GNSS observations. They were visible in the photos, but where the difficulty was observed getting Fix measurements was unrelated

2 Likes

You dont need a case. Hobble it together with velcro straps :stuck_out_tongue_winking_eye: All that matters is the antenna plumb and correct antenna height for a FIX to test.

2 Likes

Yeah. A real clumsy arrangement. I will get to it :saluting_face:

2 Likes
2 Likes

This is my early days of the M2’s, I was using the helical antennas at first, then I bought the NGS calibrated Harxon antennas for both. I had the receiver and small battery in blue bag. I still use this setup occasionally. I’ve got the Lora radio’s also. They provided pretty good range about 200m through dense woods, a little longer in the wide open. I think our terrain and woods was a factor in the range of the Lora, but I’m satisfied with the product. I’ll have to break them out of my “office of knowledge” (aka, ‘office of many things’) for a project in the future.

4 Likes

Exciting Discovery
I flashed the firmware on the RS2 and no improvement in the 100m range between RS2 & RS2+

So today I fired up the old M2. I intentionally did not allow it to update the firmware to 31.8 - So it is stuck at 31.2.
I was able to get a FIX from BOTH the RS2 & the RS2+ (using each as a base at over 200m).
I would have ventured further but no need since the respective RS2/RS2+ Rover had lost Fix at 100m during the same session.
Does this mean the problem is with Firmware 31.8?
Emlid, I really wish there was a way to reverse the firmware updates to the previously functional one. Please make this a feature of Firmware Flash Tool software

3 Likes

Was going to suggest that also… reason being is why is this issue happening across ALL the devices and other users devices? Too coincidental? So was thinking the common factor may be the firmware?
Glad you are able to test things!

3 Likes

So I’ve just successfully achieved Fix solution over a baseline exceeding 500m
Using the M2 on old firmware as a base.
I should note that these receivers can top this baseline distance, but the topography here would not allow for longer line-of-sight.
Used the RS2 & RS2+ as rovers simultaneously getting almost identical results.
Emlid Developers - Please make it possible for us to roll back firmware
This will allow us your loyal customers to reduce down-time and to help troubleshoot problems such as this quickly.
Thanks in advance.

2 Likes

Reading between the lines could it still be a transmission problem specific to the RS2 device you updated, e.g. the 31.8 update could just be coincident?
Good job pursuing this one.

2 Likes

Yes
Having the ability to roll back firmware would permit that

All this is strange as we just used 4 RS2s with 31.8 for almost two weeks in the field and got ranges of >500m with no issues (except a loosely screwed in antenna on the base once that reduced the range drastically).

We even had less than optimal sites with no direct line of sight (small hills) and had communication at >300m.

3 Likes

I agree. It is extremely strange that some users are enjoying these results while others aren’t.
What you have been experiencing is what i expect from this equipment.

You state you have 2 M2 receivers. Do you have 2 LoRa receivers also for both also to test between them only?

1 Like

No. Unfortunately i only have a single LoRa

1 Like