RS2 charging issues

Hi,

Are there still issues with the battery-level indication/charging?
Yesterday evening, after a power-off and connecting the charger, the RS2 showed 2 dots (blinking), so it could charge overnight. However this morning… still 2 dots blinking…

I’m now wondering if the unit got charged (and it’s only a false indication), or if the charging is broken…

Any advise?

1 Like

I have seen strange behaviour as well but usually ours will either - only charge to 4 and then show 5 when turned or charge to 5 and almost immediately drop to 3 after 10 minutes of use in the field.

It hasn’t caused any issues really and they operate all day easily but it does cause some doubt as to the actual status. I would prefer not the charge them every day if I could comfortably run them down to 2 or 1.

2 Likes

My charge and temp info is blank after 26.3? May be related?

Thanks for the feedback, looks like they are still chasing some charge-state issues.
However this looks something different.
Since I was aware of the bad charge-state indication (and there were 2 overnight charge attempts from different power sources), I advised to use it and see how long it would run. Seems the device was empty after 3-4 hours, so it wasn’t charged. Putting it back on charger, after some time, the unit started booting… so I guess it started charging again.
Anyways, the user will bring in the unit. Then I’ll try to charge myself, and probably run a system report.

@chascoadmin : the unit is mostly charged as you describe, use it till 2 leds left, and then charge again. However I think he can only use the device 1-2 (full) days before it reaches the 1-2 leds (need to verify with him). Also I thought lithium batteries would reach more charging cycles if the charging cycles are done between 30-80% (avoiding the low/high charge limits and high temperatures).

@PotatoFarmer : iirc, the unit is running 2.26.0 (think I updated the firmware shortly after 26 was released, will verify when the unit arrives )

1 Like

LiPo’s are definitely more stable when it comes to battery memory but from using them across everything from GNSS equipment to RC race cars and drones I can say that they are not invulnerable. Most companies recommend a 40-50% resting charge for storage and not less than a 20% final capacity. I don’t think it is that important with GNSS equipment because of the low draw but with the others batteries quickly degrade. What are the specs of the chargers you are using? Are they quick-charge 3A capable? I have seen that anything less does not work reliably.

1 Like

I totally agree

Maybe here you’ve got a point. At my desk I’m just using a 2A quick-charge from another product. (2.5A@5V, 2A@9V, 1.5A@12V), but I never had issues charging with this charger (except the infinite blink 5th LED-issue). This particullar device has always been charged with a regular 10W 2A@5V phone-charger.

But according to the user, he only gets 8 hours of use an a full battery (is using Bluetooth, WiFi & all constellations (I think at 5 or 10Hz).

Anyone else has this experience? the product page mentions ‘Charging: USB Type-C 5 V, 2 A’, So I guess that would be sufficient

I know their spec says 2A but in our experiences a 3A is more reliable. Either way if you have successfully charged before an update and then it got weird I would assume it is the latter. A challenging environment and 10Hz will eat up more battery so 8 hours of continuous use isn’t all that bad. Just don’t let it run when you are using mostly because it will continuously scan for the radio connection and corrections.

I wish it was that easy, but there was no update, same hardware/software/charger for months. It just stopped charging. (Will try some other chargers/cables once the unit arrives here)

You’ve got a point with the 3A I think, The docs do say:

To charge the receiver 5 watts is required. For operating 7,5 watts on average is required (10 watts maximum).

So 10W-charger is probably on the low side as well.

Hi Andy,

Reach RS2 should be charged fine with USB-C 5 V 2 A. I’d suggest checking if the issue persists when they charge the unit with another USB-C cable and connect it to a stable power supply like a wall adapter or PC.

Please ask the user to conduct a battery test. It will allow me to evaluate the actual battery performance. They can do it as follows:

  • Turn on Reach, connect it to the power supply and charge it overnight (at least 9 hours)
  • Disconnect the charge and wait until Reach fully discharges and turns off itself
  • Connect the charge and turn on the device
  • Generate the Full System Report and share it with me. They can download the report from Settings -> General -> Troubleshooting -> System report -> Full report .

Full System reports can contain sensitive information, so I’d recommend sharing them via support@emlid.com.

I just received a brand new RS2, I’ve put in the charger and booted the device.
It had FW v26.2, so I was forced to update to v26.4 during initial boot.
After updating/rebooting, I immeadiately checked the battery stats, but they look OK:

Maybe time to upgrade as well?

2 Likes

Definitely,

I must of upgraded to 26.3 a couple days before 26.4 lol

1 Like

But I can confirm that in 26.4, the led keeps blinking while reachview reports a charging current of 0 A:


(now I’m going to pick up the ‘broken’ unit)

Hi @kseniia.suzdaltseva

Problem is that we’re unable to charge the unit. The user already tried 2 times an overnight-charge from 2 different power sources (but same usb cable/charger).
I quickly tried with 2 other USB-cables/chargers, plug it in and wait a couple of seconds for some LED’s to start blinking, but nothing happened. None could get the LEDs start blinking in 10 seconds RS2 :frowning:

So last attempt was to put it on the charger/cable I just used to charge another RS2. I left it overnight, but the RS2 is still dead.

  • Any other ways to charge the device?
  • What type of connector is the 9-pins? maybe I can quickly find one in a local store and try to power it this way? (docs only state ‘9-pin’, but is there an official name, so I can search for the correct one?)
  • Now the battery is totally empty. Should the 1st LED start blinking immediately when it starts charging, or is there some ‘dead’ time, so it can reach a minimum-level of charge before it shows a sign of life ? (I have some other devices which need to charge ca 5 minutes before the charging indication starts shining when charging from 0%, is the RS2 similar?)

Better news:
I went back to the basics… I tried cleaning with compressed air (although it looked clean).
I plugged the charger… and there was light :slight_smile:

So now, I’ve got the answer on the last question, the devices boots as soon as receives power.
I’m still interested in the answers of the other 2 questions:

Hi Andy,

Thanks for keeping me posted! Glad to hear that the receiver can be charged fine now.

Any other ways to charge the device?

Reach RS2 can be powered either via the USB port or the bottom connector. I’d suggest checking our Power supply guide to learn more about the second option.

What type of connector is the 9-pins? maybe I can quickly find one in a local store and try to power it this way? (docs only state ‘9-pin’, but is there an official name, so I can search for the correct one?)

We use a custom 9-pin connector. It looks similar to LEMO, but they are different and won’t be compatible. You can get the connector from our online store or one of our dealers nearby.

will the external power through 9-pin also charge the battery? (cannot find it in the guide/docs)

Nearby is already in another country :frowning: I wanted to avoid waiting multiple days, but now the unit is charging again. I’ll order a cable ‘just in case’ I need it another day…

Initially I didn’t expect the connector to be a problem, because the connector has pretty good seals. Probably dirt got captured inside the connector on the cable and was ‘pushed’ into the connector of the RS2… Sorry for bothering you with this, hope this experience can help others…

Edit/Question: Is the angled external adapter compatible with the RS2 ?

I updated to 27 last night and now the charge indicator only goes to the 4th LED.

1 Like

Bad news,
Seems dirt wasn’t the (only) issue.
Since the previous ‘solution’ the RS2 had been used for a full day of work (without recharge).
As far as we can remember, the device was charged before the weekend, but was found empty after the weekend… (no idea if it was self-discharged/not charged, or we forgot to turn off).

Also the next charge was too fast to be realistic. (same for the discharge)
No Idea what’s going on… Will try do the charge/discharge-cycle/system-report overnight.

Edit: And charging seems to be stuck at 2 LEDs again

I took the RS2 for some more diagnostics, and found some disturbing battery/voltage figures.
I plugged in the RS2 into wall socket for charging, the device was showing 1 orange LED (so indicating Low Battery).
While plugged in, I powered on the RS2 and took a look in reachview at the battery status, which was showing a Voltage of 7.30V, combined with a ‘State of charge’ of 1%. and a slightly negative charging current. It looks like the device doesn’t want to charge, while still drawing current from the battery. (which could explain why at noon the device kept blinking at the second led - without actually making progress, and after the full afternoon connected to wall power it only had the red light left…)

When disconnecting wall power, I see the voltage dropping relatively fast (to 6.7 V in 3 minutes)
When plugging back in I see periods of positive charge currents (0.25A), with short moments of small negative currents. A couple of minutes later, I’m back at a stable negative current.

How should I proceed for a system report? (since the device doesn’t charge to 100%)?
@kseniia.suzdaltseva : I’ve send you a full system report of this state stuck at 1%.