ReachView v2.21.1 for Reach RS and Reach RTK

Hello, guys!

We are releasing a new very important upgrade for our Reach RS and Reach RTK. The release finally brings ReachView on all of our devices to the same version.

You can take a look at the improvements in the release message for ReachView v2.21.0

Updating your Reach RTK and Reach RS

In order to update your device to the latest version and receive further OTA firmware updates, you need to perform a good ol’ firmware reflashing described in our docs.

The newer stable release for all devices is going to be available soon.


Does this include the RS+ as well?

This update only relates to the original Reach and Reach RS.

RS+ can be updated to v2.21.0 via ReachView app.


Good morning
I have 4 reach rtk’s tried to reflash one. The flash program never connects to the reach?
Windows 10 and reach rtk connected with usb cable

Hi, thanks for the report.
Have you installed Intel Edison Drivers ?

We will add this step to the docs.

1 Like

No I did not. I thought that it was not necessary for the new updater program?

I do not see the flashall.bat ? where is this?

Hi, @jmcarthur!
You don’t need anymore flashall script, just run Emlid Flash Tool and choose downloaded zip archive. The process of flashing will start automatically after connecting the device.

I must be doing something wrong because it never connects.

I suspect that the problem might be connected with not providing enough power to Reach to boot. Did you previously successfully flash your device with the same cables and the same computer using flashall script?

This is on a desktop have not had to reflash these units for several years.
I just tried another unit and it did connect the flashing started and went quickly to about the middle of slider and is now sitting still for several minutes and the light on unit is sitting still solid blue pink color

I have not had any luck with the flash tool either. I cannot get past the Disconnect step. nothing is connected to the computer (Win10) yet it keeps spinning at Disconnect all Reach units and won’t go past this step.

1 Like

Hi @jmcarthur, @codyrh,

May I ask you to share flasher logs so we can check them and understand what may cause the issue?

To access flasher logs on Windows, you can follow these steps:

  1. Press Win + R
  2. The Run window should appear
  3. Paste this string into the Run window: AppData\Local\Emlid\Reach Firmware Flash Tool\logs

It should open the folder with flasher logs. Please send them to us.


Hello Tatiana

Attached are the log files. The first few are of the !st unit that did not connect. The last few are of a different unit that did connect but half way thru the update process the unit turned off, came back on and the update never resumed. (26.1 KB)

Attached. The first few were from when I was attempting to update my M+, I eventually was able to connect to wifi and update that one. The rest are from the RTK. (9.1 KB)

@gleb.gira Hi Gleb !!!Could you improve the stakeout system? Indicate two directions of measurements.
Staking is very difficult.
0.50 meters north, 0.10 meters east. It would be very helpful
Thank you luis

1 Like

Hi all

any suggestion ?



I have win 7


They are working on fixing it. They will let us know when fixed probably here.

4 posts were split to a new topic: Issues with connecting to Wi-Fi on v2.21.0