Reach RS2 and FG for Android

I’m testing out Field Genius for Android (10day trial) and the RS2. I’m not having success keeping the RS2 connected to FGA over Bluetooth for more than 20s. It repeatedly bumps to disconnected and wants me to reconnect. I’ve opened a ticket with microsurvey, but wanted to know if anyone here had success and what settings were used (or maybe success on a different android tablet). Here’s the setup:

Reach RS2

  • Position output via NMEA to BT
  • RTK via NTRIP to the Florida Permanent Reference Network (using GPS, GLO, GAL)
  • Update Freq: 1Hz
  • BT linked to Tablet

Field Genius:

  • Version:
  • Build 2019-08-02
  • Instrument connection: NMEA Basic over Bluetooth


  • Samsung Galaxy Tab A 8" (2017)
  • Android 8.1

I can successfully connect the RS2 to FG 10 via BT on my laptop and I can connect the RS2 to the Lefebure NTRIP Client on the Samsung Tab A without problems.


hmm… then maybe something in the ReachView app? or a combination of BOTH the ReachView app and FGAndroid?

OFF TOPIC for a sec… do you see anywhere in FieldGenius for Android if it has GNSS Localization or anything similar? ANd also Rotate Translate & Scale functions?


The site localization feature says “coming soon” when you click on it. I wasn’t able to see in the interface Rotate, Translate, & Scale…but I haven’t spent much time with FGA other than trying to troubleshoot the BT connection problem. Main functions right now seem Survey + Linework and staking. Also, orthometric heights are not yet implemented.


@Africawaterdoc. Thanks! So it’s not “primetime” yet.

@tatiana.andreeva When trying to connect the RS2 to Field Genius - Android over Bluetooth it connects, posts it current state to FG (I see the satellites, position, etc) and it disconnects (won’t hold a connection longer than 20s). See my post :point_up_2:. ReachView is giving the following on the Position Output page:
(1) When I tell FG to connect to the instrument it initiates the connections and says: “connected to local host”. FG receives a few updates from the RS2
(2) Within 20s, FG disconnects and ReachView gives: “send error(32)” for 2s
(3) Then it reverts to “send error (111)” which I know means there is no connected NMEA receiver.

But what does send error(32) indicate? It might help me troubleshoot with microsurvey. Thanks-

I was talking to micro survey about the andriod version ( i have the windows version ) the sales guy said why switch if you have the windows version? It is still a lot better and has more capability . The andriod is for guys that are just entering into FG and who are not using all the functions . Thats my knock.

Yeah, the Windows FG version is superior as it is WELL ESTABLISHED. The Android version is in it’s infancy so no time to deal with that until it’s fully developed over the next year or so.

The thing with the Android version is it may be a little more intuitive and also help with battery life using a good Android tablet. Probably much better fending off over heating problems in the field also compared to a full blown resource hungry Windows tablet or Surface. (And cheaper of course).

The Surface is fragile and not really ideal for outdoor ruggedness… but you can obviously ruggedize it… but not many choices and get expensive compared to Android tablet rugged options. Display brightness isn’t ideal either. So “maybe” possibly more options in this area with Android tablets? Or better yet, iPad use with bright outdoor display with more rugged options when their iOS version is ready.

Hi @Africawaterdoc,

At the moment, it looks like this issue is from Android FG side as, according to your tests, Reach RS2 connects fine to Windows FG and Lefebure app.

We’re in touch with MicroSurvey support regarding this question now. Currently, may I ask you to provide us with a detailed description of all your step-by-step actions when you’re trying to establish the connection?

“send error (32)” indicates a broken pipe, and “send error (111)” means that the connection is refused.

Broken pipe error usually occurs if the request is blocked or it takes too long to get a reaction.

1 Like

Sure, I’ll be as detailed as possible and I’ll start from a clean state (all previous pairings ‘forgotten’):

Method one (try to pair from within FG)

  1. Power up RS2, Samsung Galaxy Tab A (2017), and computer
  2. RS2 connects to local wireless (same as tablet and computer)
  3. Computer logs onto ReachView v2.20.7 via local network (for configuring RS2 and monitoring RS2 side)
  4. Set RTK Settings: Kinematic, EMA 15 degrees, SNR-M 35, GNSS selected: GPS, GLONASS, GALILEO; Update Rate: 1Hz
  5. Set Correction Input: NTRIP to Florida Precise Reference Network (Station KREG - RTCM 3.1 MSM4) All confirmed as working and allowing RS2 to gain FIX. Approx tested baseline is 15km)
  6. Position output 1: Turn On, Set to BT, Format NMEA (states send error (111) - expected because not yet paired)
  7. Base mode: off
  8. Logging: on
  9. Mobile Data: On, connected to TING 3G for NTRIP streaming
  10. WIFI: On, connected to local network (or hotspot if away)
  11. Bluetooth: Turn on, Turn on always discoverable with PIN code [123456], states no paired devices, shows several discoverable devices including Samsung Galaxy Tab A and computer. (in this method I try to pair from FG menu only)
  12. Launch FG android
  13. Set new project up: Name: test, Distance: meter, Angle: Degrees, Coordinate: FL83-E (Florida state plane, meter), Vertical: ellipsoidal WGS84
  14. select instrument: Add profile; select GNSS rover; Make = NMEA, Model = Basic, Profile name NMEA-Basic, select create
  15. click set up communication, choose Bluetooth, search for device, select reach, select connect. FG states connecting to instrument. [NOTE I am not asked to enter a passcode or anything]. Unit connects.
  16. set up corrections: no RTK [handled by RS2 internally]
  17. set up antenna height [2.134m]
  18. use default
  19. FG android GNSS Rover Profile page shows:
    connection, satellites [12], PDOP [2.5], click done, back
  20. FGA shows location on map, and position text, option to record point ,etc.
  21. in less than 20 seconds, position and coordinates disappear without message. Righthand side of FGA changes to: select instrument or reconnect. Selecting reconnect connects again for less than 20s. And reverts to Select instrument/reconnect. Every time I hit reconnect, it connects, shows the position/option to record. And disconnects within 20s. Doesn’t matter how close unit tablet are to each other.
  22. on reachview position output page. when connected it shows: connected to local host, within 20s, it shows send error (32), then send error (111).

method 2 (pair devices first)
steps 1-11 above are the same.
12b) From Reachview Bluetooth tab select Galaxy Tab A from discoverable devices
13b) Tablet receives pairing message. Select OK. Now tablet and reachview show that they are paired.
14b) Launch FG android (new launch after previously closing down)
15b) open project, select instrument, add profile, gnss rover, make = NMEA, model = basic, click create
16b) click set up communication, Bluetooth, search.
17b) select reach
18b) set up profile as before
19b) same result, disconnects within 20s.

Random note: When connecting the RS2 to my computer, the prompt asks if the PIN on the device matching the one displayed. Every time, it shows a pin that is different than 123456. haven’t been in a situation where I’ve been asked to input a pin and needed to use 123456.

other note: I have two RS2 units. Same behavior on both.

1 Like

You’re not alone @Africawaterdoc I’ve been testing FGA over the weekend on a Samsung Galaxy Tab Active 2 with the exact same disconnect issue with Bluetooth.

I have tried using the NMEA and Reach RS instrument settings within FGA, but the behaviour is the same - disconnects after approx 20 seconds, which make setup, let alone use, of FGA with an RS2 basically impossible.

I will also email MicroSurvey support to see what they say.

1 Like

I use a very good topography application, also on androit, it’s topview.
You can request a free 20-day trial. You can buy license for two days with paypal.


Yes, it is also in English, you just have to select the language in the last menu marked with the symbol:?

Hi @Africawaterdoc,


I’ll keep you updated.

I don t find the english button!

the last button on the right of purple that has the symbol “?”.
then click on the second option: Serial No., user …
there you select the language

There is 9 buttons below BETOP meny!

No one shows what you write!

What button do you mean?

top right, purple button.

now the second option: serial number, user …

now display language

download the application directly from the

topv page

My button is blue!

The link did not work!