Reach RS not turning on


I need help. I haven’t used my Reach RS in a while. This morning, I went to charge both units. My rover charged, no problem. However, the base is not charging. I have used a variety of USB cords (including the one that came with the device) and 1 amp chargers (including my laptop). I also tried the combination of cords that I used to charge the rover to try to charge the base. No luck. I have also tried to push the power button for 15 secs to reset. No luck. Other options?

Also, just to provide additional info… When the base is plug in and I push the power button, I hear a very slight whirring sound.


I am sure you already seen this thread:

Mine did that at first also. But the battery was dead and charged it and came back on after a few tries. I thought it was a goner also… but after a few tries it was good.

I love these Emlid Reach RS units, but you do get what you pay for I feel. When I say that, there are features of the big dog GNNS receivers I wish the Emlids had…i.e. removeable battery, some have (2)!

I think the NEW “PLUS” versions show the power light on when charging, which is dumb the non-PLUS do not have… you’d think a firmware upgrade could easily implement that? Either way, plug it in and open ReachView and see if it indicates charge if somehow? Reboot, power down etc? probably won’t until it powers and connects…but worth a shot.

What irks me the most is USB micro-b connection. That type is so unreliable after constant use, either cable itself or connector, then it’s all over. Would be nice if everything was micro-c by now.

Thanks timd1971. I had seen that post. But, I have tried multiple chargers at this point, including my laptop (which is only a couple of months old) and no luck. I let it sit while connected (c. 30 minutes with each attempt) - thinking that it might take a little time before the charging registered. No luck.

not sure…but 6 month warranty? depending when you bought them and where?

This may also be a “feature” of them new charger. They are so smart and when a empty battery is supposed to charged, the charger thinks there is no battery because it can not detect any and thereby not start charging. Not sure this is the case but i had similar happens to me lithium and Lipos before. I usually give it few tries to get som umph into the battery so it would be detected by the charger. It might help connect it to a dumber charger for few minutes :stuck_out_tongue_winking_eye:

did you try maybe a different power transformer adapter? i.e. one that comes with a iPhone or Android phone? I think those have 1A or 2A 5VDC? Not sure…but maybe the Laptop at 1VDC is not enough to get it over the “dead” threshold? But your other one is fine though? But did it charge to 100%?

Thanks @TB_RTK . I don’t have a “dumper” charger (I think I know what you mean, but I definitely don’t have anything, but the basic chargers). And @timd1971, I definitely tried an iPhone charger and my original Android phone charger (both 5V and 1amp). I didn’t realize that the laptop was only 1V. Which leads to another question, why didn’t it come with a charger? Then there would be no question. I would have two (since I have 2 Reachs- rover and base) and could test them against each other. As it is, I have tried enough chargers and cords to believe that it is the device not the cords/ chargers. Any further thoughts? Any thoughts on the slight whir or buzz that I mentioned in my first post?

Lot of devices do NOT come with that portion…I guess these manufacturers “FIGURE” you already have extra ones layong around from old iPhones etc. who knows.

I don’t know if the laptop is 1V.

If it’s under warranty, check with that first. Personally after exhausting all options…I’d open it up to see if loose cable or something to that matter. So I assume it doens;t even turn on when plugged in charging?

My kids have a old Samsung Tablet and the micro-b charging port connectins peeled up and no longer connected to a cable… but I was able to do some micro surgery on it and it barely connects now…again, I hate micro-b usb connections… should be micro-c these days. get a magnifying glass and look at the connectors to make sure they aren’t shorted together or missing on either end… hopefully not so on the Emlid side.

the “whir” or buzz may not be a good sign? something awry in the power portion?

some pix at end of thread here of the guts of the RS. Not sure where the battery is?

Thanks @timd1971 . I hear you re: usb micro. I have used USB-c only once and it is much better! But, this issue has not been resolved. I’m hoping someone from Emlid will chime in.

Hi Ben, I’ve sent you an email!

Let us know how it turns out! ; )

Just to post a resolution. The Reach RS simply would not turn on. @dmitriy.ershov and I communicated through email and, under his direction, I opened up the device. However, the suggested fix did not work and @dmitriy.ershov was able to send me a replacement device. So, now all is well, even though no one knows what happened. I appreciate the excellent service provide by @dmitriy.ershov and by Emlid in general. Cheers!


That was very nice of him. Glad they helped you out.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.