Using LoRa to connect rover and base

OK, and the frequency is 1Hz, 0.1Hz, 1Hz respectively? If so then good.

Set the radio speed at the highest frequency. See how much range you get. Then drop it down to the next lowest speed and see how much further you get. On the status page, watch that your age of differential time is not ramping up beyond a few of seconds. Find the slowest radio speed where the age of differential does not get too high, and that is where your maximum range should be.

We tried a similar method. We will try this and post the outcome.

-Trey

There are users with many different levels of experience so this question might be too basic but are you 100% sure your correction data is going over your LoRa? It almost sounds like your correction data could be over wifi somehow. Of course, this is probably not the case but I just wanted to make sure. It would only happen if you had some things accidentally turned on. It wouldn’t be the first time it has happened.:wink: Just making sure.

2 Likes

This is a peculiar case. I will ask you to provide the following:

  • Two simple systems reports - for both base and rover. The setting on both Reach units might give some clue on what’s going on.
  • Some photos of your setup and the testing space. Don’t take this the wrong way, but do you have the LoRa antennas on?
  • Logs from the rover, if you have any. The position log contains age of differential info.

How exactly did you establish that the link was lost? What was the main sign?

Overall, I would recommend setting both output power and air rate to the max. The range limitations of the maximum air rate will not kick in until a very serious distance. Big air rate, however, allows for a more stable correction channel.

1 Like

That is totally not too basic of a question! Thanks for asking!

What we are doing is taking the base and rover off the wifi network and turning their hotspots on and connecting our phones to that network so we can read the data…

Does this answer your question?

Thanks. That sounds like your theory is right! As @egor.fedorov already mentioned, the two simple systems reports or some screen shots of your settings would help us help you!

To answer your questions:

  1. We do have the antennas connected.

  2. As far as telling when the link was lost is when we look at the status of the rover and it loses the grey bars on the graph. From what we have read, the grey bars indicate that is connected to base unit.

The other requests you made I can take care of when I get back to office on Monday…

Thank you for your time!
-Trey

1 Like

Screenshot settings for Rover:

1.)

2.)

Screenshot settings for Base Station:
1.)

2.)


When we are getting our data from the Status graph, we are staying with in visibility of the base station. (Even though it shouldn’t matter using LoRa)

If there is any other information you want me to provide, please request.
Thank you.

-Trey

1 Like

Base system report:

Simple system report
app version: 2.10.0-r0
'wifi_status, interface: wlan0':
- Client state
- IP address: 192.168.131.201
  mac address: 90:b6:86:04:a3:bc
  ssid: Clearpath Base Station
base mode:
  base coordinates:
    accumulation: '15'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: true
    format: rtcm3
    path: lora
    type: lora
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1008':
      enabled: false
      frequency: '1'
    '1010':
      enabled: true
      frequency: '0.5'
    '1019':
      enabled: false
      frequency: '1'
    '1020':
      enabled: false
      frequency: '1'
    '1097':
      enabled: false
      frequency: '0.5'
    '1107':
      enabled: true
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
    gps:
      enabled: false
      frequency: '1'
    qzss:
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: true
  pin: '***'
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: SGUGAtifton:***@107.7.166.152:8080/Glonass_RTCM_30
    send position to base: single
    type: ntripcli
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: false
    version: null
  correction:
    format: RTCM3
    started: false
    version: null
  interval: 24
  overwrite: true
  raw:
    format: RINEX
    started: false
    version: '3.03'
  solution:
    format: LLH
    started: false
    version: null
lora:
  air rate: '9.11'
  frequency: 1000100
  output power: '20'
position output:
  output1:
    enabled: false
    format: nmea
    path: ttyGS0:9600:8:n:1:off
    type: serial
  output2:
    enabled: true
    format: llh
    path: :2013
    type: tcpsvr
rtk settings:
  elevation mask angle: '20'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzs: true
    qzss: false
    sbas: true
  snr mask: '35'
  update rate: '5'

Rover system report:

Simple system report
app version: 2.10.0-r0
'wifi_status, interface: wlan0':
- Client state
- IP address: 192.168.131.202
  mac address: 90:b6:86:03:8a:70
  ssid: Clearpath Base Station
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: false
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1008':
      enabled: false
      frequency: '1'
    '1010':
      enabled: true
      frequency: '1'
    '1019':
      enabled: false
      frequency: '1'
    '1020':
      enabled: false
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
    gps:
      enabled: false
      frequency: '1'
    qzss:
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: lora
    send position to base: 'off'
    type: lora
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: false
    version: null
  interval: 24
  overwrite: true
  raw:
    format: RINEX
    started: true
    version: '3.03'
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: '9.11'
  frequency: 1000100
  output power: '20'
position output:
  output1:
    enabled: false
    format: nmea
    path: bluetooth
    type: bluetooth
  output2:
    enabled: true
    format: llh
    path: :2013
    type: tcpsvr
rtk settings:
  elevation mask angle: '20'
  glonass ar mode: 'off'
  gps ar mode: continuous
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzs: true
    qzss: false
    sbas: true
  snr mask: '35'
  update rate: '5'

Thanks for sharing the photos and system reports. I’ve just sent you an email.

You gonna let us in on what the problem was?:wink:

We have not figured it out yet. About to test in an empty field to see if we are getting the same problems; if so, it will probably be hardware issue. All the settings are set correctly.

We will post solution as soon as we have one. (right after we jump up and down for joy of course)

2 Likes

We have resolved the issue.

One of our Reach RS units was messed up. We are guessing that the LoRa radio transceiver inside was the issue. We cut both of them on and used a tool that reads the frequency coming off an antenna. When we did this we got some weird numbers for the Base Reach RS unit. So we tried the LoRa radio on two other units and excluded the one that we got a weird reading for and the LoRa radio worked fine.

Thanks for the help and feedback along the way!

Best,
Trey

3 Likes

~Inside of the base unit that we were having trouble with is what pictured below~
I think we found the source of our issue.

(just in case you can’t tell) The antenna was not plugged into the internal LoRa radio.

3 Likes

Yeah, i have heard that can cause some problems :sweat_smile:

2 Likes

@treybr3 Wow, this is pretty bad. Very sorry about this situation. Could you please pm me a picture of the barcode on the bottom of that RS so that we can investigate?

2 Likes

Thank you! Is everything functioning normally after you connected the antenna cable?

Yes, thank you!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.