Reach RS+ Green status light continually blinks

Hi Richard,

I’ve received your Full System Report on the unit, thanks! We’ll check what could have caused the issue with the time sync.

9 posts were split to a new topic: Reach doesn’t pass the time sync


Just wanted to give you an update on this case. We’re working on the fix for green LED behavior issue. I’ll inform you once the update is released.

If your Reacgh RS+ starts experiencing this issue again, please, reach out to me straight away.

@polina.buriak Hi Polina! my RS + started to fail, the green led started flashing. It started with version 2.23.7, before it had 2.18.1 and it always worked very well. Something is causing rechview to run internally wrong.


Thanks for the report!

Currently, we’re working on solving this green LED behavior. I’ll reach out once there’s an update is released.


Hey everyone,

We’ve released the new v2.22.6 firmware update that should resolve the issues with the green LED blinking behavior. I’d ask you to update to it and check if it works for you.

To update, please go to the Updater page on your browser by typing the following to the address bar: Reach's_IP:5000. You will need to connect the device to the Wi-Fi network so that it can download the update.

Please note that the fix for this in the dev branch will be in the v2.23.9 version. We’re working on the releasing it as soon as possible. I’ll update you once it’s available.


Yesterday I updated the equipment, did tests and everything worked correctly. Today, the problem returned, the green led is not solid.

Hi, everyone…

Not to pile on, but I’m actually having the same problem (blinking green LED) on both our Reach RS+ units.

For what it’s worth, we hadn’t used them for some time and yesterday I broke them out to update them. I downloaded and installed 2.22.6 (I think… whichever one was available yesterday afternoon) then tested them out after that. This morning, I turned them on and they’re both blinking green with no way to connect to them.

Any suggestions? I can do a firmware flash if need be, but I wasn’t sure if there was another option.

Thank you -

@operacion @mmiller


Do you remember the version you updated from? Do you bump into this issue every time you turn on the device?

in version 2.22.5 I had the problem, with the new version yesterday it worked, today the green led is not solid.

I believe that I was updating from Version 2.18.[something]. It had been a bit since we’d needed the units so they hadn’t been updated. This is the first time that I’ve encountered this issue.

@operacion @mmiller

Thank you for your prompt reply. Could you please tell what are the statuses of other LEDs?

If the device turns on, we’d be glad if you could share the Full System Report by sending me a private message.

1 Like

the other LEDs are solid, the green LED is never solid.
The reach viewer cannot be entered because the green led is never solid, so I cannot send the report. Before I only had that problem with the base, now my rover and base have the same problem.

1 Like

What a shame that it continues to happen with version 2.22.6

I updated to v2.22.6 as I had several start ups where the green light turned solid green after starting so I could access the software. It still worked after re-booting and I set it up for a survey the next day (yesterday). Sadly, the same issue returned and I could not carry out the survey. I tried throughout the day but the green light kept blinking. I set it up on my window sill this morning and it started correctly. Very frustrating.

I’m afraid that I’m unable to connect to either of our RS+ units through ReachView. Unless there’s another way to access the full system report, I’m going to be unable to get it.

Regarding the status lights: They’re on and solid. The green one is blinking.

Hi, @george.staroselskiy -

I saw your announcement of the dev release 2.23.9 that lists what I interpret is a solution to this particular problem. Would you recommend that I reflash the firmware and then get this update?

Thank you for your help.

Hi! The v2.22.7 is already on the way and is going to be released today or tomorrow, so I suggest waiting for it. Furthermore, if I understand correctly the ReachView is unaccessible for you now and there’s no easy way to install v2.23.9 right now as it requires the interaction with the ReachView app.

1 Like

Hey everyone,

The v2.22.7 release is out now. Could you please update to it and check the green LED’s behavior?

To update, you need to access the Updater page at Reach's_IP:5000 through the Internet browser. Just type it into the address bar.

Please keep us informed whether the update resolves the issue for you.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.