Reach RS+ Green status light continually blinks

We have an Emlid Reach RS+ since early 2019. It has worked very well until yesterday. The unit powers up, connects to WiFi but the green status light keeps blinking and does not go solid green. In this state, there is no access to the software. I have turned the unit off and back on again multiple times but with the same result. Can anyone help with a resolution please?

Are you indoors? This usually means the unit isn’t getting enough satellites and is not finishing initializing.

Thanks for responding. No. Each time I’ve been outside with open skies. And it’s even always worked on my window sill when I’ve been setting up projects. Very strange.

I too have occasionally gotten mine to work indoors, but it’s pretty sketchy and the sats have to be in the right place. When you say connected to WiFi is it from the receiver’s hotspot of from another access point? If it’s not the hotspot can you turn off the other source of WiFi and see what happens?

I’ve connected to different Wifi including my home router, a mobile router and my phone’s hotspot in my attempt to see if any of these is producing the problem but still the same. I’ve shut these off to use the receiver’s hotspot to see if that makes a difference but again, the same.

My start up cycle is this and there might be a clue here?
Turn the power on - all indicators light up and then go out except the power button. A few seconds later, the green status light starts to flash and then the blue network flashes and either connects to a wifi signal and pulses or flashes quickly if it can’t find a network, and then solid blue when it activates its own hotspot. All the while, the status light keeps flashing green and doesn’t stop.

1 Like

If it’s blinking about once/sec that’s definitely the time sync portion of negotiating the satellites. I’m at a loss beyond doing a reflash.

https://docs.emlid.com/reachrs/common/reachview/firmware-reflashing/

Thanks. I think I may have to do that.

Hi Richard,

Welcome to the community forum!

Before you reflash the device, may I ask you to specify the firmware version that you worked on? Would it be possible to remember if there was any specific sequence of actions after which the unit stopped finishing the time sync?

Thank you for responding. I’m currently using firmware 2.22.5. As I recall, I used the receiver as normal the day before this issue so I was not aware of anything untoward until I swtiched on the unit the following day.

After more multiple attempts, I have managed to get the recevier working normally today. While I have access to the software, is there anything I could check to determine whether a setting is causing the issue. I fear that once I turn the receiver off, it will not work again. Thanks for any advice.

Richard,

Could you please generate the Full System Report on your unit? Please send it to me in PM as it might contain sensitive information.

Could you also clarify if at the moment the receiver has a good satellite reception?

Hi Polina
I have now been able to generate a full system report and I’ve sent this via email. Thanks.

Hi Richard,

I’ve received your Full System Report on the unit, thanks! We’ll check what could have caused the issue with the time sync.

9 posts were split to a new topic: Reach doesn’t pass the time sync

Richard,

Just wanted to give you an update on this case. We’re working on the fix for green LED behavior issue. I’ll inform you once the update is released.

If your Reacgh RS+ starts experiencing this issue again, please, reach out to me straight away.

@polina.buriak Hi Polina! my RS + started to fail, the green led started flashing. It started with version 2.23.7, before it had 2.18.1 and it always worked very well. Something is causing rechview to run internally wrong.

Luis,

Thanks for the report!

Currently, we’re working on solving this green LED behavior. I’ll reach out once there’s an update is released.

3 Likes

Hey everyone,

We’ve released the new v2.22.6 firmware update that should resolve the issues with the green LED blinking behavior. I’d ask you to update to it and check if it works for you.

To update, please go to the Updater page on your browser by typing the following to the address bar: Reach's_IP:5000. You will need to connect the device to the Wi-Fi network so that it can download the update.

Please note that the fix for this in the dev branch will be in the v2.23.9 version. We’re working on the releasing it as soon as possible. I’ll update you once it’s available.

3 Likes

Yesterday I updated the equipment, did tests and everything worked correctly. Today, the problem returned, the green led is not solid.