Reach GNSS and Pixhawk 4 connection

Hi

What could be correct pinout to connect Reach GNSS module to new Pixhawk4? In https://docs.emlid.com/reach/ardupilot-integration/ description reference made to Serial 4/5, however new Pixhawk 4 doesn’t have such a port https://docs.px4.io/en/flight_controller/pixhawk4.html . Any help?

Thank you!

Hi @rihards.gailums,

It should work if you connect Reach to UART and I2C for additional GPS port (number 12 on the image you attached).

Thank you!
Couple more questions.
We are using Ardupilot / Ardurover and Mission Planner a described here: https://docs.emlid.com/reach/ardupilot-integration/

  1. How to validate that RTK data is being received by Pixhawk? Any value - like GPS2 in real time logs?

  2. When setting up rover unit and base station unit - what are settings of tab “Base mode” should be - ON or OFF? As well on base station - should tabs “position input” and “correction output” should be switched to OFF?

Hi @rihards.gailums,

You can check the GPS2 data in Mission Planner status tab.

Yes, you should disable base mode for rover unit. In regards to the base station, position output and correction input can be disabled too.

A post was merged into an existing topic: Connecting the Emlid reach m+ to the Pixhawk 4

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.