Reach Firmware 29 Beta 3 is out

More observations using the RS2 on a job today.

The Pixel 3 saw both instances of the RS2, wifi and bluetooth. I worked with wifi and after I completed the job, I disconnected the RS2 and reconnected through bluetooth and this time, everything was functional ! During the job (via wifi) I did have one unforced disconnect in about 40 minutes. But it hooked back up when commanded.

I used the new Base > Manual > Point from Project on this job and it worked just fine !

I was using a P4RTK. At first, I tried connecting to the RS2 via Local NTRIP. This time the P4R would not connect. I switched to Emlid Caster and the P4R connected immediately.

I’m trying to be as consistent as possible with my approach but my results are not always consistent. If it is just me, I guess we can chalk it up to the Pixel 3 being “not ideal”

Cheers,
Dave

1 Like

Hello everyone!

We’ve just released the new Beta version of Reach Firmware - 29 Beta 3!

Improvements:

  • Output leap seconds in RINEX NAV logs
  • Add support for NTRIP v2 to the NTRIP local caster option
  • Add approximate position to RINEX Events
  • Improve RINEX logs quality with the OPUS preset

Fixes:

  • Some cases when receiver could stuck in loading
  • Issue when it wasn’t possible to update base mode RTCM3 settings, when NTRIP was selected as base mode output
  • Some cases with an empty RINEX Base corrections log
  • Representation of the current GSM modem mode for Reach RS2 receivers
  • Stop recording logs if rolling logs is disabled and no space is left
  • Solution logs file extension being always LLH
  • Some cases when devices with same names are not visible in ReachView3
  • Some cases with the wrong Bluetooth device name representation after changing the receiver name
  • Typo in the name of the sdun column in *.POS files
16 Likes

Hi Dave,

Maybe it indeed was a one-time issue. Still, we’ll check the report.

About the issue with P4RTK, is it reproducible? Did you connect to Reach’s hotspot or external Wi-Fi?

I will check with the P4R with Local when I get it out next. It’s probably just a one time issue.

Thanks!

1 Like

Thanks! Let us know if it occurs again.

Imagining there is a button in Survey Interface for Start Stop & Go mode and when pressing it, ReachView will take care of correct setting for logging file and duration of each survey point. And when press Stop, all necessary files are packed and download.

Just dreaming :blush::blush::blush:

4 Likes

Hi @l3technologycambodia,

Dreaming is a good thing :slight_smile: I’ll write down your dream as a feature request!

6 Likes

I just updated an M2 and RS2 to v29 B3 and saw a brief flash of some information of projects in the cloud? I haven’t been able to find anything here or in docs yet.

You mean the new Account Sync feature?

2 Likes

Exactly. I’m going to delegate this project to my other pilot. :wink: Thanks!

4 Likes

I am trying the cloud caster with my base connected to my home Wi-Fi and that is all good. Now on my rover it is using the hotspot for my phone and while I can connect I keep getting a read error at the bottom. I am sure everything is entered correctly.

After a little more fumbling around and not getting the RS2 to fully connect to the caster I decided to load up the drone before it got to dark to test. Drone went green in about 3-5 minutes and flew solid. The login error was on my part. I found the documentation and the rover has a whole different set of credentials. :slight_smile:

Now to understand the local caster. I guess it just needs to be within WiFi range of me/controller and the remote gets it directly from the receiver?

1 Like

The Local works by all devices being on the same network. The network, phone / hot spot, does not have to be connected to the www. Example. You are in the boonies and there is not data. You still turn on your hot spot and connect the RS2 and the drone’s remote to the hot spot. Enter the Local credentials and you should get corrections.

1 Like

So even if I am right next to the base I need to connect to a 3rd party for networking? I can’t just WiFi the Smart Controller to the receiver’s hotspot? After downloading the Google SRTM I am afraid I might lose everything in the canyon holes, maybe even have a tougher time with satellites. Hopefully since I am so close to Austin and only 5-6 miles from the closest station I might get lucky. Since I got the cloud casting dialed in I better get on the local. Flight starts in less than 12 hours!

Using caster.emlid.com I received failed to resolve host after putting in the correct credentials? I then tried the IP address of the caster from the documentation and it connected just fine. I think I see that I would just put in the address of the RS2 as defined by the 3rd party data. With that I would use the reach:emlidreach credentials?

Maybe. I did not try it but if they are all on the same network, it should work.

Local does not use caster.emlid.com It uses the IP address displayed in RV3. And, the rest of the credentials as per RV3 for local. All different than Emlid Caster.

1 Like

Thanks Dave! This will make the morning much more fun.

1 Like

Is there 29 Beta 4 out? My RS2 will not find it if it is.

See here: Can’t turn on RS2 Mobile data after update to 28.4 - #3 by amc.proiect

Hi Zach,

29 Beta 3 Reach Firmware is the latest available Beta version right now.

1 Like