Raspberry Pi 3 support for Navio is here!

Originally published at: http://www.emlid.com/raspberry-pi-3-support-for-navio-is-here-2/

For the last weeks we’ve been working relentlessly on the new revision of our special Raspbian image for Navio autopilot that supports Raspberry Pi 3. The new image works on the following hardware combinations:

  • Raspberry Pi 3 with Navio2
  • Raspberry Pi 3 with Navio+
  • Raspberry Pi 2 with Navio2
  • Raspberry Pi 2 with Navio+

Here’s the overview of the features:

Raspberry Pi 3 support

Raspberry Pi 3 is the new version of Raspberry Pi SBC. It is based on the new BCM2837 which has four 64-bit A53 cores with higher clock speed. Upgrade in the clock speed and new architecture results in 50 to 60 percent better performance compared to Raspberry Pi 2.

This gives more resources for the APM autopilot, video streaming and other drone software.


New Linux kernel

We decided to use the newer Linux 4.4 kernel that is the LTS release version which means that it will be supported for a longer period of time.

This version also features improved AUX SPI driver for more robust communication with Navio RC IO coprocessor.

Kernel headers are pre-installed in the system allowing users to compile kernels modules with ease.

Easy updates

We’ve set up DKMS subsystem to provide updates in the easiest way possible.

System updates now work by simply running the dist-upgrade. It will roll out all latest features and improvements of the software and firmware.


Simple initial Wi-Fi configuration

We’re aware that there’s a lot of Windows users out there which suffer from the initial setup because configuration files on EXT partition aren’t accessible. We have moved wpa_supplicant.conf to the FAT32 partition.

All that is needed now to setup WiFi is to insert SD card in your computer, open wpa_supplicant.conf and add your network credentials. After that you’re good to try out your Navio!

Pre-installed GStreamer

So many of our users use Navio for low latency video streaming with GStreamer. Now there is no need to download 300MB of gstreamer1.0 packages because they are now also a part of the image.

Where can I get it?

The image is available for download in our docs for Navio2 and Navio+.

We’re eager to hear your feedback on this release.

Best regards,
Emlid team


Good job. Currently downloading and Raspi3 is on the way. Will maybe be able to test this weekend.

This is good news! My Navio2 arrived today and the RPi3 is already waiting on the shelf! Will install ASAP!

Thank you yep yep yep,here we go!!

Fantastic work team! Really appreciate the new enhancements for us Windows people and simplified upgrade process!

Great job guys! However, I can’t seem to get the built-in WIFI working. I changed the data in wpa_supplicant.conf to match my wireless network and it never connects. If I type ‘sudo ifdown wlan0’ it says

ifdown: interface wlan0 not configured

Typing ‘sudo ifup wlan0’ yields

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

The built-in WIFI works when using the same settings on the standard Jessie image. Any ideas?

Followed to documentation and start APM by “sudo ArduCopter-quad -A udp: -C /dev/ttyAMA0 > /home/pi/startup_log &”.
So, that the APM version is 3.3.
The calibration of accelerometer and compass having no issue.
The connection to Mission Planner through UDP by on board Wifi.

Unfortunately, there is few problems.

  1. ESC calibration is not completed by sounds.
  2. Radio calibration could not start for no signal.

All setup was just fine with Raspberry Pi 2 on the same copter. I just replace CPU board and software.

Any suggestion is helpful.

Solved by myself.
The loading APM version was NAVIO+ for NAVIO2.
After installing correct version of APM for NAVIO2, the issue has been solved.
The updated APM version is Copter V3.4-dev (cce4f12e).

Hi. Great news!
Is there any chance I will be able to run the LXDE graphical user interface on the same Raspi 3 that is running my Navio+?

I’ve used LXDE with no issues using the old image so I assume there would be no problems there. We need to use it because our university internet is so much easier to setup via the gui.

See Randy’s message regarding using Copter V3.4-dev.

Considering the on-board wifi card, the Navio2 can be controlled over wifi correct? does it need to be connected to the Internet or can I setup a router without hooking it up to ‘the outside world’? I would prefer to separate potentially dangerous equipment and the internet, for (hopefully) obvious reasons, paranoid or otherwise…

Thanks :grinning:

Yes, you can setup the Pi3 as an access point with hostapd.

I am already crashed my NAVIO2 + RP3 on Saturday.
I will investigate my clash.

Thank you Al_B :slight_smile:

Is there a way to use the latest release with the original Navio Board

It should work as it is software compatible with Navio+.

Is annoying bug with high USB I/O poll rate fixed as well?

Anyone else having problems using the built-in WIFI?

was that an answer to the control question, or the Internet question?

Thanks for replying though :grinning: