Raspberry Pi 3 support for Navio is here!

A few things could be causing that issue. Firstly are you providing enough power to the Pi, whilst it will usually run off a laptop, the raspberry pi 3 requires more current to function as well as run its peripherals so running it off a 500mA supply (what most laptop usb hubs supply) causes an array of issues with the wireless and bluetooth devices on the board.

Another thing to do is to check your wpa_supplicant file for any errors.

If its still not working you may want to switch your pi’s internet into managed mode, ensure you have network manager installed, and then try connecting to the internet via the GUI, you will need to remove any wireless settings you added to get wifi to work in headless mode to ensure that the wireless device does not show up with “Device not ready”. If you see "device not managed you still need to remove some stuff from the /etc/network/interfaces file. (Just ensure wlan0 isn’t mentioned anywhere in it).

Once you’ve connected to the wlan once the device should auto-connect to that network on startup even if you use headless mode.

Hope that helps!

I am using the 2A power supply from Adafruit with nothing except the Navio2 connected to the Pi3. I have double checked the wpa_supplicant, I can use the same data in the file on the standard Jessie image and it works, so it makes me think something is going on with the EMLID image. I’ll have to try the managed mode and report back.

@larssoltmann did you manage to solve the problem (maybe by removing WPA-PSK line)?

Did you check that there are no spaces between ssid=“network_name” and so on? It took me a lot of time realising that I was writing ssid = “network_name” instead of ssid=“network_name”…

Yes the issue has been solved using this thread Navio 2 and Raspberry Pi 3 wifi issues (SOLVED). Still don’t know exactly what the problem was since the output from the ‘wpa_passphrase’ command was identical to what I had added to the supplicant but for some reason that worked.

1 Like

Can I run with this image apt-get dist-upgrade without replacing the kernel?

Why no PREEMPT_RT kernel?


@dgrat yes, dist-upgrade should not break the kernel now.

@Klejs RT patch is being merged into the mainline kernel more and more. On 4.4 PREEMPT shows really good latency results, so it’s okay to use it now.

What is the login name and password for the Navio2 image? Thanks.

Username: pi
password: raspberry