Only red LED lights up on M+ after updating to v2.22.4

The reach view 2.20.8 installed on my customer’s drone (Phantom 4 pro) and worked fine for 6 month but when my customer updated reachview from 2.20.8 to 2.22.4, now only red LED is on and blue and green are off !
He must sent this device to me and I disassemble drone and reflash by USB!
Why is this happening?

Hi @SkyMAP.Innovator.LLC,

It’s strange that the unit started to behave that way after an update. Usually, this LED status means that there is not enough power for the unit to boot.

Could you please clarify how Reach M+ is powered? Just to make sure there are no issues with that.

Hi @SkyMAP.Innovator.LLC,

I have a couple of additional questions. Could you please clarify if there were any difficulties during the update? Do I understand correctly that the unit doesn’t create the hotspot?

I had the same issue and it ended up being my power brick was not providing enough power even though it has been said that power requirements didn’t change. Have they tried connecting it to a standard 2.0 amp charger?

No issu in power!
I am using Ashot board. Ashot gives +5v to Reach m+.
It was working with this for 6 month and now after updating disabled!
He must sent device from another city(1000 km) to me and disassemble and reflash 2.22.4 or lower firmware!

But Ashot board gives +5v to Reach m+ and good quality voltage for Reach m+/m2.

I have to agree with you, but just about every occurrence of this over the past month has been power related. Personally I think something happened in the firmware as I too (and several others) had perfectly working devices. I believe mine started somewhere around 2.20.x. I haven’t tried it with my AShot board yet, but will try t do so this week and report back. Unfortunately I have three different methods of powering, 2 M+'s and 2 M2’s so it takes quit eallot of testing to get anything conclusive.

1 Like

My another customer’s Reach M+ disabled after updating from 2.16 to 2.22.4 !!!
New FW need more power than old fw?
I experienced with no-emlid cable only for off blue and green LED and solved with Emlid’s usb cable.
But now my two customers has same issu after updating !
Please add a safeboot or safemode for booting under wifi network for this condition and update or downgrade reach.

Hi @SkyMAP.Innovator.LLC,

We’re currently looking into the issue and trying to reproduce it.

As far as I understand, both units are powered from a JST-GH port. Would it be possible to check if the same issue persists while powering over USB?

1 Like

Mine is via USB and a powerpack. I changed from a 1-amp to a 2-amp battery and it works fine now.

1 Like

One of disabled Reach relived by reflashing 2.22.4!!!
Phantom 4 disassembled and Reach reflashed and then set ppk configuration and I put it in drone with same Ashot board and now is working fine!
I am wait to recieve another disabled reach and will share info.

1 Like

I might also include that I am running the Dev versions of Reachview…

Hi @SkyMAP.Innovator.LLC,

Thanks for the info!

May I ask you to answer a couple more questions?

  • Have you had a chance to check if the issue persists while powering over USB?
  • Were there any issues during the update process?
  • Did your customers perform the update while supplying power through JST port?

Hi @chascoadmin,

Thanks for the info, too! Were there any difficulties during the update?

I did have an issue where the update prompted me several times even after it said that it had completed successfully, but I think that it could be contributed to networking issues as well. I tried to forget the Wi-Fi network I am connected to each time I need to use it because of the action automatically logging into a Wi-Fi network when it is available instead of being able to choose a hotspot.

Hi @SkyMAP.Innovator.LLC,

It’d be nice if you have a chance to comment on these questions as it helps us to find the root of the issue:

1.No. I don’t check Reach with USB before reflashing!
2.No. No issu during update. Everything was fine.
3.Yes. During update the drone was on and the reach was connected to JST port.

But after finishing update, the blue and green do not tune on.

Hi @SkyMAP.Innovator.LLC,

Thanks for this info! We’re looking into that now. Once I have any other questions or news, I get back.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.