No heartbeat, tried everything....everything

When I run the example take off and land script and connect to the local ip of the drone,, it fails to connect. I have followed every tutorial and tried every solution I could find on here and github and nothing works. Can someone please help me get this working?

Hi Ethan,

May I ask you to specify the device you’re working with?

Would you mind describing your actions step-by-step so that we could understand which step causes the issue?

I am working with the Navio2 connected a Raspberry Pi 3.
I power on my drone, ssh into the drone, then I run either or which are example scripts that came with dronekit. I have both of those scripts connecting to as per tutorials using the --connect or --master argument. Everything is updated to current versions. They both fail to connect and I get a message that says “no heartbeat packets received in 5 seconds” when using and mavproxy just says "waiting for heartbeat, MAV> link 1 down

Hi Ethan,

Dronekit should work just fine with Navio2.

May I ask you to post the steps you take with the screenshots of the commands’ output attached? That will help understand on which stage the issue occurs. At the moment, it’s difficult to determine what goes awry.

When I type “ls -l serial*” I find that ttyS0 is missing. Could this be the culprit causing the issue?
Here is everything you need.

I have followed the tutorials and documentation to set up Navio2 and run scripts locally on the drone. Everything else works. I can control the drone via an rc controller and I can connect to the drone using telemetry via my laptop and mission planner.

I am using the latest Navio2 image with the latest Ardupilot version installed and the latest RCIO firmware.

I am unable to connect my python scripts to the navio2 locally using “–connect”. also does not connect. I get the following output when running “ --master=”:
Connect source_system=255
Log Directory:
Telemetry log: mav.tlog
Waiting for heartbeat from
MAV> link 1 down

Could someone please point out where I am going wrong here? I have googled this error relentlessly to no avail. It appears that this issue is rare but others have also experienced it. From what I can tell, no one has ever resolved the issue. As far as I am concerned I have a faulty Navio2 board unless someone can point out something to the contrary. My window for returning the Navio2 is closing, so it would be appreciated if this issue can be resolved in a somewhat timely manner or confirm that I have a faulty Navio2. Thanks.

Hi Ethan,

I’ll try to reproduce the issue. I’ll get back to you once there’s news.

Hi Ethan,

Sorry it took a long time to get back to you!

May I ask you to post the following:

  • the screenshot of your configuration file /etc/default/arducopter
  • the output of the command systemctl status arducopter
  • the command you use to run ?

Please make sure you restart arducopter with sudo systemctl restart arducopter after making changes to any files during the session.

Hi Polina,

Unfortunately I no longer have the Navio 2 as I deemed mine to be defective and am currently in the process of disputing my transaction with as they do not want to refund my purchase. The reason I deemed my board to be defective was the issue I and many others face seems to have no available solution which makes me think this is a hardware and not a software issue. I could be wrong though as I am not an expert. However, if you search Google for the issue, you will see that it is rare, but others have encountered it. Only a few have posted “solutions”, but none of those worked for me.
I posted the command used to run in a earlier post. If you scroll up and read carefully, you will find it. Since I no longer have the Navio 2 in my physical possession, I can no longer post screen shots of my configurations. However, I can tell you that all official tutorials and guides were followed exactly as stated and the default configuration was used for /etc/default/arducopter. The output for systemctl status arducopter was active and running. I could manually fly my drone just fine using an RC controller. I could also connect to a GCS. Its just whenever I tried to connect to the drone locally and execute a python script to fly autonomously, I would always get the ‘timeout no heartbeat’ error. I will keep check on the Navio 2’s progress and if I ever see this issue resolved, I will be more than happy to give the Navio 2 another chance. Until then…

A post was split to a new topic: Can’t connect to Dronekit

Hi Ethan,

Sorry to hear about your disappointing experience with Navio2!

Still, I’m afraid this doesn’t look like a hardware issue according to the fact that you can connect Navio2 to GCS and control it using the RC controller fine.

Navio2 is a highly customizable device. The variety of its use-cases influences the setup complexity, and therefore, creates more difficulties in remote troubleshooting. It’s often quite hard to understand remotely on which stage of the setup something went wrong, that’s why we’re asking so many questions in order to see the whole picture of what is going on.

If you’re replacing the device and will face any similar issues with the new one, please do not hesitate to create a new thread with a detailed description.

Thank you!

1 Like

We’ve just released the new Navio2 image that should solve the issue with the Dronekit connection. You can check out the details in this community forum thread: