Emlid

New Emlid Raspbian [emlid-raspbian-20180525] with Raspberry Pi 3 Model B+ support


(Domingos Moura) #46

pi@navio:~ $ cd /dev
pi@navio:/dev $ dir
autofs loop7 ram6 tty20 tty46 uinput
block loop-control ram7 tty21 tty47 urandom
btrfs-control mapper ram8 tty22 tty48 vchiq
bus mem ram9 tty23 tty49 vcio
cachefiles memory_bandwidth random tty24 tty5 vc-mem
char mmcblk0 raw tty25 tty50 vcs
console mmcblk0p1 rfkill tty26 tty51 vcs1
cpu_dma_latency mmcblk0p2 serial tty27 tty52 vcs2
cuse mqueue serial0 tty28 tty53 vcs3
disk net shm tty29 tty54 vcs4
fb0 network_latency snd tty3 tty55 vcs5
fd network_throughput stderr tty30 tty56 vcs6
full null stdin tty31 tty57 vcsa
fuse ppp stdout tty32 tty58 vcsa1
gpiochip0 ptmx tty tty33 tty59 vcsa2
gpiomem pts tty0 tty34 tty6 vcsa3
hwrng ram0 tty1 tty35 tty60 vcsa4
initctl ram1 tty10 tty36 tty61 vcsa5
input ram10 tty11 tty37 tty62 vcsa6
kmsg ram11 tty12 tty38 tty63 vcsm
log ram12 tty13 tty39 tty7 vhci
loop0 ram13 tty14 tty4 tty8 watchdog
loop1 ram14 tty15 tty40 tty9 watchdog0
loop2 ram15 tty16 tty41 ttyAMA0 zero
loop3 ram2 tty17 tty42 ttyprintk
loop4 ram3 tty18 tty43 ttyUSB0
loop5 ram4 tty19 tty44 ttyUSB1
loop6 ram5 tty2 tty45 uhid
pi@navio:/dev $


(Domingos Moura) #47

It looks like not.


(Domingos Moura) #48

pi@navio:~ $ dmesg | grep spi
pi@navio:~ $ dmesg | grep i2c
[ 2.878687] i2c /dev entries driver
pi@navio:~ $


(Barry Bolton) #49

Just my 2 cents.

You might have a defective RPI. My RPI 3 did the same thing. For some reason it just started becoming hot to the point where the PI would idle at 80c. See if you can replace your pi and see if the results are the same.


(Domingos Moura) #50

Barry thanks for your comment but i’ve flashed another SD card with the previous image and it worked really well. Same wiring and same setup just swaping cards.


(Barry Bolton) #51

OK great. No more issues ?


(Domingos Moura) #52

No that’s it, if i switch cards it works beautifully. It might be something related with the new image. Hope they find a solution.


(Domingos Moura) #53

Hello Alexey, how are you doing with the issue, any update? Is there anything else i can do to fix it?


(Alexey Bulatov) #54

Sorry for the long wait.

We have updated ardupilot package for Navio+. So after sudo apt-get update && sudo apt-get dist-upgrade you will get arducopter, which can work with navio-rgb overlay.
So please make update and return /boot/config.txt to the original state.


(Domingos Moura) #55

No problem, i guess you’ve had a lot of lines to read.

Yesterday i’ve flashed the SD one more time, it didnt work, today i did “sudo apt-get update && sudo apt-get dist-upgrade” and it worked. Radio calibration went ok, and i flew it for 3 min for testing, it is working good. It is stable and flying good. Good job!


(Pedro Braz) #56

Hi all,

Why was WBC support dropped? It was a very nice feature to send Video thru Wifi. Do you have plans to support it again? Can i try and installed in this new Emlid’s image?

At present WBC does not support the RPI 3B+ but I can use a 3B with this image right?

regards,

P.


(Dmitriy Ershov) #59

Hi Pedro,

You can use previous image with 3B to have WBC support.


(Andy Mcleod) #61

George, this sounds very exciting, but the link doesn’t get me an Emlid headless OS. It is a plain RPI Jessie with GUI and other useless apps.


(Tatiana Andreeva) #63

Hi @andy.mcleod,

I’ve replied to you in another thread.