NAVIO2 - Inconsistent Compass Problems

Hello,

Hello,

I have found many problems setting up NAVIO2 using the Mission Planner.

It has an error tormenting me " PREARM : INCONSISTENT Compasses " .

My setup is as follows :

RASPBERRY PI 3
NAVIO2
3DR RADIO 433MHZ
FUTABA RECEIVER RECEIVER 8FG 6208SB

Below the images of the setting in the Mission Planner, already I tried to carry out other suggestions as described in the blog , but it did not work .

Please Help me …

Best Regards

Fabio

1 Like

As long as you are using the most recent ardupilot builds I don’t think you’ll need to roll the second compass, its compiled in when compiling for the Navio2 board. https://github.com/ArduPilot/ardupilot/blob/master/libraries/AP_Compass/AP_Compass_LSM9DS1.cpp#L203

I ran into the same problem but mine was really bad EMI, external compass fixed my inssue, but some good info here.

Thank You your help this is information is priceless, but is not solve my problem.
I need found more information like Step by Step, because this problems its equal the cheap Chinese Pixhawk. When I buy NAVIO2 FC, I dont imagine have these types problems.

1 Like

Make sure you use “Onboard mag calibration” (the one on the right and not “live calibration”.

Also make sure you make calibration in an open area as far as possible from metals.

These 2 things made a huge difference to mine.

Corrado

Double check everything, especially what @Corrado_Steri said. Before my currently built I didn’t need an external compass and it worked perfectly.

what I believe @mr337 already said (your screenshot shows wrong configuration)

  1. use latest emlid’s image
  2. don’t use different values for rotation on compass #1 and #2 - if navio2 is mounted with the arrow pointing to the front and navio is on top of rpi - keep it 0 ( untick “externally mounted” and reboot) – and recalibrate afterwards!

Hello there!

I wanted to confirm that @Corrado_Steri and @panky were right. You should pursue everything they told as it’s the procedure described in the docs.

I’m pretty sure that everything’s fine with the compass itself otherwise the behavior would be different. But if you want to double check that, you can download our examples and launch AccelGyroMag.

I performed all procedures according the documentation available for NAVIO2 on your website .

Follow the steps taken:

1 - Accomplished download the image.
2 - I created the Micro SD Card with the image ( emlid-raspbian-20160718.img ) .
3 - I performed the install (sudo apt-get update && sudo apt-get install apm-navio2) and update on Navio2 as documentation (sudo apt-get update && sudo apt-get dist-upgrade )
4 - Booted the NAVIO2 ( sudo ArduCopter - quad -A udp : 192.168.1.2 : 14550 C / dev / ttyAMA0 )
5 - I updated the file ( /etc/rc.local file ) for auto startup.
6 - I installed the Mission Planner (version 1.3.39 ) .
7 - The message displayed on the Mission Planner in the Message tab ( Frame : QUAD APM : Copter V3.4 - rc1 ( dfa90d29 ) )
8 - I install the foam inside the sensor conform the Navio2 procedure.
9 - After that I bought a “hand compass” used in “camp” and checked on my frame and the place where I chose to perform the calibration if there was some kind interference.

When using a "hand compass" is possible to identify whether there is any kind of ferrous metal or the generation of some kind of interference from the battery , cables , screws, nuts or frame.

It made ​​sure that there was no problem with my configuration ( quad ) or equipment.

After that I went to an open field ( farm ) , free for sources "energy towers" or "metal", "metal fences" and "buildings".

10 - I performed the calibration through the Mission Planner using the 3dr modem .

At this time pointed to NORTH the FC Navio2.

After the calibration using the Mission Planner ( On Board Mag Calibration) the result was as follows :

id : 0x : -190.2045 y: -391.2848 z: 500.8231 fit: 12.67884

id : 1 x : y -135.0238 : -113.0326 z: 275.9233 fit: 6.627566

But after finishing the Mission Planner does not show any message like "Calibration Finish" .

I selected the " ACCEPT " button and updated values ​​.

After i Check in Mission Planner (Full Parameter List) and values is update. 

11 - After having done all these things messages are still issued

- "Error pos see variance" 
- "BAD AHRS "                                                 

12 - I’m sure the problem is not a failed installation or a mistake made ​​by me or by any magnetic interference source.

 THE PROBLEM IS THE NAVIO2 or any other specific SETUP absent on the documentation.

And now ?
You will insist on saying that it is a configuration problem ?
Or a magnetic field problem?

it seems like your compass has successfully calibrated;
the error messages indicating a problem (most likely) with the IMU (or GPS); you might want to repeat acceleration calibration and reboot; (these messages are not related to the compass);

I tried to recalibrate it more than over 30 times .
I lost one whole day doing it without any success .

I use Tallysman multi- GNSS antenna .

This antenna is not good , I have other compass bought in China in my house they can capture 7 to 8 satellites and Tallysman nothing.

But the GPS is work.

sometimes these messages can occur if you don’t reboot after calibration;
calibrating accels should be done indoor, on surface where you know they are even; it’s important not to shake/wobble navio when accepting points and be as accurate as possible - maybe using something your arms can rest on when you eg have to turn the copter on it’s back;
( as explained here: https://vimeo.com/56224615 )

Sorry , I 've done it numerous times, after the compass calibration procedure.

On the ( EKF STATUS) the error appears in POSITION ( VERT ) .

The change in this bar is constant.

Its no make sense.

The horizontal and vertical position variance errors are thrown when the EKF and GPS or other sensors do not agree.

Any idea ?

Reading this I’m super confused.

This makes no sense. Is it possible you are confusing the two? From the steps above it looks like you did get a good compass calibration as @panky has mentioned. If not you’ll get a bad compass health or a mismatch error, which at the moment has slipped my mind.

Now the GPS is another issue. You need to verify that you are getting consistent GPS lock and if not you’ll get major issues. There may be a chance the antenna is dead on arrival and if so find another compatible one or replace it. Also you need to verify that IMUs have been calibrated and if not you need to investigate that directly. With the issues you are having (failing GPS and failed IMUs) makes sense to encounter “pos variance” and “Bad AHRS”.

If you think your getting issues with bad hardware such as a defective Navio2 shield run the demo code https://github.com/emlid/Navio2 to test each individual sensor.

@Fabio_Ferreira

The only thing I can suggest is to calm down and to process the information that you can deduce from this thread. @mr337 and @panky did an awesome job providing hints and instructions that are of great value. I do get your frustration, though. But doing the same thing 30 times in a row usually doesn’t really yield any results. You need to take a look at the situation from another perspective. I suggest trying out an external compass. These are extremely cheap and they eliminate risks of running into magnetic interference problems that are created by board’s routing.

I guess you did not understand my problem yet.

There is no kind of interference near the NAVIO2 .

It is absurd that your answer , because the equipment should function without the need for an external compass .

How to see my problem in another perspectiva is what I 'm doing.

But after trying different solutions the equipment dont work.

Another thing , I bought a product and not a platform that I had to " seek a solution through another angle ."

You should have a quality control, endorse your product before launching this on the market .

You should be organized as a company , create virtualized environments with all ready settings , catalog all errors and provide solutions to their users.

I do not consider myself a novice user and am providing all the info about a clear and orderly manner.

I am a user of the products and 3dr DJI and never experienced such discomfort

1 Like

to be honest, I bought Navio because I have the possibility to customize almost every feature that’s important for an UAV; it’s actually not really comparable to a RTF solution, like DJI provides; it’s an autopilot and for sure it’s not a hobby that will succeed in 15min; emlid provides solid hardware with navio and the software -autopilot, that works and does what it’s supposed to do, but especially if you’re beginning with ardupilot it can be hard to understand what different sensors do and how they are supposed to be handled;
when you buy Navio(2) you have nearly unlimited possibilities to build UAVs Rovers, automate them, including a Quadcore processed rpi, but there’s also a lot of space for errors…; sometimes you just have to wait a few days until you get in the mood again for trying to repeat all processes again;
you are getting all the support you need - just leave the copter/autopilot alone before you get frustrated and wait for motivation;

at the moment your compass seems to be fine - if you still wanna buy one i can recommend a breakout board with hmc983l ( 7eur drotek; 2eur from aliexpress)
for your AHRS or EKF problems you can check your HUD in missionplanner: when you move your navio it should represent the right direction for roll and pitch!
for GPS check your HDOP and the map in MissionPlanner; (like sudden jumps)
that should narrow down your problem…

1 Like

Just to be on the same page I need to get a little more information. Please, be patient and help me help you! :slight_smile:

You did what @panky said here

and as of now the Compasses inconsistent error is gone, isn’t it?

The only errors you’re observing right now are [quote=“Fabio_Ferreira, post:8, topic:3755”]

  • “Error pos see variance”
  • "BAD AHRS "
    [/quote]

These are not compass related. In order to track down the problem we need to verify that you calibrated your accelerometers, too. What happens if you leave the board after successful calibrations and a reboot without shaking it?

Could you also run a Barometer example please and verify that the data you’re getting is adequate.

I understand that when something is not working it can be really irritating, but can we please focus on solving your problem and not teaching us how to develop products / do business.

We do test all devices before they leave the factory. We do work on providing solution to errors. Even more - we work on getting rid of them so users don’t stumble on them at all. We do provide instructions on how to workaround some. But some errors may be caused by numerous factors and for them we provide support individually here.

1 Like

This is my compass setting.
I did not do nothing different from your guidance , as its documentation.

I dont have any mag source near the NAVIO2 FC.

if you prefer I can install TeamView and you access my confiuração in Mission Planner. now.

So here’s the outcome:

Georgii spent two evenings helping Fabio_Ferreira to get his setup working (that’s how bad Emlid’s support is).

  1. “Inconsistent compass” error went away when all settings for compass were set up correctly and calibration done too.

  2. “Bad AHRS” error was caused by two instances or ArduCopter running simultaneously.

  3. “GPS error” appeared after that. Satellite levels were good at the moment. Resetting the parameters and setting up everything carefully from start solved that one too.

In the end the copter was able to lift off. It didn’t fly well, so the owner has to do some tunings, but that’s another story.

As usual, repeating incorrect procedure 30 times and blaming the company does not help to solve the issue. Carefully following instructions, providing proper reports and listening to advice does.

3 Likes