Legacy RTCM3 messages

Unfortunately, I will not get a chance to test it till tomorrow.

I have updated my M2 but my evening is booked.

How are you transmitting RTCM? Radio/NTRIP or what? Are you sure you are transmitting and receiving?

I am bench testing today. I updated my M2, set it up as a base. It is transmitting via a RFD900+. I have a 3DR radio that is paired with the RFD connected to my laptop via USB that is port 20. After connecting and parsing I get the attached data. This will work with Trimble I think. I am not sure what data the 1008 is sending but in my M2 project it was only sending null.SNIP stream

I am transmitting via NTRIP to the emlid caster.
I am also sure that the rover receives the corrections from the caster.
I have test it with SurvCE, Surpad, Lefebure ntrip client and all of them show that the corrections are being received. The problem is that the rover stays single or autonomous.

Have you ever had them RTK fix before? If so, with what base? If you still have that base, you might use SNIP to parse and show in RTCM viewer. This way you will see what messages it was sending and mirror it with your M2 output.

Both rovers (novatel and hemisphere) work great with various local COORS (nearest base or vrs).
They also work great between them (base-rover).
As of now I have test the emlid M2 base with 3 different brand receivers (novatel,hemisphere,kolida) and none of them worked. At first I thought it was some weird network problem but it was not because the novatel base works great with the emlid caster.
The initial tests were done with 2.24.2 and the todays tests with the dev version 26.

Just an FYI it is CORS ( Continuously Operating Reference Station), not COORS that is the Rocky Mountains Golden Banquet Beer.

Are all your tests utilizing Emlid’s NTRIP caster? Have you ever tried it via a radio or other means, serial data for instance. You have a lot of different things to troubleshoot when using the caster. Narrow your troubleshooting down to determine where the breakdown is. I would try to get it working local with serial data or radio if you have them available. If it works there, it should work via a caster if all parameters are setup correctly.

BTW, I haven’t played with Emlid’s caster. I prefer a base in the field for the work I do. I have played with others and have a good working knowledge of Lance’s NTRIP client.

Sorry for the misspelling.
All of my tests are via ntrip. I have no radio for M2 and the other equipment has 450-470mhz uhf radios.
I have tried emlid caster, rtk2go caster and another private caster. I had a couple successful tests but it was random. M2 corrections are not properly recognized by the other receivers.
I insist that it must be some bug because I have set other bases over ntrip with emlid caster and rtk2go and the rover recognizes the corrections properly.
I’ll wait for your results with Trimble gear.

I don’t think that would be definitive. My Trimble works with MSM4 but needs message 1008 to do so. Now that they have added that ability, about half of my M2 project was for not.

Not sure the changes are working correctly. I tried to connect my M2 with my Trimble unit by taking out my Arduino 1008 injector. I could not get my monitor to go fixed with either all legacy output or MSM4 and message 1008.

I changed everything back to MSM4 and added my 1008 injector back in and still couldn’t get fixed. I have been racking my brain on it for almost three hours.

Tomorrow night, I will do a test with M2 version 2.24.2 and my 1008 injector and see if it goes fixed. If so, then there is definitely an issue with the BETA software.

There was one thing I did notice on SNIP that I do not recall seeing before this update. Once connected and parsed in the past it just said RTCM3. Tonight with the Beta software it made mention of UBlox F9P.

I know there are several sites that state “Do not mix new with legacy” perhaps there is a lot of truth to that.

I didn’t get a chance to mess with the talker changing from GN or GP. I wouldn’t think that has anything to do with it as that is NMEA not RTCM but who knows in a Beta. If nothing else, please keep the option of selecting what NMEA messages you want to output.

Hey guys,

Thanks for the testing!

Such behavior of the solution status while using our legacy messages needs to be investigated. Please share with us the messages you’ve chosen while establishing the RTK link and the base correction logs as well.

It’d be great if we could keep all of the details of this conversation on one thread so that it’s easier to see the full picture. Please share your data in the main thread.

Hello All. It’s been a while since I’ve posted ‘in anger’ so to speak. I haven’t tested the new beta firmware yet - hopefully in the next week.

I never was able to get my Trimble ag receiver to get stable lock with MSM4 & 1008 injection. Although it was a while ago. I do recall the Trimble wasn’t particularly happy going back and forth to a ‘stable’ RTCM 3 or even an MSM7 based correction.

However after standing the tractor most of the winter, I ran it the other day and it started working again on MSM7 based corrections.

Just a recollection / observation. Good luck all.

Hi everyone,

I wanted to give a little update on the workflow with the legacy messages. To make them work with your rover, please, make sure that the update rate you set in GNSS Settings corresponds to the frequency of the RTCM3 messages.

So you need to set the update rate to 1 Hz on in GNSS Settings:

Then, the GNSS RTCM3 messages frequency should be set to 1 Hz:

Please let us know if this workaround works for you.

Edited: changed the screenshot and information about the frequency.

2 Likes

I just want to specify that this update frequency should be kept at 1 Hz to avoid any disruption.

If time permits I’ll test that this evening.

I’ll also send the logs.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.