Hotspot connection keeps dropping out RS+

Hi all,

I’ve been having a nightmare today. I have two RS+ and have connected them to home wifi and mobile hotspots without issue. I can connect to the RS+ hotspot too. But then the connections drop out, and the unit has to be restarted before connection can be restored. When connecting to the RS+ hotspot, my mobile hotspot and home router are switched off and the blue LED is solid. Yet it keeps dropping out after a few minutes and then won’t reconnect.

I need a fix for this ASAP. Any advice? I’ve trawled the forums and documents, tried several different processes, without any luck.

Your help is greatly appreciated.


What device are you using?

Is the actual signal dropping or are you just unable to access the interface?

Hi Michael,

I’ve tried with my iPhone and Samsung tablet. The network disconnects, and then when I go to reconnect the wifi settings say that the password is incorrect - it’s not but I retype it anyway and it still says the same.

I have experienced similar and at one point and an update it went away. Then it came back, but less frequently. I was able to overcome this temporarily by forgetting the network and making a new connection.

What version of Reachview are you running?

I have tried forgetting the network so that the only network available was the RS+ hotspot. I’m running 2.18.1 for firmware, and version 1.5 for the app.

Just for clarity, that means you did forget the Reach hotspots as well? I am sure someone with a little more knowledge of the actual firmwares and issues will chime in soon.

Yes. I did a full network settings reset on my iPhone so it forgot the RS+ network and I had to reconnect with the password etc. What is concerning me is that it is happening on both RS+, although that makes me hopeful it’s not a hardware issue at least.

Yep, seems like a firmware/communications issue. I know there have been quite a few problems with Android and iOS has been better, but like I said - I have experienced the same thing with my base, rover and M+ occasionally.

Has it been working fine and then the problem started consistently?

Have you had any OS updates recently?

I haven’t actually used it much aside from the initial set up, and only got it a couple of months ago. When I did the initial set up I had a similar issue but later found out this was due to it connecting to the home wifi.

A wired connection from Reach to phone would be great.

I did have an OS update a couple of days ago, but it was minor one.

1 Like

Hi Shane,

Could you confirm Wi-Fi is working fine when Reach units are connected to your home Wi-Fi/hotspot?

Could you confirm you observe the same behavior with both units?

May I ask you to post full system reports from both devices when they are in hotspot mode?


Hi Dmitiriy

They stay connect on fine on the home WiFi. They disconnect from mobile hotspot and reach hotspot. This is the same behaviour for both devices.

I can post a full report later today. I won’t be home until 4pm UK time however.

1 Like

For the system report do I need to create the problem or will it have logged the issues from yesterday?


I believe you won’t be able to get system report once issue appears (because you won’t be able to connect to the device). So please just send us the reports once you start the units in hotspot mode.

Also, do you have other Wi-Fi networks around in the area when you observe this issue?

That was my worry but glad I can just get it from the hotspot. It’s in an area where there are other WiFi networks but none are known to Reach or any of my devices. I’ll post the reports when I can today.


In case you have troubles posting them here, please use Cloud storage or send them to

2 Likes (457.2 KB) (352.8 KB)

I’ve attached the full reports as requested. Hopefully you find some answers in them. Thanks


Thank you, Shane!

Could you remember if you had the same issue on the previous firmware version?

I don’t think so. But I never really tried it out as I’ve been away.

Hi Dmitriy,

Have you got anything for me to try?

Hi Shane,

We are still looking into your system reports! Will be back soon