GPS Ground Speed Zero when platform is moving


I’m seeing an odd problem where the GPS ground speed is being reported as zero when the platform is moving.

I am currently in the middle of tuning my rover and noticed some problems.

I’ve posted my issue on the ardurover thread and Randy (from the ardurover team) noted that the ground speed reported by the GPS (on the mission planner logs) was zero most of the time.

Can someone please explain what parameters I can look into to fix this?
I currently have a Reach RS GPS unit with the latest stable release firmware connected to my RPI3 (navio2) board via USB.


I also found this thread…

Not sure if the problem is related to mine

Latest dev update has many NMEA improvements. Would you consider trying it?

Hi @egor.fedorov

Ok I will and will report back. I’m assuming ardurover receives NMEA messages via ERB format ?


In the PR I saw

“RMC,VTG: change speed calculations(from 3D to 2D), remove magnetic heading and
change direction calculations - don’t hold and send wrong direction if speed is close to 0”

What is the cutoff speed.

When I am using the GPS to do a ground survey with a camera I am moving relatively slow. At about 20 cm/s . Will this be an issue?

Unfortunately, it should. By default, the cutoff speed is 0.5 m/s.

If you are interested, you can perform tests with this constant lowered to, say, 0.1 m/s and report back to us with you results. I will help you with the recompilation process, if you need.

Hi Egor,

Yes Please. I don’t think I have a choice.
Where can I find information on the recompilation process?

I’m assuming every time I do an update this recompilation needs to be done?

Was cutoff speed always set to 0.5m/s in the past or was this a recent update? IF so why was it increased? Also what was the original cut -off speed (ver 2.10 stable)?This might help me understand my current problem better

Getting an accurate estimate of position and velocity is extremely important as I will be using it for row crop following application. If the data is bad, ardurover will have navigation issues.

Thank you

Also since I will be recompiling …any way to change the units back to m/s instead of km/h . It makes more sense to be in m/s for slower ground platforms. Much more easier to visualise.

Maybe different units can be set as a parameter setting in the GUI in the future? Will the unit change from km/h to m/s also affect the data sent to ardurover?

Hi @egor.fedorov,

Would you be able to help me with this soon?

Thank you

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.