Speed is missing in RMC sentence

Hello,

I have been using Reach with a program to autosteer a farm tractor.

The accuracy is phenomenal and I can get great results with the position from reach (and with the autosteer software), but sometimes the program “freezes” and I noticed it was saying that the groundspeed was zero. At first I though it was a problem with the software or the tablet that is running it, however I noticed that the problem is in the NMEA sentence.
I still get new sentences, valid ones but the RMC sentence, in the speed space comes with zeros.

Is this a known problem, or have anyone had the same problem?

Hello Henrique,

We’ve recently pushed update v2.6.0. Amongst other things, it contains new NMEA sentences. Would you try updating, using it with your autosteer software and reporting back?

I can’t confirm right now the version I have, but i have updated it I believe Friday 23rd. Is this one the v2.6.0 already?

Before the update it used to happen, but I haven’t figured out the problem. After the last update (I must confirm the version I have now) it is still happening.

It looks like a random problem, not sure if it was coincidence, but after the update, the day I tried it looked a bit worse, happened more times, during more time.

Do you use USB output?

I use USB Ethernet driver and str2svr to push Nmea to localhost:7777 on Tablet and use cerea rtklib input Filters.

With this a had no problems…

Yes, I am using USB output directly from reach and connect through a COM port to Cerea.

I am not sure if I understood your connection.

You set TCP at Reach and send the NMEA to RTKLIB software, and then from RTKLIB to Cerea where you use their filters?

Am I correct? Or the communication between Reach and tablet is still with usb, and only between RTKLIB and Cerea you use the RTKLIB software to create a server and send NMEA to Cerea?

Thank you for your help

I have confirmed the version and reapeted the tests and it is still happening at 2.6.0.

I had not update one of the Reachs that I have and tested it. It is still in 2.5.4 and it happens rarely and even when it happens it is only for a second, at 2.6.0 it has happened for minutes.

Not sure if it matters, but I have confirmed and it also happens at Reach View. Should I put the logs here?

Kind of on the same topic: “speed accuracy” information is hardcoded to zero on the ERB protocol.
Please fix it, it improves ardupilot integration.

No!

I use usb2ethernet driver.
Reach is now a Ethernet device at 192.168.2.15
I use str2svr to get nema from reach at 192.168.2.15:portxxxx
Str2svr output is set to localhost (tablet) :7777
Cerea gets nmea from there.
Cerea has some filters - look into Settings

@Amilcar_Lucas I am not using ardupilot, the program I use can only accept NMEA.

@Andreas_Ortner, when i search for usb2ethernet driver i get adapters and i think you are talking about a program like str2svr, but to convert serial communication into a server, right?

I’ve tried using only str2svr to get the input from serial or tcp, i have tried setting both outputs at reach, and output to localhost at port 7777. and i can use rtkplot to read from localhost at port 7777, however i can’t get the Cerea to connect, i have checked the port at the configuration file and it is 7777. What do I have to do to get Cerea connecting to localhost?

Try to follow the instructions for intel Edison at:

https://software.intel.com/en-us/connecting-to-intel-edison-board-using-ethernet-over-usb

Andreas!

Now I understood! I can now successfuly connect Reach through usb2ethernet, and using str2srv to send information to Cerea i can also use the filters. However i still have the speed problem.

What version of reach are you using?

@egor.fedorov, I made a quick video showing the problem. https://youtu.be/RV96Fa5SefM

I have updated my unit to the 2.7.0 version and it is still happening.

There is any way of downgrade? I’ve recompiled the software but the first time I connect it reachview does almost automatically the update to the most recent version, i can’t find a way of keep the version i’ve recompiled.

AFAIK After doing the update you need to follow the instructions on Recompiling Reach RTKLIB source code (rtkrcv and/or str2srv) but instead of rtkrcv use str2rsrv

And please ask EMLID to add that information to the user manual. I already asked for it, but got no real answer.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.