Emlid with a Autel Evo RTK UAV

NAVD88? If so, it could be a mistake, cause in ReachView3, base should be set up in ellipsoidal height.

If you entered the orthometric height for the base, heights on the drone were calculated incorrectly. That’s why you have an error while trying to apply GRS80 in Pix4D.

I set the base up based on a known point in a project I create a head of time and from what I’ve seen it’s set to ellipsoid in meters not ortho height.
This has been working fine with the M300, I think it has something to do with Autel and Pix4d but until I hear back from them I’m guessing. I figured I’d give this forum a shot since there’s a lot more smarter folks on here than me.

dpitmanDave Pitman


“What is the altitude recorded to an image if you have FIX status and take a picture with the drone on the ground next to the RS2+ ?”

Something so simple to do, but I have forgotten to do this step many times!
Thanks Dave for reminding me of this tip as a check.

1 Like

NAVD88 Height, EPSG 6360 (Geoid 18) is the correct datum for our area.

Hmm, yes, then probably it’s related to Pix4D somehow. I’m curious to know their answer, please keep us posted!

Yes, sure. I just meant the base should be set up with ellipsoidal height.

We shoot on grid and the base position is assigned by one of the points that have been established. Is there something else to do?

@svetlana.nikolenko Will do. Been going back and forth with Pix4d support for the past couple of days. So far it’s been me trying to prove my setup is valid…We’ll see.

1 Like

If you chose the point from the ReachView 3 project, everything is fine.

1 Like

It sounds to me like you shouldn’t be adjusting geoid height in Pix4D if the height value you enter as base position in RS2 is NAVD88.

Since you’ve been troubleshooting this since a few days ago, you might already have done this but have you tried just setting up the images’ vertical coordinate system as Arbitrary?

Pix4D has terrible terminology and UI for dealing with vertical datums, I still don’t entirely understand why they made it that way.

1 Like

Hey @Gabriel_C , I use the Geoid Height option.

Maybe it’s something with the integration of the way Autel writes their geo data. I know we had trouble getting DroneDeploy to recognize the image with RTK precision because of that. I’ve never tried them on Pix4D. I might be able to try through Discovery with our images to see what I get in comparison to what we ended up with on DroneDeploy.

I processed one of the test flights in DD and the elevation was off by 95 ft.
Might be time to open a ticket with Autel.

As a general rule our area from Bastrop up to Liberty Hill is anywhere from 80-95ft from what I have experienced so you are definitely on the high end. I think they are the only ones that are going to be able to figure it out.

Ran another test this morning. Flew a site twice once with my normal base setup for correction and once using the correction network. Processed both flights in Pix4d and they are under 1/10th from each other but still off by 87 feet. The Geoid offset for this site is -84.22 feet.
So I know this has nothing to do with my base setup, which I already knew but this may prove it to the Pix4d folks and maybe Autel, if they ever get back to me.

Are you entirely certain that the network correction stream you’re using isn’t in NAVD88? Your base and your drone would then have orthometric heights already, which would explain why when you enter the geoid separation in Pix4D, it shifts the entire project off by about that value.

Have you tried putting 0 in the geoid height setting for your input images?


Using 0 for the offset basically doubles the amount it’s off by. 172 feet. So it seems to apply the geoid offset but it’s still off. Waiting for Autel support to reply.

Everything is ellipsoid until you either process with GCP’s and do a manual vertical calibration post processing.

1 Like

First want to thank everyone for their input. This is a great learning platform for someone like me without years of experience in this field.
Pix4d support got back to me this morning with something else to try and this seems to have fix my issue. I had to go into the Image Properties Editor and select the Geoid Height Above WGS 84 Ellipsoid and set it to 0 after importing the images into Pix4d. This is something I haven’t had to do with the M300…might try it though to see if it makes a difference there as well.

After processing the first step added in my checkpoint and my vertical accuracy was .034,
Probably run a couple more test flights but these results are very promising.
Again, thanks for all the input.


Nailed it!


Yep. Just didn’t know you could set that when importing the images.
I did a quick check between processing option on the M300 and the Autel and it looks like there’s something in the images from the M300 that tells Pix4d to set the Geoid to 0.00, or based on Pix4d knowing it’s the M300 it automatically sets it. Where as for the Autel you have to set it manually.
Learn something new everyday.