Emlid with a Autel Evo RTK UAV

does the IoS device, with reach3 app, have to be cellular to set and operate two emlids in a base - rover configuration? My state agency has restrictions on cellular IPADs. We want to know if we can use a wifi-only IPAD, w the reach3 app installed, to control an emlid base rover set up. Does anyone know if the new autel evo UAV would function as a rover with the emlid base, without a cellular ipad controlling the EVO? I suspect that the EVO has onboard cell reception; it may not need for IoS controlling device to be cellular. We also want to know if we need a seperate IoS device to run the emlid base and one to run the EVO app simultaneously, during an RTK flight.

We use Verizon Inseego Skyus routers to provide connectivity for all devices. We primarily use network CORS but when data gets sketchy we use local casting. I haven’t had many situations where the Emlid gear wouldn’t fix but the drone has had issues getting out of float in that scenario.

1 Like

Please correct me if I’m wrong. Based on the study I’ve done and what I understand about your comment: we only need a wifi IoS device to set up the emlid as a base [get it broadcasting the LoRa radio and functioning as a hotspot] and then we use a wifi IoS to get the evo into RTK mode for the fliight via the autel explorer app for the evo. Is there any task/need, in the emlid-evo RTK workflow, for cell on the Ios device?

That’s pretty much it. We use the RTK network when possible and a lot of the times the amyloid has service when the drone does not which creates this scenario. We can shoot in an RTK base points and then use that point in base mode and connect the drone to the local NTRIP option.

If I am able to RTK in that base point, I need to remember to turn off incoming NTRIP so that I can try the drone on the network first. If that doesn’t work then I change the values in Autel Explorer to the Emlid local. This is the most consistent workflow that I have found.

1 Like

Nope. Wifi only with the Smart Controller.

The Evo’s Smart Controller is not cellular capable. It is a non-cellular Android device. It can connect to wifi from a hot-spot or from the RS2(+)s built in wifi. You would need to also connect a smart device (your iPad) to the same Emlid network and set up the Emlid via ReachView3.

You can use an Emlid RS2(+) with it’s built-in wifi network, or use a smart device’s hot-spot, to pass corrections to an Evo. In this case, you would be using the “Local NTRIP” function and the Base would need to be set up on a known coordinate. No cellular connection needed in this configuration.

If you want to pass corrections from any outside device or network not in your immediate area, you would need a cellular connected smart device or sim in your Emlid receiver. (or LoRa if using 2 RS2(+)s).

Please have a read here:

3 Likes

Hi @kenforestry,

Dave and Michael are quite experienced in Autel drones workflow, so the only thing left to me is just agreeing with them!

Just a small summary: you can get it all to work without the Internet. Reach devices transmit their own hotspot without an Internet connection. You can configure everything through this hotspot. And, as Dave mentioned, there is a local NTRIP caster feature. It allows using Reach as a base for Autel drone if there is no Internet on a site at all.

4 Likes

Svetlana, I’m following up on your summary to confirm that I don’t need to make the emlid reach R2S internet-capable to operate the autel evo drone as a local NTRIP? I set up the evo rtk settings to match the emlid ntrip settings and continue to get the autel evo warning that there’s no RTK connection.

You can connect the drone and base through a wireless router or directly to the Wi-Fi hotspot of the RS2 itself. Make sure to enter your base point or use a single averaged point and document it in case you need to come back.

1 Like

Hi @kenforestry,

Yes. The local NTRIP feature is needed exactly for cases when you can’t provide devices with the Internet.

2 Likes

Your Evo Smart Controller must first be connected to the same wifi network as the Emlid receiver. Then, in the Evo’s RTK settings, you enter the credentials presented by the Emlid receiver for Base Output>Local NTRIP

Note that your IP will be similar but different than the screenshot.

2 Likes

Just wanted add to Dave’s helpful advice, is to click on the little “i” icon to the right of the Local NTRIP selection to access the setup info for input into the Autel’s controller.

1 Like

I followed the above procedures to match the emlid’s local ntrip setttings on the evo, prior to this exchange, but I’m still getting the no rtk connection on the evo, even tho within the evo rtk settings I get a successful connection message. Dave Pitman suggested that the evo’s smart controller must be connected to the same wifi network as the emlid. I don’t know how to do this. I thought matching the emlid ntrip settings accomplished this. I don’t know what settings, besides the evo RTK collection settings makes the wifi connection

" I don’t know what settings, besides the evo RTK collection settings makes the wifi connection"

Hi Ken, that’s an easy fix. Simply boot up the Autel Controller, swipe up to unlock the screen. You will then be in the Autel home screen. Next, to get to the Android home screen, swipe up from the very bottom and you will see three icons at the bottom. Tap the center icon and that will take you the home screen with the settings icon. Tap settings to get to the WiFi page and you will see your network. If not, scroll all the way down to add a network.
I included a couple of screen shots.


1 Like

Mark, Thank for that great how-to replay, inc captures; I need that to resolve this problem. I followed your instructions; I can’t find that same-looking home page. To complicate matters, I’m using an IPHONE. the phone wifi settings are connected to the emlid, but I note a warning that the emlid setting is not connected to the internet. I can’t find a screen or get to where I can create a network, within the autel explorer app; just the RTK settings page, which shows a successful connection to the emlid. My question remains: does the emlid have to have an internet connection in addition to broadcasting a wifi signal to the autel explorer app?

What controller do you have?

1 Like

Gotcha. I wonder if you both have the same version… I know the Smart Controller UI looks nothing like that.

Michael, I recently purchased the Autel Robotics EVO II Pro 6K Enterprise Rugged
Bundle V2 with the RTK accessory module directly from Autelpilot and it came with the 7.9" Smart Controller. I don’t know why it differs from your Smart Controller UI. The screen that is shown above is the Home Page of the Android Screen.
The screen below is one of the home page of the Autel screen. It has about a dozen different backgrounds that it rotates through.



Ken, Ok, I was thrown at first by the picture of the back of the unit and not seeing the front screen. But I see that you have the standard controller that comes with the Autel EVO RTK version and similar to the standard controller on my EVO II Pro v1. I guess I can’t read, as that is clearly stated in your title "Emlid with a Autel EVO RTK UAV" My mind just saw the Autel EVO RTK part and I assumed you were talking about Autel Robotics EVO II Pro 6K Enterprise version which comes with the larger integrated screen. So the setup might be different with that controller. The controller must have a WiFi setup page, because how else would you setup an NTRIP connection with it? Through Bluetooth?

I’m going to try this weekend connecting directly with Emlid WiFi only and not through a hotspot like I have been doing. I’ll let you how it goes, even though it is a different controller.

Mark, my work partner and I tried again, this afternoon, to connect the emlid to the evo controller via his android phone. We don’t get the same home screen with his android as your screen capture. I tried, unsuccessfully, earlier today using my iphone. We’ve verified that the local ntrip settings, reach3, match in the explorer app. In fact, explorer rtk indicates a successful connection, but, we noticed, that the connection is to “Autel Evo”, not emlid, and we continue to get the rtk not connected message on the main screen of the explorer app, preventing arming. When we check the wifi settings on the phones we note a “not connected to internet” and hotspot is noted as ON in his android reach settings. There is a sim card port on the emlid; it appears to not have a sim card installed. I want to know if you can get the autel to arm without an internet connection [wifi only from the emlid to the autel]. Check your emlid to deter if it has a sim card installed; maybe they failed to install an internet sim card in our new emlid Reach2S+?