Emlid tool. "ms5611: failed. is the barometer covered with a foam"

Hello and thank you for reading.

Just upgraded to your Stretch build.

When running the emlid tool the test section says “ms5611: failed. is the barometer covered with a foam”

Which is yes because that is what the docs suggested. Question is though I changed my UAV from a quad copter to a drone. The autopilot is in a housing inside the body of the plane. Is it neccesary to still have the peace of foam

I just removed the peace of foam and I still get the same error message

OK so it looks like my Onboard Barometer is no functioning as it should.

My altutide readings jump from -20000 to + 4000. Can I disable it? or do i need to get another board?

Its very important to cover it with a piece of open cell foam.

It is covered with a peace of foam and it is giving me an error

Have you tried taking the unit out of the housing/plane and see if it still produce error?
Do you have a picture of the navio showing the foam?

Edit: Also similar issue

And some more tips to check out

It gives me the same error with or without the foam.

But it is a bit confusing because when I calibrate the sensor using Qgroundcontrol it tells me that everything was calibrated successfully. There is a little error screen though that gives warning that says pressure differential

Keep in mind that the navio+raspberry is inside a 3d printed case inside the body of my quad plane so it is completely isolated.

I had the same piece of foam over the barometer in my quad and never got that message

Did it ever work? (before you updated to stretch)
Is the casing ventilated?
Other then that, failure is always an option. Some other tech dude might have a better throuble shooting tip…?

Yes it was working perfectly. However previous version that I had was not the build with the new Emlid tool.

Observation I made was that With the GPS attached the Alt reading would be stable but without it the alt reading would fluctuate

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.